aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-04-29 07:14:37 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-05-01 17:55:55 +0000
commit6707a3c942b51ab3e3cf110383e3119dfe2e49b0 (patch)
treebd3221fe24dd880cfb3169fd2241e74ff7f78bed
parent51abee5375fe25f7ef6a69d7d2800ca935ca1827 (diff)
downloadports-6707a3c942b51ab3e3cf110383e3119dfe2e49b0.tar.gz
ports-6707a3c942b51ab3e3cf110383e3119dfe2e49b0.zip
Clean up some things
- Fix typos - Remove duplicate variables - Remove nop variables - Clean up commented PORTREVISION - Add missing USES Reported by: portscan
-rw-r--r--audio/faudio/Makefile2
-rw-r--r--audio/faustlive/Makefile2
-rw-r--r--biology/jalview/Makefile2
-rw-r--r--cad/calculix-ccx/Makefile2
-rw-r--r--cad/tkgate/Makefile2
-rw-r--r--deskutils/copyq/Makefile5
-rw-r--r--devel/arcanist-lib/Makefile2
-rw-r--r--devel/cl-cffi/Makefile1
-rw-r--r--devel/ice37/Makefile1
-rw-r--r--devel/libspice-server/Makefile2
-rw-r--r--devel/sonarqube-community/Makefile2
-rw-r--r--dns/maradns/Makefile1
-rw-r--r--games/black-hole-solver/Makefile2
-rw-r--r--games/dose-response/Makefile2
-rw-r--r--graphics/feh/Makefile1
-rw-r--r--graphics/ksnip/Makefile2
-rw-r--r--graphics/osg/Makefile2
-rw-r--r--graphics/rawtherapee/Makefile2
-rw-r--r--graphics/wayland/Makefile2
-rw-r--r--japanese/scim-anthy/Makefile2
-rw-r--r--lang/c/Makefile1
-rw-r--r--lang/squeak/Makefile1
-rw-r--r--lang/swi-pl/Makefile7
-rw-r--r--lang/v8/Makefile2
-rw-r--r--mail/cyrus-imapd34/Makefile2
-rw-r--r--multimedia/avidemux/Makefile.common2
-rw-r--r--multimedia/kodi-addon-visualization.shadertoy/Makefile2
-rw-r--r--multimedia/kodi-addon-visualization.spectrum/Makefile2
-rw-r--r--multimedia/librespot/Makefile2
-rw-r--r--multimedia/libxine/Makefile1
-rw-r--r--multimedia/olive/Makefile2
-rw-r--r--net-im/openfire/Makefile1
-rw-r--r--net-im/qxmpp-qt5/Makefile2
-rw-r--r--net/glusterfs/Makefile1
-rw-r--r--net/py-qt5-networkauth/Makefile2
-rw-r--r--net/tigervnc-server/Makefile1
-rw-r--r--print/system-config-printer/Makefile4
-rw-r--r--science/vipster/Makefile2
-rw-r--r--sysutils/dsbmd/Makefile2
-rw-r--r--sysutils/slurm-wlm/Makefile1
-rw-r--r--sysutils/xbattbar/Makefile2
-rw-r--r--textproc/randlm/Makefile1
-rw-r--r--www/deno/Makefile2
-rw-r--r--www/foswiki/Makefile1
-rw-r--r--www/mod_auth_mellon/Makefile3
-rw-r--r--x11/keynav/Makefile2
-rw-r--r--x11/wezterm/Makefile1
47 files changed, 35 insertions, 56 deletions
diff --git a/audio/faudio/Makefile b/audio/faudio/Makefile
index 27117c1ca7c3..09894023a561 100644
--- a/audio/faudio/Makefile
+++ b/audio/faudio/Makefile
@@ -21,7 +21,7 @@ OPTIONS_DEFAULT= GSTREAMER
GSTREAMER_DESC= WMA/XMA support via GStreamer
-GSTREAMER_USES= gettext-runtime pkgconfig
+GSTREAMER_USES= gettext-runtime gnome pkgconfig
GSTREAMER_USE= GNOME=glib20 \
GSTREAMER1=yes
GSTREAMER_CMAKE_BOOL= GSTREAMER
diff --git a/audio/faustlive/Makefile b/audio/faustlive/Makefile
index 1fcf6436278a..81ed0b32b2ac 100644
--- a/audio/faustlive/Makefile
+++ b/audio/faustlive/Makefile
@@ -26,8 +26,6 @@ USE_GITHUB= yes
GH_ACCOUNT= grame-cncm
GH_TUPLE= grame-cncm:faustlibraries:cde5c7b:grame_cncm_faustlibraries/Resources/Libs
-CMAKE_SOURCE_PATH= ${WRKSRC}/package
-
SHEBANG_GLOB= build install makelibs
LLVM_VERSION= 11 # llvm version should be the same as in audio/faust
diff --git a/biology/jalview/Makefile b/biology/jalview/Makefile
index f99bd8d81676..e9159ecb079b 100644
--- a/biology/jalview/Makefile
+++ b/biology/jalview/Makefile
@@ -6,8 +6,6 @@ CATEGORIES= biology java
MASTER_SITES= https://www.jalview.org/source/
DISTNAME= ${PORTNAME}_${DISTVERSION:S/./_/g}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
-EXTRACT_ONLY= ${PORTNAME}_${DISTVERSION:S/./_/g}${EXTRACT_SUFX}
-
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= yuri@FreeBSD.org
diff --git a/cad/calculix-ccx/Makefile b/cad/calculix-ccx/Makefile
index 8a2d86d84be5..c5733de025f5 100644
--- a/cad/calculix-ccx/Makefile
+++ b/cad/calculix-ccx/Makefile
@@ -18,7 +18,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libarpack.so:math/arpack-ng \
libspooles.so:math/spooles
-USES= blaslapack compiler:openmp fortran gmake tar:bzip2
+USES= blaslapack compiler:openmp fortran gmake perl5 tar:bzip2
USE_PERL5= build
DIST_SOURCES= ccx_${PORTVERSION}.src${EXTRACT_SUFX}
diff --git a/cad/tkgate/Makefile b/cad/tkgate/Makefile
index 004a2edb0178..f8ff452952a9 100644
--- a/cad/tkgate/Makefile
+++ b/cad/tkgate/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= autoreconf gnome iconv:translit libtool pkgconfig tk
+USES= autoreconf gnome iconv:translit libtool pkgconfig tk xorg
USE_XORG= x11 xft
USE_GNOME= pango
diff --git a/deskutils/copyq/Makefile b/deskutils/copyq/Makefile
index cdebec1315ef..3e2de234663e 100644
--- a/deskutils/copyq/Makefile
+++ b/deskutils/copyq/Makefile
@@ -11,10 +11,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/share/ECM/cmake/ECMConfig.cmake:devel/kf5-extra-cmake-modules
-LIB_DEPENDS= libKF5Notifications.so.5:devel/kf5-knotifications \
- libwayland-client.so:graphics/wayland
+LIB_DEPENDS= libwayland-client.so:graphics/wayland
-USES= cmake compiler:c++11-lang qt:5 xorg
+USES= cmake compiler:c++11-lang kde:5 qt:5 xorg
USE_GITHUB= yes
GH_ACCOUNT= hluk
GH_PROJECT= CopyQ
diff --git a/devel/arcanist-lib/Makefile b/devel/arcanist-lib/Makefile
index b30be6df513b..b73e2d8f8a7d 100644
--- a/devel/arcanist-lib/Makefile
+++ b/devel/arcanist-lib/Makefile
@@ -45,8 +45,6 @@ ENCODINGS_USE= PHP=mbstring
RUN_DEPENDS= arcanist-lib${PHP_PKGNAMESUFFIX}>0:devel/arcanist-lib@${PHP_FLAVOR}
-NO_BUILD= yes
-
CONFLICTS= arc
PLIST_FILES= bin/arc
diff --git a/devel/cl-cffi/Makefile b/devel/cl-cffi/Makefile
index ecadc0fcf7ca..a665ec0fb00f 100644
--- a/devel/cl-cffi/Makefile
+++ b/devel/cl-cffi/Makefile
@@ -27,7 +27,6 @@ BUILD_DEPENDS= cl-alexandria>=0:devel/cl-alexandria \
RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_BUILD= yes
-NO_ARCH= yes
USE_ASDF= yes
diff --git a/devel/ice37/Makefile b/devel/ice37/Makefile
index 5b7835011cc2..5547efb53727 100644
--- a/devel/ice37/Makefile
+++ b/devel/ice37/Makefile
@@ -33,7 +33,6 @@ OPTIONS_DEFINE?= DEBUG STATIC TEST
OPTIONS_SUB= yes
USES+= compiler:c++14-lang iconv gmake
-CONFIGS= shared
DEBUG_MAKE_ENV= OPTIMIZE=no
TEST_ALL_TARGET_OFF= srcs
MAKE_ARGS+= V=1
diff --git a/devel/libspice-server/Makefile b/devel/libspice-server/Makefile
index 2ffe3d4747ff..55ad990f7b30 100644
--- a/devel/libspice-server/Makefile
+++ b/devel/libspice-server/Makefile
@@ -32,7 +32,7 @@ SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
STATISTICS_CONFIGURE_ENABLE= statistics
-USES= autoreconf compiler:c++11-lang gmake gnome jpeg libtool \
+USES= autoreconf compiler:c++11-lang cpe gmake gnome jpeg libtool \
localbase:ldflag pkgconfig python ssl tar:bzip2 xorg
USE_GNOME= glib20
diff --git a/devel/sonarqube-community/Makefile b/devel/sonarqube-community/Makefile
index e2bd0d34eaea..1c0415e16009 100644
--- a/devel/sonarqube-community/Makefile
+++ b/devel/sonarqube-community/Makefile
@@ -29,7 +29,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= bash:shells/bash #\
#jna>0:devel/jna
-USES= shebangfix zip
+USES= cpe shebangfix zip
CPE_VENDOR= sonarsource
USE_JAVA= yes
diff --git a/dns/maradns/Makefile b/dns/maradns/Makefile
index 3e9524e9959d..7266c158d47e 100644
--- a/dns/maradns/Makefile
+++ b/dns/maradns/Makefile
@@ -16,7 +16,6 @@ USE_RC_SUBR= ${PORTNAME} zoneserver Deadwood
USERS= bind
GROUPS= bind
INSTALL_TARGET= install PREFIX=${STAGEDIR}${PREFIX}
-SHEBANG_FILES= tools/bind2csv2.py
HAS_CONFIGURE= yes
OPTIONS_DEFINE= IPV6 DOCS EXAMPLES
diff --git a/games/black-hole-solver/Makefile b/games/black-hole-solver/Makefile
index a325d56ca115..119e5d44e121 100644
--- a/games/black-hole-solver/Makefile
+++ b/games/black-hole-solver/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= rinutils>0:devel/rinutils \
p5-Path-Tiny>=0:devel/p5-Path-Tiny
-USES= cmake compiler:c11 python:build tar:xz
+USES= cmake compiler:c11 perl5 python:build tar:xz
USE_PERL5= build
BINARY_ALIAS= python3=${PYTHON_CMD}
diff --git a/games/dose-response/Makefile b/games/dose-response/Makefile
index f8920453fb8a..f4ce93526ed8 100644
--- a/games/dose-response/Makefile
+++ b/games/dose-response/Makefile
@@ -10,7 +10,7 @@ COMMENT= Open-world roguelike game where you play an addict
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING.txt
-USES= cargo gnome
+USES= cargo gnome sdl
USE_SDL= sdl2
USE_GITHUB= yes
GH_ACCOUNT= tryjumping
diff --git a/graphics/feh/Makefile b/graphics/feh/Makefile
index 6e6ab02553be..8973295db4e9 100644
--- a/graphics/feh/Makefile
+++ b/graphics/feh/Makefile
@@ -18,7 +18,6 @@ LIB_DEPENDS= libImlib2.so:graphics/imlib2 \
USES= compiler:c++11-lang cpe desktop-file-utils gmake localbase:ldflags \
tar:bzip2 xorg
USE_XORG= x11 xt xinerama
-USE_PERL5= run
CPE_VENDOR= daniel_friesel
MAKE_ENV+= LDFLAGS="${LDFLAGS}" verscmp=0
diff --git a/graphics/ksnip/Makefile b/graphics/ksnip/Makefile
index c1879676d7d5..263f74950727 100644
--- a/graphics/ksnip/Makefile
+++ b/graphics/ksnip/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libkColorPicker.so:graphics/kcolorpicker \
libkImageAnnotator.so:graphics/kimageannotator
-USES= cmake compiler:c++11-lang kde:5 qt:5
+USES= cmake compiler:c++11-lang kde:5 qt:5 xorg
USE_GITHUB= yes
GH_ACCOUNT= ksnip
USE_KDE= ecm_build
diff --git a/graphics/osg/Makefile b/graphics/osg/Makefile
index f23a6b01d0c7..9c419d036357 100644
--- a/graphics/osg/Makefile
+++ b/graphics/osg/Makefile
@@ -93,9 +93,11 @@ OPENEXR_LIB_DEPENDS= libOpenEXR.so:graphics/openexr libImath.so:math/Imath
OPENEXR_VARS= FORCE_REQUIRE+=OpenEXR
OPENEXR_VARS_OFF= FORCE_IGNORE+=OpenEXR
PDF_LIB_DEPENDS= libpoppler-glib.so:graphics/poppler-glib
+PDF_USES= gnome
PDF_USE= GNOME=cairo
PDF_VARS= FORCE_REQUIRE+=Poppler-glib
PDF_VARS_OFF= FORCE_IGNORE+=Poppler-glib
+SDL_USES= sdl
SDL_USE= SDL=sdl
SDL_VARS= FORCE_REQUIRE+=SDL
SDL_VARS_OFF= FORCE_IGNORE+=SDL
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index 13005de649cb..9a36e086d945 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -30,8 +30,6 @@ LIB_DEPENDS= \
USES= cmake desktop-file-utils compiler:gcc-c++11-lib gnome \
jpeg localbase:ldflags pkgconfig tar:xz
-DOS2UNIX_REGEX= .*\.(cc|h)
-
# Binutils required for LTO (base ar/nm/ld/ranlib don't work)
USE_BINUTILS= yes
diff --git a/graphics/wayland/Makefile b/graphics/wayland/Makefile
index adaf4cc8f1fa..fda3cb475ca2 100644
--- a/graphics/wayland/Makefile
+++ b/graphics/wayland/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
CFLAGS+= "-I${LOCALBASE}/include/libepoll-shim"
-USES= meson pkgconfig tar:xz
+USES= gnome meson pkgconfig tar:xz
USE_GNOME= libxslt:build
USE_LDCONFIG= yes
MESON_ARGS= -Ddocumentation=false
diff --git a/japanese/scim-anthy/Makefile b/japanese/scim-anthy/Makefile
index 668ff07b47b4..c8b9cb81b914 100644
--- a/japanese/scim-anthy/Makefile
+++ b/japanese/scim-anthy/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libanthy.so:japanese/anthy \
RUN_DEPENDS:= ${BUILD_DEPENDS} \
kasumi:japanese/kasumi
-USES= gettext-runtime gmake iconv libtool:keepla pkgconfig
+USES= gettext-runtime gmake gnome iconv libtool:keepla pkgconfig
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk20 pango
GNU_CONFIGURE= yes
diff --git a/lang/c/Makefile b/lang/c/Makefile
index fdbf0615d386..a360ba324894 100644
--- a/lang/c/Makefile
+++ b/lang/c/Makefile
@@ -12,7 +12,6 @@ RUN_DEPENDS= bash:shells/bash
USE_GITHUB= yes
GH_ACCOUNT= ryanmjacobs
-SHEBANG_FILES= c
NO_ARCH= yes
NO_BUILD= yes
diff --git a/lang/squeak/Makefile b/lang/squeak/Makefile
index c7c1371424ff..f7631ecd0a4a 100644
--- a/lang/squeak/Makefile
+++ b/lang/squeak/Makefile
@@ -45,7 +45,6 @@ IMAGE_FULL_VERSION= ${IMAGE_VERSION}-${IMAGE_SVN_VERSION}
SQUEAK_SRC= SqueakV46.sources
SQUEAK_LIB_DIR= ${PORTVERSION}-${SVN_VERSION}
-CMAKE_SOURCE_PATH= unix
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= unix/cmake/configure
CONFIGURE_ARGS= --prefix=${PREFIX}
diff --git a/lang/swi-pl/Makefile b/lang/swi-pl/Makefile
index f834e60d6f34..7b69c88965fa 100644
--- a/lang/swi-pl/Makefile
+++ b/lang/swi-pl/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libpcre.so:devel/pcre \
libyaml.so:textproc/libyaml
USES= cmake compiler:c11 libarchive libedit pathfix pkgconfig \
- readline shebangfix ssl
+ readline shebangfix ssl xorg
USE_XORG= ice sm x11 xext xft xinerama xpm xt
OPTIONS_DEFINE= DOCS TCMALLOC EXAMPLES XPCE GMP THREADED ODBC
@@ -43,9 +43,8 @@ XPCE_DESC= Install XPCE graphical support
XPCE_CMAKE_ON= -DSWIPL_PACKAGES_X=ON
XPCE_CMAKE_OFF= -DSWIPL_PACKAGES_X=OFF
XPCE_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2 \
- libjpeg.so:graphics/jpeg-turbo
-XCPE_USES= jpeg xorg
+ libfreetype.so:print/freetype2
+XPCE_USES= jpeg
GMP_DESC= Enable bignum and rational numbers
GMP_CMAKE_ON= -DUSE_GMP=ON
diff --git a/lang/v8/Makefile b/lang/v8/Makefile
index 51f85fb3577d..1900cca003da 100644
--- a/lang/v8/Makefile
+++ b/lang/v8/Makefile
@@ -46,7 +46,7 @@ BUILD_DEPENDS= binutils>0:devel/binutils \
libunwind>0:devel/libunwind
LIB_DEPENDS= libicudata.so:devel/icu
-USES= pkgconfig ninja python:3.5+,build tar:xz
+USES= gnome ninja pkgconfig python:3.5+,build tar:xz
USE_GITHUB= yes
USE_LDCONFIG= yes
USE_GNOME= glib20
diff --git a/mail/cyrus-imapd34/Makefile b/mail/cyrus-imapd34/Makefile
index c136c5dd15d1..7a8f7c1c60db 100644
--- a/mail/cyrus-imapd34/Makefile
+++ b/mail/cyrus-imapd34/Makefile
@@ -1,6 +1,6 @@
PORTNAME= cyrus-imapd
PORTVERSION= 3.4.0
-#PORTREVISION= 0
+PORTREVISION= 0
CATEGORIES= mail
MASTER_SITES= https://github.com/cyrusimap/cyrus-imapd/releases/download/${PORTNAME}-${PORTVERSION}/
PKGNAMESUFFIX= 34
diff --git a/multimedia/avidemux/Makefile.common b/multimedia/avidemux/Makefile.common
index d1be0f0cbe79..8422a0be5659 100644
--- a/multimedia/avidemux/Makefile.common
+++ b/multimedia/avidemux/Makefile.common
@@ -15,7 +15,7 @@ USE_GNOME= libxml2
OPTIONS_FILE= ${PORT_DBDIR}/${OPTIONS_NAME:C/-.*//}/options
USES= cmake:noninja pkgconfig iconv gmake compiler:features sqlite
-USES+= dos2unix
+USES+= dos2unix gnome
DOS2UNIX_FILES= cmake/admCheckMiscLibs.cmake \
avidemux_core/ADM_coreVideoCodec/include/ADM_coreVideoCodec6_export.h \
avidemux_core/ADM_coreVideoCodec/include/ADM_ffmp43.h
diff --git a/multimedia/kodi-addon-visualization.shadertoy/Makefile b/multimedia/kodi-addon-visualization.shadertoy/Makefile
index a23f70a03096..aac61bc752e3 100644
--- a/multimedia/kodi-addon-visualization.shadertoy/Makefile
+++ b/multimedia/kodi-addon-visualization.shadertoy/Makefile
@@ -12,7 +12,7 @@ LICENSE= GPLv2+
BUILD_DEPENDS= glm>0:math/glm
-USES= cmake localbase compiler:c++14-lang kodi
+USES= cmake compiler:c++14-lang gl kodi localbase
USE_CXXSTD= c++14
USE_GITHUB= yes
GH_ACCOUNT= xbmc
diff --git a/multimedia/kodi-addon-visualization.spectrum/Makefile b/multimedia/kodi-addon-visualization.spectrum/Makefile
index 9c7d8fc142a0..e98c1e432ccd 100644
--- a/multimedia/kodi-addon-visualization.spectrum/Makefile
+++ b/multimedia/kodi-addon-visualization.spectrum/Makefile
@@ -12,7 +12,7 @@ LICENSE= GPLv2+
BUILD_DEPENDS= glm>0:math/glm
-USES= cmake localbase compiler:c++14-lang kodi
+USES= cmake compiler:c++14-lang gl kodi localbase
USE_CXXSTD= c++14
USE_GITHUB= yes
GH_ACCOUNT= xbmc
diff --git a/multimedia/librespot/Makefile b/multimedia/librespot/Makefile
index d2db17e2feac..1e0d82bd4253 100644
--- a/multimedia/librespot/Makefile
+++ b/multimedia/librespot/Makefile
@@ -27,6 +27,7 @@ ALSA_DESC= Rodio audio backend using ALSA
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
ALSA_VARS= CARGO_FEATURES+=rodio-backend
+GSTREAMER_USES= gnome
GSTREAMER_USE= GNOME=glib20 \
GSTREAMER1=yes
GSTREAMER_VARS= CARGO_FEATURES+=gstreamer-backend
@@ -36,6 +37,7 @@ PORTAUDIO_LIB_DEPENDS= libportaudio.so:audio/portaudio
PORTAUDIO_VARS= CARGO_FEATURES+=portaudio-backend
PULSEAUDIO_LIB_DEPENDS= libpulse-simple.so:audio/pulseaudio
PULSEAUDIO_VARS= CARGO_FEATURES+=pulseaudio-backend
+SDL_USES= sdl
SDL_USE= SDL=sdl2
SDL_VARS= CARGO_FEATURES+=sdl-backend
TREMOR_LIB_DEPENDS= libvorbisidec.so:audio/libtremor
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 835e95a4dd18..cf64aa1ee5c3 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -124,6 +124,7 @@ PIXBUF_USE= GNOME=gdkpixbuf2,glib20
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_CONFIGURE_WITH= pulseaudio
SDL_CONFIGURE_WITH= sdl
+SDL_USES= sdl
SDL_USE= SDL=sdl
SFTP_LIB_DEPENDS= libssh2.so:security/libssh2
SFTP_CONFIGURE_ENABLE= sftp
diff --git a/multimedia/olive/Makefile b/multimedia/olive/Makefile
index f680189d7100..1ce1e67e7081 100644
--- a/multimedia/olive/Makefile
+++ b/multimedia/olive/Makefile
@@ -23,8 +23,6 @@ DOS2UNIX_FILES= olive.pro \
USE_QT= core gui multimedia network opengl svg widgets buildtools_build linguisttools_build
USE_GL= gl
-CMAKE_ARGS= -DGIT_HASH:STRING=NoGitHashVersion${DISTVERSION}
-
DATADIR= ${PREFIX}/share/olive-editor
PORTSCOUT= limit:^.*[1-9]\..* # prevent tags like 20181223
diff --git a/net-im/openfire/Makefile b/net-im/openfire/Makefile
index ded4cafe1279..2af0f285b8ec 100644
--- a/net-im/openfire/Makefile
+++ b/net-im/openfire/Makefile
@@ -25,6 +25,7 @@ ONLINE_M2_DESC= Download last plugins during build process (into ~/.m2)
OPTIONS_DEFAULT= LOCAL_M2
LOCAL_M2_DISTFILES= FreeBSD-${PORTNAME}-${PORTVERSION}-maven-repository.tar.gz:maven
+USES= cpe
USE_JAVA= yes
JAVA_VERSION= 1.8+
NO_ARCH= yes
diff --git a/net-im/qxmpp-qt5/Makefile b/net-im/qxmpp-qt5/Makefile
index 670fe4fed35c..81e750f66fb8 100644
--- a/net-im/qxmpp-qt5/Makefile
+++ b/net-im/qxmpp-qt5/Makefile
@@ -14,8 +14,6 @@ USES= cmake compiler:c++17-lang libtool pathfix pkgconfig qt:5
USE_QT= core gui network xml \
buildtools_build qmake_build testlib_build
-QMAKE_ARGS= QXMPP_NO_TESTS=1
-
USE_GITHUB= yes
GH_ACCOUNT= qxmpp-project
diff --git a/net/glusterfs/Makefile b/net/glusterfs/Makefile
index f8894349b727..b4580b9fbb42 100644
--- a/net/glusterfs/Makefile
+++ b/net/glusterfs/Makefile
@@ -67,7 +67,6 @@ LDFLAGS+= -L"${LOCALBASE}/lib" -largp
INSTALL_TARGET= install-strip
PLIST_SUB= GLUSTERLIBDIR="lib/${PORTNAME}" \
PORTVERSION="${PORTVERSION}"
-KMODDIR?= /boot/modules
OPTIONS_DEFINE= DOCS
diff --git a/net/py-qt5-networkauth/Makefile b/net/py-qt5-networkauth/Makefile
index be07c78a8f7e..23cf1a8af5fb 100644
--- a/net/py-qt5-networkauth/Makefile
+++ b/net/py-qt5-networkauth/Makefile
@@ -8,7 +8,7 @@ DISTNAME= ${PYQTNETWORKAUTH_DISTNAME}
MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for the Qt5 toolkit, QtNetworkAuth module
-USES= python:3.5+ pyqt:5 qt:5
+USES= gl pyqt:5 python:3.5+ qt:5
USE_PYQT= sip_build core gui network widgets
USE_PYTHON= concurrent flavors py3kplist
USE_QT= core gui network networkauth qmake_build
diff --git a/net/tigervnc-server/Makefile b/net/tigervnc-server/Makefile
index 0ee2ea56b476..c0e1a3b99f92 100644
--- a/net/tigervnc-server/Makefile
+++ b/net/tigervnc-server/Makefile
@@ -1,6 +1,5 @@
PORTREVISION= 1
PKGNAMESUFFIX= -server
-CATEGORIES= net x11-servers
COMMENT= TigerVNC Server
diff --git a/print/system-config-printer/Makefile b/print/system-config-printer/Makefile
index 6535af9a73d5..5312af6a1d12 100644
--- a/print/system-config-printer/Makefile
+++ b/print/system-config-printer/Makefile
@@ -21,8 +21,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${PY_FLAVOR} \
PORTSCOUT= limitw:1,even
GNU_CONFIGURE= yes
-USES= autoreconf desktop-file-utils gettext gmake pathfix pkgconfig python:3.5+ \
- shebangfix tar:xz
+USES= autoreconf desktop-file-utils gettext gmake gnome pathfix \
+ pkgconfig python:3.5+ shebangfix tar:xz
USE_GITHUB= yes
GH_ACCOUNT= OpenPrinting
diff --git a/science/vipster/Makefile b/science/vipster/Makefile
index b2a38bcd2fab..0dd52964ee43 100644
--- a/science/vipster/Makefile
+++ b/science/vipster/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= catch>0:devel/catch \
libfmt>0:devel/libfmt \
nlohmann-json>0:devel/nlohmann-json
-USES= cmake compiler:c++17-lang
+USES= cmake compiler:c++17-lang gl
USE_GL= gl
USE_LDCONFIG= yes
diff --git a/sysutils/dsbmd/Makefile b/sysutils/dsbmd/Makefile
index c8fdf946afff..b0b351af2b9c 100644
--- a/sysutils/dsbmd/Makefile
+++ b/sysutils/dsbmd/Makefile
@@ -18,8 +18,6 @@ USE_GITHUB= yes
GH_ACCOUNT= mrclksr
GH_PROJECT= DSBMD
-QMAKE_ARGS= PORTS=1
-
PLIST_FILES= "@sample etc/dsbmd.conf.sample" \
libexec/dsbmd
diff --git a/sysutils/slurm-wlm/Makefile b/sysutils/slurm-wlm/Makefile
index b32b3bb1f719..bec93eb0253f 100644
--- a/sysutils/slurm-wlm/Makefile
+++ b/sysutils/slurm-wlm/Makefile
@@ -22,7 +22,6 @@ LIB_DEPENDS= libjson-c.so:devel/json-c \
USES= compiler:c11 gmake gnome libtool localbase lua pkgconfig \
python:build readline:port shebangfix ssl tar:bz2
USE_LDCONFIG= yes
-USE_PERL5= configure
USE_RC_SUBR= slurmctld slurmd
USERS= slurm
diff --git a/sysutils/xbattbar/Makefile b/sysutils/xbattbar/Makefile
index 79428b8a1b2c..e1ecf448e7cf 100644
--- a/sysutils/xbattbar/Makefile
+++ b/sysutils/xbattbar/Makefile
@@ -16,7 +16,7 @@ COMMENT= Simple battery meter
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= imake
+USES= imake xorg
USE_XORG= x11 xext
WRKSRC= ${WRKDIR}/xbattbar-${PORTVERSION}
PLIST_FILES= bin/xbattbar \
diff --git a/textproc/randlm/Makefile b/textproc/randlm/Makefile
index c4ceac9021d3..08a7c11132fd 100644
--- a/textproc/randlm/Makefile
+++ b/textproc/randlm/Makefile
@@ -23,7 +23,6 @@ RUN_DEPENDS= ${LOCALBASE}/include/google/sparse_hash_map:devel/sparsehash
USES= autoreconf libtool localbase:ldflags compiler:c++11-lang
USE_CXXSTD= gnu++98
-USE_PERL5= run
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE=yes
diff --git a/www/deno/Makefile b/www/deno/Makefile
index 8d9f99ed6d57..ee1ec6f912f9 100644
--- a/www/deno/Makefile
+++ b/www/deno/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= binutils>0:devel/binutils \
gn:devel/gn \
libunwind>0:devel/libunwind
-USES= cargo ninja:build pkgconfig:build python:3.6+,build
+USES= cargo gnome ninja:build pkgconfig:build python:3.6+,build
USE_GITHUB= yes
GH_ACCOUNT= denoland
diff --git a/www/foswiki/Makefile b/www/foswiki/Makefile
index a22a2df03bae..c20b599a69f6 100644
--- a/www/foswiki/Makefile
+++ b/www/foswiki/Makefile
@@ -22,7 +22,6 @@ RUN_DEPENDS= p5-Error>=0.15:lang/p5-Error \
USES= cpe perl5 tar:tgz
-NO_BUILD= yes
NO_ARCH= yes
OPTIONS_DEFINE= OPTINT OPTOTH APACHE
diff --git a/www/mod_auth_mellon/Makefile b/www/mod_auth_mellon/Makefile
index 31713c47b1e4..18fa0dc08c11 100644
--- a/www/mod_auth_mellon/Makefile
+++ b/www/mod_auth_mellon/Makefile
@@ -15,7 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcurl.so:ftp/curl \
liblasso.so:security/lasso
-USES= apache:2.2+ autoreconf gettext-runtime gnome libtool pkgconfig ssl
+USES= apache:2.2+ autoreconf cpe gettext-runtime gnome libtool \
+ pkgconfig ssl
USE_GNOME= glib20
USE_GITHUB= yes
GH_ACCOUNT= latchset
diff --git a/x11/keynav/Makefile b/x11/keynav/Makefile
index a54916dbcb7c..54aa1d6506ff 100644
--- a/x11/keynav/Makefile
+++ b/x11/keynav/Makefile
@@ -11,7 +11,7 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LIB_DEPENDS= libxdo.so:x11/xdotool
-USES= gmake gnome pkgconfig
+USES= gmake gnome pkgconfig xorg
USE_GITHUB= yes
GH_ACCOUNT= jordansissel
GH_TAGNAME= 78f9e07
diff --git a/x11/wezterm/Makefile b/x11/wezterm/Makefile
index a702c8615dd0..afa9c6b18229 100644
--- a/x11/wezterm/Makefile
+++ b/x11/wezterm/Makefile
@@ -17,7 +17,6 @@ LIB_DEPENDS= libwayland-egl.so:graphics/wayland \
USES= cargo python:3.4+,build ssl xorg
USE_GITHUB= yes
-USE_PERL5= build
USE_XORG= x11 xcb
GH_ACCOUNT= wez
GH_TUPLE= harfbuzz:harfbuzz:2.7.2:harfbuzz/deps/harfbuzz/harfbuzz \