aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-10-11 12:58:07 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-10-11 12:58:07 +0000
commit672ab62bc4336f85330c88c1316c103b9c6df318 (patch)
tree4732883e64f7d49c5cb31a96cb2dca1f2a81267e
parentffd5a3b1c1139e25838cf43fdd00ed181f4c7ce6 (diff)
downloadports-672ab62bc4336f85330c88c1316c103b9c6df318.tar.gz
ports-672ab62bc4336f85330c88c1316c103b9c6df318.zip
graphics/py-pandana: Allow build with py-tables 3.9.0
-rw-r--r--graphics/py-pandana/Makefile4
-rw-r--r--graphics/py-pandana/files/patch-setup.py7
2 files changed, 6 insertions, 5 deletions
diff --git a/graphics/py-pandana/Makefile b/graphics/py-pandana/Makefile
index 036b01e41f4f..f9e40afb8bd6 100644
--- a/graphics/py-pandana/Makefile
+++ b/graphics/py-pandana/Makefile
@@ -1,6 +1,6 @@
PORTNAME= pandana
PORTVERSION= 0.6.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.8,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pandas>=0.17,1:math/py-pandas@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scikit-learn>=0.18:science/py-scikit-learn@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}tables>=3.1<3.8:devel/py-tables@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}tables>=3.1:devel/py-tables@${PY_FLAVOR}
USES= compiler:c++11-lang python
USE_PYTHON= autoplist concurrent cython distutils
diff --git a/graphics/py-pandana/files/patch-setup.py b/graphics/py-pandana/files/patch-setup.py
index 2425ffefde8c..1c91738d9cff 100644
--- a/graphics/py-pandana/files/patch-setup.py
+++ b/graphics/py-pandana/files/patch-setup.py
@@ -1,11 +1,12 @@
--- setup.py.orig 2021-03-17 16:44:15 UTC
+++ setup.py
-@@ -151,7 +151,7 @@ setup(
+@@ -150,8 +150,7 @@ setup(
+ 'pandas >=0.17',
'requests >=2.0',
'scikit-learn >=0.18',
- 'tables >=3.1, <3.6; python_version <"3.6"',
+- 'tables >=3.1, <3.6; python_version <"3.6"',
- 'tables >=3.1, <3.7; python_version >="3.6"'
-+ 'tables >=3.1, <3.8; python_version >="3.6"'
++ 'tables >=3.1',
],
cmdclass={
'test': PyTest,