aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2015-10-30 23:07:16 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2015-10-30 23:07:16 +0000
commit6752b25fda1854c4a118f87c2df760bf18c08af0 (patch)
tree35a5850dc171c61b03527223ba198474d871c4ab
parent7a21b5033d37d7dbbb5f0d60af6e8cd2ecfe56a0 (diff)
downloadports-6752b25fda1854c4a118f87c2df760bf18c08af0.tar.gz
ports-6752b25fda1854c4a118f87c2df760bf18c08af0.zip
- Fix creation of rc symlink in package
- Fix procname in rc script so it can 'stop' correctly. [1] Submitted by: Dirk Engling <erdgeist@erdgeist.org> [1]
Notes
Notes: svn path=/head/; revision=400559
-rw-r--r--mail/qmail-mysql/Makefile2
-rw-r--r--mail/qmail-spamcontrol/Makefile2
-rw-r--r--mail/qmail-tls/Makefile2
-rw-r--r--mail/qmail/Makefile4
-rw-r--r--mail/qmail/files/qmailsmtpd.in2
-rw-r--r--mail/qmail/pkg-plist1
6 files changed, 8 insertions, 5 deletions
diff --git a/mail/qmail-mysql/Makefile b/mail/qmail-mysql/Makefile
index 5f3a6e91ea36..bd318303199c 100644
--- a/mail/qmail-mysql/Makefile
+++ b/mail/qmail-mysql/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qmail
PORTVERSION= ${QMAIL_VERSION}.${MYSQL_PATCH_VERSION}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail
PKGNAMESUFFIX= -mysql
diff --git a/mail/qmail-spamcontrol/Makefile b/mail/qmail-spamcontrol/Makefile
index 04cc017c9dc0..b447739408bf 100644
--- a/mail/qmail-spamcontrol/Makefile
+++ b/mail/qmail-spamcontrol/Makefile
@@ -2,7 +2,7 @@
PORTNAME= qmail
PORTVERSION= ${QMAIL_VERSION}.${SPAMCONTROL_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES+= http://www.fehcom.de/qmail/spamcontrol/:spamcontrol \
LOCAL/bdrewery/qmail/:spamcontrol
diff --git a/mail/qmail-tls/Makefile b/mail/qmail-tls/Makefile
index dbf05ab82af4..36fc9de365c4 100644
--- a/mail/qmail-tls/Makefile
+++ b/mail/qmail-tls/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qmail
PORTVERSION= ${QMAIL_VERSION}.${TLS_PATCH_DATE}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail
PKGNAMESUFFIX= -tls
diff --git a/mail/qmail/Makefile b/mail/qmail/Makefile
index 911325a964ed..3d468e49ac0e 100644
--- a/mail/qmail/Makefile
+++ b/mail/qmail/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ${QMAIL_PORTNAME}
PORTVERSION?= ${QMAIL_VERSION}
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= mail
MASTER_SITES+= QMAIL
DISTNAME= ${PORTNAME}-${QMAIL_VERSION}
@@ -892,6 +892,8 @@ post-install:
${STAGEDIR}${PREFIX}/control/signatures.sample
@${FIND} ${WRKDIR} -type f -name run -exec ${SED} -i "" \
-e 's|${STAGEDIR}|${PREFIX}|' {} +
+.else
+ @${MKDIR} ${STAGEDIR}${LOCALBASE}/etc/rc.d
.endif
@${MKDIR} ${STAGEDIR}${LOCALBASE}/etc/man.d
${INSTALL_DATA} ${WRKDIR}/qmail.conf ${STAGEDIR}${LOCALBASE}/etc/man.d/qmail.conf
diff --git a/mail/qmail/files/qmailsmtpd.in b/mail/qmail/files/qmailsmtpd.in
index 936592127ef7..112b2cc4216d 100644
--- a/mail/qmail/files/qmailsmtpd.in
+++ b/mail/qmail/files/qmailsmtpd.in
@@ -36,7 +36,7 @@ load_rc_config $name
start_cmd=qmailsmtpd_start
start_precmd=qmailsmtpd_precmd
pidfile=${qmailsmtpd_pidfile}
-procname=${qmailsmtpd_tcprules}
+procname=${qmailsmtpd_tcpserver}
qmailsmtpd_start()
{
diff --git a/mail/qmail/pkg-plist b/mail/qmail/pkg-plist
index f6055bf77148..0dd708bb52d4 100644
--- a/mail/qmail/pkg-plist
+++ b/mail/qmail/pkg-plist
@@ -238,4 +238,5 @@ scripts/mkaliasdir
@cwd %%LOCALBASE%%
@dir etc/man.d
etc/man.d/qmail.conf
+%%RCDLINK%%@dir etc/rc.d
@cwd %%QMAIL_PREFIX%%