aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2023-08-01 17:01:19 +0000
committerJason E. Hale <jhale@FreeBSD.org>2023-08-01 17:52:33 +0000
commit677c88dc92150f20ebe494352fccb6c1e5a9197a (patch)
tree6df4c62b9217c44e852444fcd234029ec29aa9ac
parent37437d0243483245a23158242a6e3908339d8919 (diff)
downloadports-677c88dc92150f20ebe494352fccb6c1e5a9197a.tar.gz
ports-677c88dc92150f20ebe494352fccb6c1e5a9197a.zip
graphics/libxisf: New port
LibXISF is C++ library that can read and write XISF files produced by PixInsight. It implements the XISF 1.0 specification. https://gitea.nouspiro.space/nou/libXISF
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/libxisf/Makefile30
-rw-r--r--graphics/libxisf/distinfo3
-rw-r--r--graphics/libxisf/pkg-descr2
-rw-r--r--graphics/libxisf/pkg-plist6
5 files changed, 42 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 8b7975031b24..5e67a56dfe6a 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -521,6 +521,7 @@
SUBDIR += libwmf
SUBDIR += libwmf-nox11
SUBDIR += libwpg03
+ SUBDIR += libxisf
SUBDIR += libyuv
SUBDIR += libzmf
SUBDIR += lightzone
diff --git a/graphics/libxisf/Makefile b/graphics/libxisf/Makefile
new file mode 100644
index 000000000000..f645a2367cb2
--- /dev/null
+++ b/graphics/libxisf/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= libxisf
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.8
+CATEGORIES= graphics astro
+MASTER_SITES= https://gitea.nouspiro.space/nou/libXISF/archive/
+DISTNAME= ${DISTVERSIONPREFIX}${DISTVERSION}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= jhale@FreeBSD.org
+COMMENT= Library to read and write XISF files produced by PixInsight
+WWW= https://gitea.nouspiro.space/nou/libXISF
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= liblz4.so:archivers/liblz4 \
+ libpugixml.so:textproc/pugixml
+
+USES= cmake compiler:c++17-lang pkgconfig
+USE_LDCONFIG= yes
+
+CMAKE_OFF= USE_BUNDLED_LIBS
+
+TEST_TARGET= test
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PLIST_SUB= VERSION=${DISTVERSION}
+
+.include <bsd.port.mk>
diff --git a/graphics/libxisf/distinfo b/graphics/libxisf/distinfo
new file mode 100644
index 000000000000..93bc2fd0515d
--- /dev/null
+++ b/graphics/libxisf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1690907274
+SHA256 (libxisf/v0.2.8.tar.gz) = 7a48889629cd4c7ef77cd307dceb2a7d713231a71ff2dd65d9bf9a82352b61af
+SIZE (libxisf/v0.2.8.tar.gz) = 1610531
diff --git a/graphics/libxisf/pkg-descr b/graphics/libxisf/pkg-descr
new file mode 100644
index 000000000000..b0dab995cf1b
--- /dev/null
+++ b/graphics/libxisf/pkg-descr
@@ -0,0 +1,2 @@
+LibXISF is C++ library that can read and write XISF files produced by
+PixInsight. It implements the XISF 1.0 specification.
diff --git a/graphics/libxisf/pkg-plist b/graphics/libxisf/pkg-plist
new file mode 100644
index 000000000000..8789dd757ef6
--- /dev/null
+++ b/graphics/libxisf/pkg-plist
@@ -0,0 +1,6 @@
+include/libXISF_global.h
+include/libxisf.h
+lib/libXISF.so
+lib/libXISF.so.0
+lib/libXISF.so.%%VERSION%%
+libdata/pkgconfig/libxisf.pc