aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2022-11-22 14:25:31 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2022-11-22 14:31:11 +0000
commit677e3e510f57a9de977eef3fbec384304a02815f (patch)
tree284609f3c4c0736620486d3cddf9254e631be9f5
parent45aa58a4603d27197028533bb980cf55b6e55cbf (diff)
downloadports-677e3e510f57a9de977eef3fbec384304a02815f.tar.gz
ports-677e3e510f57a9de977eef3fbec384304a02815f.zip
devel/libgit2: Add python as a build dep to fix NINJA_DEFAULT=samurai
Normally, python is brought in from ninja. When NINJA_DEFAULT=samurai, that dependency is missing. -- Could NOT find PythonInterp (missing: PYTHON_EXECUTABLE) CMake Error at tests/libgit2/CMakeLists.txt:7 (message): Could not find a python interpreter, which is needed to build the tests. Make sure python is available, or pass -DBUILD_TESTS=OFF to skip building the tests Note that python is only used to build tests, so no PORTREVISION bump is needed here.
-rw-r--r--devel/libgit2/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/libgit2/Makefile b/devel/libgit2/Makefile
index 89f47924c907..c757c815352b 100644
--- a/devel/libgit2/Makefile
+++ b/devel/libgit2/Makefile
@@ -17,7 +17,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libpcre2-8.so:devel/pcre2 \
libhttp_parser.so:www/http-parser
-USES= cmake cpe pkgconfig ssl
+USES= cmake cpe pkgconfig python:build ssl
USE_GITHUB= yes
USE_LDCONFIG= yes