aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJuraj Lutter <otis@FreeBSD.org>2022-03-25 20:20:22 +0000
committerJuraj Lutter <otis@FreeBSD.org>2022-03-26 08:59:18 +0000
commit6804aa8f7c5ecbdc86095a7553a7e3acd2136098 (patch)
tree112f5ff4c7af96b36ea9ddd43ef2e929900c033f
parent247c7db7513f1264922428278678da641c5a3f52 (diff)
downloadports-6804aa8f7c5ecbdc86095a7553a7e3acd2136098.tar.gz
ports-6804aa8f7c5ecbdc86095a7553a7e3acd2136098.zip
mail/dovecot-fts-xapian: Update to 1.5.4
-rw-r--r--mail/dovecot-fts-xapian/Makefile12
-rw-r--r--mail/dovecot-fts-xapian/distinfo6
-rw-r--r--mail/dovecot-fts-xapian/files/patch-src_fts-backend-xapian.cpp13
3 files changed, 22 insertions, 9 deletions
diff --git a/mail/dovecot-fts-xapian/Makefile b/mail/dovecot-fts-xapian/Makefile
index ed04d5a34169..0756d855975c 100644
--- a/mail/dovecot-fts-xapian/Makefile
+++ b/mail/dovecot-fts-xapian/Makefile
@@ -1,10 +1,10 @@
PORTNAME= fts-xapian
-DISTVERSION= 1.5.1
-PORTREVISION= 1
+DISTVERSION= 1.5.4
+DISTVERSIONSUFFIX= b
CATEGORIES= mail
-MASTER_SITES= https://github.com/grosjo/fts-xapian/releases/download/${DISTVERSION}/
+MASTER_SITES= https://github.com/grosjo/fts-xapian/releases/download/${DISTVERSIONFULL}/
PKGNAMEPREFIX= dovecot-
-DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${DISTVERSION}
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${DISTVERSIONFULL}
MAINTAINER= otis@FreeBSD.org
COMMENT= Dovecot FTS plugin based on Xapian
@@ -16,11 +16,11 @@ LIB_DEPENDS= libicuuc.so:devel/icu \
libxapian.so:databases/xapian-core
RUN_DEPENDS= dovecot>=2.3.7:mail/dovecot
-USES= autoreconf compiler:c++11-lang libtool pkgconfig
+USES= autoreconf compiler:c++11-lang libtool pkgconfig sqlite
GNU_CONFIGURE= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSIONFULL}
PLIST_FILES= lib/dovecot/lib21_fts_xapian_plugin.a \
lib/dovecot/lib21_fts_xapian_plugin.so
diff --git a/mail/dovecot-fts-xapian/distinfo b/mail/dovecot-fts-xapian/distinfo
index e7e0d0262582..b49a38017d7d 100644
--- a/mail/dovecot-fts-xapian/distinfo
+++ b/mail/dovecot-fts-xapian/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1636662908
-SHA256 (dovecot-fts-xapian-1.5.1.tar.gz) = 12b610492849440b96fc8527a98cd537fe14465c4e618eacfd9651101e343f2e
-SIZE (dovecot-fts-xapian-1.5.1.tar.gz) = 2896670
+TIMESTAMP = 1648195324
+SHA256 (dovecot-fts-xapian-1.5.4b.tar.gz) = cfc60caade77aadc8441b971d2e49f7337033a1e83494163cd8abcd459c79f6d
+SIZE (dovecot-fts-xapian-1.5.4b.tar.gz) = 33138
diff --git a/mail/dovecot-fts-xapian/files/patch-src_fts-backend-xapian.cpp b/mail/dovecot-fts-xapian/files/patch-src_fts-backend-xapian.cpp
new file mode 100644
index 000000000000..bab0275d4914
--- /dev/null
+++ b/mail/dovecot-fts-xapian/files/patch-src_fts-backend-xapian.cpp
@@ -0,0 +1,13 @@
+Patch to silence a warning, until adopted by upstream (issue #101)
+
+--- src/fts-backend-xapian.cpp.orig 2022-03-25 21:16:29 UTC
++++ src/fts-backend-xapian.cpp
+@@ -750,7 +750,7 @@ struct fts_backend fts_backend_xapian =
+ {
+ .name = "xapian",
+ .flags = FTS_BACKEND_FLAG_BUILD_FULL_WORDS,
+- {
++ .v = {
+ fts_backend_xapian_alloc,
+ fts_backend_xapian_init,
+ fts_backend_xapian_deinit,