aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-10-11 12:53:37 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-10-11 12:53:37 +0000
commit686b8c12ee3e1a3faa20999c4b84974e1203b630 (patch)
tree2854dc478b4c59def3a090f43d76a8a0312c10ae
parentcda33f6c5d52e0d66ba3747f1bc8a1d890956afa (diff)
downloadports-686b8c12ee3e1a3faa20999c4b84974e1203b630.tar.gz
ports-686b8c12ee3e1a3faa20999c4b84974e1203b630.zip
devel/py-jupyter-collaboration: Add py-jupyter-collaboration 1.2.0
JupyterLab Real-Time Collaboration is a Jupyter Server Extension and JupyterLab extensions providing support for Y documents and adding collaboration UI elements in JupyterLab.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-jupyter-collaboration/Makefile32
-rw-r--r--devel/py-jupyter-collaboration/distinfo3
-rw-r--r--devel/py-jupyter-collaboration/pkg-descr3
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 766da3ec1c97..4e882221b9bf 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4892,6 +4892,7 @@
SUBDIR += py-jsonschema417
SUBDIR += py-jsonsir
SUBDIR += py-jupyter-client
+ SUBDIR += py-jupyter-collaboration
SUBDIR += py-jupyter-core
SUBDIR += py-jupyter-events
SUBDIR += py-jupyter-kernel-test
diff --git a/devel/py-jupyter-collaboration/Makefile b/devel/py-jupyter-collaboration/Makefile
new file mode 100644
index 000000000000..b4ccf7b8e10c
--- /dev/null
+++ b/devel/py-jupyter-collaboration/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= jupyter-collaboration
+PORTVERSION= 1.2.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= jupyter_collaboration-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= JupyterLab Extension enabling Real-Time Collaboration
+WWW= https://jupyterlab-realtime-collaboration.readthedocs.io/en/latest/ \
+ https://github.com/jupyterlab/jupyter-collaboration
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatch-jupyter-builder>=0.5:devel/py-hatch-jupyter-builder@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}hatch-nodejs-version>=0:devel/py-hatch-nodejs-version@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}hatchling>=1.4.0:devel/py-hatchling@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jupyterlab>=4.0.0:devel/py-jupyterlab@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>=4.18.0:devel/py-jsonschema@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jupyter-events>=0.7.0:devel/py-jupyter-events@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jupyter-server>=2.0.0<3.0.0:devel/py-jupyter-server@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jupyter-server-fileid>=0.7.0<1:devel/py-jupyter-server-fileid@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jupyter-ydoc>=1.0.1<2.0.0:devel/py-jupyter-ydoc@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ypy-websocket>=0.12.1<0.13.0:devel/py-ypy-websocket@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-jupyter-collaboration/distinfo b/devel/py-jupyter-collaboration/distinfo
new file mode 100644
index 000000000000..eccf6a0d16e9
--- /dev/null
+++ b/devel/py-jupyter-collaboration/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1696904096
+SHA256 (jupyter_collaboration-1.2.0.tar.gz) = aa17023c0807941c2df8bb7c35d0daf993e134da2d0af36dcfd590c7a387bce7
+SIZE (jupyter_collaboration-1.2.0.tar.gz) = 293971
diff --git a/devel/py-jupyter-collaboration/pkg-descr b/devel/py-jupyter-collaboration/pkg-descr
new file mode 100644
index 000000000000..75820ef4e806
--- /dev/null
+++ b/devel/py-jupyter-collaboration/pkg-descr
@@ -0,0 +1,3 @@
+JupyterLab Real-Time Collaboration is a Jupyter Server Extension and JupyterLab
+extensions providing support for Y documents and adding collaboration UI
+elements in JupyterLab.