aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-25 20:12:27 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-25 20:35:11 +0000
commit686f85208f178a98a420daa83785fd3a9dfae608 (patch)
tree2a41d96f492050bdabbff2ca3e7a6f6fe8762a58
parent87e9a560e9ce98a122ebcf201d047acf85168134 (diff)
downloadports-686f85208f178a98a420daa83785fd3a9dfae608.tar.gz
ports-686f85208f178a98a420daa83785fd3a9dfae608.zip
textproc/discount: Convert REINPLACE_CMD to patch file
-rw-r--r--textproc/discount/Makefile3
-rw-r--r--textproc/discount/files/patch-configure.inc10
2 files changed, 10 insertions, 3 deletions
diff --git a/textproc/discount/Makefile b/textproc/discount/Makefile
index 76f811f7ee52..73ddf971178e 100644
--- a/textproc/discount/Makefile
+++ b/textproc/discount/Makefile
@@ -39,9 +39,6 @@ EXTRA_CONFIGURE_ON= --with-dl=both --with-fenced-code --with-github-tags --with-
SAMPLES_INSTALL_TARGET= install.samples
TAB8_CONFIGURE_ON= --with-tabstops=8
-post-configure:
- @${REINPLACE_CMD} -e 's|/sbin/ldconfig|#&|' ${WRKSRC}/librarian.sh
-
post-install:
${INSTALL_DATA} ${WRKSRC}/libmarkdown.a ${STAGEDIR}${PREFIX}/lib/libmarkdown.a
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmarkdown.so
diff --git a/textproc/discount/files/patch-configure.inc b/textproc/discount/files/patch-configure.inc
new file mode 100644
index 000000000000..ec33a22e576c
--- /dev/null
+++ b/textproc/discount/files/patch-configure.inc
@@ -0,0 +1,10 @@
+--- configure.inc.orig 2020-08-24 05:45:49 UTC
++++ configure.inc
+@@ -1501,7 +1501,6 @@ install)$PROG_INSTALL -c \$FULLNAME "\$1"
+ $PROG_LN_S -f \$FULLNAME \$1/\$LIBNAME.\$MAJOR
+ $PROG_LN_S -f \$FULLNAME \$1/\$LIBNAME
+ EOF
+- test "$LDCONFIG" && echo ' '$LDCONFIG '"$1"' >> librarian.sh
+ cat >> librarian.sh << EOF
+ ;;
+ esac