aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-30 07:37:58 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-31 00:06:38 +0000
commit68a2dd33db1724e951265025447a8b6e94891664 (patch)
treecf40864567f40262a69765fcd6c32f1ea71c48ae
parent8bd99739aa6e687975c6c3566019072fa21a14fa (diff)
downloadports-68a2dd33db1724e951265025447a8b6e94891664.tar.gz
ports-68a2dd33db1724e951265025447a8b6e94891664.zip
net/wireguard-kmod: Remove expired port
2023-12-31 net/wireguard-kmod: Only useful for FreeBSD 12 which is EoL soon
-rw-r--r--MOVED1
-rw-r--r--net/Makefile1
-rw-r--r--net/wireguard-kmod/Makefile24
-rw-r--r--net/wireguard-kmod/distinfo3
-rw-r--r--net/wireguard-kmod/files/patch-if__wg.c32
-rw-r--r--net/wireguard-kmod/files/patch-support.h34
-rw-r--r--net/wireguard-kmod/pkg-descr7
-rw-r--r--net/wireguard-kmod/pkg-message11
8 files changed, 1 insertions, 112 deletions
diff --git a/MOVED b/MOVED
index fa3db9c6861c..1582e9bdebbe 100644
--- a/MOVED
+++ b/MOVED
@@ -8291,3 +8291,4 @@ www/kf5-kdewebkit||2023-12-31|Has expired: Depends on deprecated www/qt5-webkit
www/py-dj41-django-auth-ldap|www/py-dj42-django-auth-ldap|2023-12-31|Has expired: Extended support of Django 4.1 ends December 2023, upgrade to the Django 4.2+ version of this port. See https://www.djangoproject.com/download/
sysutils/kfloppy||2023-12-31|Has expired: No longer part of KDE Gear since 23.08
net/wireguard||2023-12-31|Has expired: Only useful for FreeBSD 12 which is EoL soon
+net/wireguard-kmod||2023-12-31|Has expired: Only useful for FreeBSD 12 which is EoL soon
diff --git a/net/Makefile b/net/Makefile
index 6f39f2017246..a0511775c944 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1617,7 +1617,6 @@
SUBDIR += wifibox-alpine
SUBDIR += wifibox-core
SUBDIR += wireguard-go
- SUBDIR += wireguard-kmod
SUBDIR += wireguard-tools
SUBDIR += wireproxy
SUBDIR += wireshark
diff --git a/net/wireguard-kmod/Makefile b/net/wireguard-kmod/Makefile
deleted file mode 100644
index 1a5ba342ff49..000000000000
--- a/net/wireguard-kmod/Makefile
+++ /dev/null
@@ -1,24 +0,0 @@
-PORTNAME= wireguard-kmod
-PORTVERSION= 0.0.20220615
-PORTREVISION= 1
-CATEGORIES= net net-vpn
-MASTER_SITES= https://git.zx2c4.com/wireguard-freebsd/snapshot/
-DISTNAME= wireguard-freebsd-${PORTVERSION}
-
-MAINTAINER= decke@FreeBSD.org
-COMMENT= WireGuard implementation for the FreeBSD kernel
-WWW= https://git.zx2c4.com/wireguard-freebsd/
-
-LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/../COPYING
-
-DEPRECATED= Only useful for FreeBSD 12 which is EoL soon
-EXPIRATION_DATE= 2023-12-31
-
-USES= kmod tar:xz uidfix
-
-WRKSRC_SUBDIR= src
-
-PLIST_FILES= ${KMODDIR}/if_wg.ko
-
-.include <bsd.port.mk>
diff --git a/net/wireguard-kmod/distinfo b/net/wireguard-kmod/distinfo
deleted file mode 100644
index f45d8322d8f8..000000000000
--- a/net/wireguard-kmod/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1655302401
-SHA256 (wireguard-freebsd-0.0.20220615.tar.xz) = ad6c42d20a7c0ad2989e729dd41ea5a6a019426b762dfd0c6417e340935cca82
-SIZE (wireguard-freebsd-0.0.20220615.tar.xz) = 46744
diff --git a/net/wireguard-kmod/files/patch-if__wg.c b/net/wireguard-kmod/files/patch-if__wg.c
deleted file mode 100644
index 283bbfc7615b..000000000000
--- a/net/wireguard-kmod/files/patch-if__wg.c
+++ /dev/null
@@ -1,32 +0,0 @@
-Chase udp_tun_func_t typedef change in FreeBSD 14-current (bb77f0)
-
-Submitted by: Stefan Haller <stefan+freebsd@stha.de>,
- Guido Falsi <madpilot@FreeBSD.org>
-Obtained from: https://bugs.freebsd.org/266914
-Link: https://freshbsd.org/freebsd/src/commit/bb77f0c2049311f0661c2493838d81a5a66c449c
---- if_wg.c.orig 2022-06-15 14:11:06 UTC
-+++ if_wg.c
-@@ -693,7 +693,11 @@ wg_socket_init(struct wg_softc *sc, in_port_t port)
- if (rc)
- goto out;
-
-+#if __FreeBSD_version >= 1400067
-+ rc = udp_set_kernel_tunneling(so4, wg_input, NULL, sc);
-+#else
- rc = udp_set_kernel_tunneling(so4, (udp_tun_func_t)wg_input, NULL, sc);
-+#endif
- /*
- * udp_set_kernel_tunneling can only fail if there is already a tunneling function set.
- * This should never happen with a new socket.
-@@ -704,7 +708,11 @@ wg_socket_init(struct wg_softc *sc, in_port_t port)
- rc = socreate(AF_INET6, &so6, SOCK_DGRAM, IPPROTO_UDP, cred, td);
- if (rc)
- goto out;
-+#if __FreeBSD_version >= 1400067
-+ rc = udp_set_kernel_tunneling(so6, wg_input, NULL, sc);
-+#else
- rc = udp_set_kernel_tunneling(so6, (udp_tun_func_t)wg_input, NULL, sc);
-+#endif
- MPASS(rc == 0);
- #endif
-
diff --git a/net/wireguard-kmod/files/patch-support.h b/net/wireguard-kmod/files/patch-support.h
deleted file mode 100644
index d7de7b548df6..000000000000
--- a/net/wireguard-kmod/files/patch-support.h
+++ /dev/null
@@ -1,34 +0,0 @@
-From 20584d1c329ed2a71893375fa11ca4c56ed9f642 Mon Sep 17 00:00:00 2001
-From: "Jason A. Donenfeld" <Jason@zx2c4.com>
-Date: Sun, 4 Sep 2022 19:06:00 +0200
-Subject: support: account for protosw change
-
-e7d02be19 ("protosw: refactor protosw and domain static declaration and
-load") changed the way this function should be invoked.
-
-Link: https://github.com/freebsd/freebsd-src/commit/e7d02be19d40063783d6b8f1ff2bc4c7170fd434
-Reported-by: Michael Pro <michael.adm@gmail.com>
-Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
----
- src/support.h | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/support.h b/src/support.h
-index d1c326c..ee6b03c 100644
---- support.h
-+++ support.h
-@@ -37,7 +37,11 @@ sogetsockaddr(struct socket *so, struct sockaddr **nam)
- int error;
-
- CURVNET_SET(so->so_vnet);
-+#if __FreeBSD_version < 1400066
- error = (*so->so_proto->pr_usrreqs->pru_sockaddr)(so, nam);
-+#else
-+ error = so->so_proto->pr_sockaddr(so, nam);
-+#endif
- CURVNET_RESTORE();
- return (error);
- }
---
-cgit v1.2.3-11-g984f
-
diff --git a/net/wireguard-kmod/pkg-descr b/net/wireguard-kmod/pkg-descr
deleted file mode 100644
index 3bd4a7a045bd..000000000000
--- a/net/wireguard-kmod/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-Kernel module for FreeBSD to support Wireguard.
-
-At this time this code is new, unvetted, possibly buggy, and should be
-considered "experimental". It might contain security issues. We gladly
-welcome your testing and bug reports, but do keep in mind that this code
-is new, so some caution should be exercised at the moment for using it
-in mission critical environments.
diff --git a/net/wireguard-kmod/pkg-message b/net/wireguard-kmod/pkg-message
deleted file mode 100644
index c8b893f4bee7..000000000000
--- a/net/wireguard-kmod/pkg-message
+++ /dev/null
@@ -1,11 +0,0 @@
-[
-{ type: install
- message: <<EOM
-At this time this code is new, unvetted, possibly buggy, and should be
-considered "experimental". It might contain security issues. We gladly
-welcome your testing and bug reports, but do keep in mind that this code
-is new, so some caution should be exercised at the moment for using it
-in mission critical environments.
-EOM
-}
-]