aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-11-04 21:41:09 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-11-05 23:56:25 +0000
commit68acc1609371e9b5c8a374c24927823f1f60cbb1 (patch)
tree6225199ef8ad5c4f56bccab94a8f869498a3718a
parentdc96c3d56a8422d056cb108b69b381d5042365c4 (diff)
downloadports-68acc1609371e9b5c8a374c24927823f1f60cbb1.tar.gz
ports-68acc1609371e9b5c8a374c24927823f1f60cbb1.zip
graphics/yacreader: add -qt6 flavor
PDF isn't supported yet: poppler is broken and pdfium isn't packaged.
-rw-r--r--graphics/yacreader/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/graphics/yacreader/Makefile b/graphics/yacreader/Makefile
index 0b71b4f500f2..e50f5760778c 100644
--- a/graphics/yacreader/Makefile
+++ b/graphics/yacreader/Makefile
@@ -14,12 +14,24 @@ LICENSE_FILE= ${WRKSRC}/COPYING.txt
LIB_DEPENDS= libunarr.so:archivers/unarr
+FLAVORS= qt5 qt6
+
USES= compiler:c++11-lib desktop-file-utils pkgconfig qmake qt:5
USE_GITHUB= yes
USE_QT= qmake:build buildtools:build core concurrent:build declarative \
gui linguisttools:build multimedia network quickcontrols2 \
sql sql-sqlite3:run svg testlib:build widgets
+.if ${FLAVOR:U} == qt6
+PKGNAMESUFFIX= -${FLAVOR}
+USES:= ${USES:S/qt:5/qt:6/}
+USE_QT= 5compat base declarative multimedia svg tools:build
+OPTIONS_EXCLUDE=POPPLER # https://github.com/YACReader/yacreader/issues/352
+CONFLICTS_INSTALL= ${PORTNAME}
+.else
+CONFLICTS_INSTALL= ${PORTNAME}-qt6
+.endif
+
OPTIONS_DEFINE= OPENGL POPPLER
OPTIONS_DEFAULT=OPENGL POPPLER
@@ -27,7 +39,7 @@ OPENGL_USES= gl
OPENGL_USE= GL=gl
OPENGL_QMAKE_OFF= CONFIG+=no_opengl
-POPPLER_LIB_DEPENDS= libpoppler-qt5.so:graphics/poppler-qt5
+POPPLER_LIB_DEPENDS= libpoppler-${FLAVOR}.so:graphics/poppler-${FLAVOR}
POPPLER_QMAKE_OFF= CONFIG+=no_pdf
.include <bsd.port.mk>