aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-01-21 22:41:43 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-01-21 22:41:43 +0000
commit68b06b55ab51ce7823f32e8e9be004c47d92e1b4 (patch)
tree396e7f30baec58e2885f26b2224f5e7629947d82
parent16323a42ad9815987b8fbe0039cdb787110f1847 (diff)
downloadports-68b06b55ab51ce7823f32e8e9be004c47d92e1b4.tar.gz
ports-68b06b55ab51ce7823f32e8e9be004c47d92e1b4.zip
www/lighttpd: remove GDBM option
mod_trigger_b4_dl was the only module that depended on gdbm and it was removed. Reported by: Glenn Strauss <gstrauss@gluelogic.com>
-rw-r--r--www/lighttpd/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 498fbf1d5e44..7396825a3dd1 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -35,8 +35,8 @@ PORTDOCS= AUTHORS COPYING INSTALL NEWS README
USE_RC_SUBR= lighttpd
REQUIRE= LOGIN
-OPTIONS_DEFINE= ATTR DBI DOCS GDBM IPV6 KRB5 LUA MAXMINDDB NETTLE \
- LDAP SPAWNFCGI VALGRIND WEBDAV ZSTD
+OPTIONS_DEFINE= ATTR DBI DOCS IPV6 KRB5 LUA MAXMINDDB NETTLE LDAP SPAWNFCGI \
+ VALGRIND WEBDAV ZSTD
OPTIONS_GROUP= SSL
OPTIONS_GROUP_SSL= OPENSSL GNUTLS MBEDTLS NSS WOLFSSL
@@ -45,7 +45,6 @@ OPTIONS_SUB= yes
ATTR_DESC= extended attributes support
DBI_DESC= DBI authentication (mod_authn_dbi)
-GDBM_DESC= gdbm storage (mod_trigger_b4_dl)
KRB5_DESC= Kerberos authentication (mod_authn_gssapi)
LDAP_DESC= LDAP authentication (mod_authn_ldap)
LUA_DESC= lua support (mod_magnet)
@@ -59,8 +58,6 @@ ZSTD_DESC= mod_deflate support for zstd (Zstandard)
ATTR_CONFIGURE_WITH= attr
DBI_CONFIGURE_WITH= dbi=${LOCALBASE}
DBI_LIB_DEPENDS= libdbi.so:databases/libdbi
-GDBM_LIB_DEPENDS= libgdbm.so:databases/gdbm
-GDBM_CONFIGURE_WITH= gdbm
GNUTLS_CONFIGURE_WITH= gnutls=${LOCALBASE}
GNUTLS_LIBS= -lgnutls
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls