aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-27 04:06:36 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-27 04:06:36 +0000
commit692a158177bd5202ba3e56a8b3e56fcb63d3fdab (patch)
tree77f2775846920b057767fd3035506cf8e4f77358
parente545e7a4aa081f00cb1ce24943f80616cb44dfdf (diff)
downloadports-692a158177bd5202ba3e56a8b3e56fcb63d3fdab.tar.gz
ports-692a158177bd5202ba3e56a8b3e56fcb63d3fdab.zip
devel/py-crontab: Add py-crontab 1.0.1
This package intends to offer a method of parsing crontab schedule entries and determining when an item should next be run. More specifically, it calculates a delay in seconds from when the .next() method is called to when the item should next be executed.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-crontab/Makefile19
-rw-r--r--devel/py-crontab/distinfo3
-rw-r--r--devel/py-crontab/pkg-descr4
4 files changed, 27 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 788553c335f9..0c07c25e956e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4486,6 +4486,7 @@
SUBDIR += py-crashtest
SUBDIR += py-crc32c
SUBDIR += py-crcmod
+ SUBDIR += py-crontab
SUBDIR += py-cson
SUBDIR += py-csv23
SUBDIR += py-ctags
diff --git a/devel/py-crontab/Makefile b/devel/py-crontab/Makefile
new file mode 100644
index 000000000000..8b3f00c7c5c7
--- /dev/null
+++ b/devel/py-crontab/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= crontab
+PORTVERSION= 1.0.1
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Parse and use crontab schedules in Python
+WWW= https://github.com/josiahcarlson/parse-crontab
+
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-crontab/distinfo b/devel/py-crontab/distinfo
new file mode 100644
index 000000000000..3ed342234b49
--- /dev/null
+++ b/devel/py-crontab/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1684104286
+SHA256 (crontab-1.0.1.tar.gz) = 89477e3f93c81365e738d5ee2659509e6373bb2846de13922663e79aa74c6b91
+SIZE (crontab-1.0.1.tar.gz) = 19616
diff --git a/devel/py-crontab/pkg-descr b/devel/py-crontab/pkg-descr
new file mode 100644
index 000000000000..f07c9078a857
--- /dev/null
+++ b/devel/py-crontab/pkg-descr
@@ -0,0 +1,4 @@
+This package intends to offer a method of parsing crontab schedule entries and
+determining when an item should next be run. More specifically, it calculates a
+delay in seconds from when the .next() method is called to when the item should
+next be executed.