aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-03 08:53:36 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-03 09:00:55 +0000
commit699f62d696da389806fbd5f5bb86b1cc1f29f1ae (patch)
treeda02bf910d69d597b659277040becb6739746d91
parentca747fc937a3e4611aad4bebf4a7a85d2fa39741 (diff)
downloadports-699f62d696da389806fbd5f5bb86b1cc1f29f1ae.tar.gz
ports-699f62d696da389806fbd5f5bb86b1cc1f29f1ae.zip
Mk/Uses/perl5.mk: Remove outdated P5_POD_PARSER
lang/perl5.30 has been removed in b3fb5d8b3c860bd3c3ebcffafe621aea61379539.
-rw-r--r--Mk/Uses/perl5.mk6
-rw-r--r--audio/mp3lint/Makefile4
-rw-r--r--converters/p5-LaTeXML/Makefile2
-rw-r--r--databases/p5-DBIx-Class-Migration/Makefile4
-rw-r--r--devel/p5-Pod-Coverage/Makefile2
-rw-r--r--graphics/darktable/Makefile2
-rw-r--r--lang/parrot/Makefile2
-rw-r--r--mail/sqlgrey/Makefile2
-rw-r--r--math/PDL/Makefile2
-rw-r--r--net/p5-URI-Fast/Makefile2
-rw-r--r--security/silktools/Makefile2
-rw-r--r--textproc/p5-Perl-Critic/Makefile2
-rw-r--r--textproc/p5-pod2pdf/Makefile2
-rw-r--r--textproc/po4a/Makefile2
-rw-r--r--www/rt44/Makefile.cpan2
-rw-r--r--www/rt50/Makefile.cpan2
-rw-r--r--x11-toolkits/p5-Gtk2-Ex-PodViewer/Makefile2
17 files changed, 18 insertions, 24 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index c4715844e008..0f5cdf577cd7 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -166,12 +166,6 @@ IGNORE= has unknown USE_PERL5 components: ${_USE_PERL5_UNKNOWN}
_USES_POST+= perl5
-. if ${PERL_LEVEL} >= 503100
-P5_POD_PARSER= p5-Pod-Parser>=1.63:textproc/p5-Pod-Parser
-. else
-P5_POD_PARSER=
-. endif
-
.endif
.if defined(_POSTMKINCLUDED) && !defined(_INCLUDE_USES_PERL5_POST_MK)
diff --git a/audio/mp3lint/Makefile b/audio/mp3lint/Makefile
index 3f68fa995d4e..f645d2d0b988 100644
--- a/audio/mp3lint/Makefile
+++ b/audio/mp3lint/Makefile
@@ -13,8 +13,8 @@ COMMENT= Configurable tool to check collections of audio files
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${RUN_DEPENDS} \
- ${P5_POD_PARSER}
+BUILD_DEPENDS= p5-Pod-Parser>=0:textproc/p5-Pod-Parser \
+ ${RUN_DEPENDS}
RUN_DEPENDS= libmp3-archive-perl>=0:audio/libmp3-archive-perl
USES= perl5
diff --git a/converters/p5-LaTeXML/Makefile b/converters/p5-LaTeXML/Makefile
index b6d9dc21f612..7a6434ae1f22 100644
--- a/converters/p5-LaTeXML/Makefile
+++ b/converters/p5-LaTeXML/Makefile
@@ -21,12 +21,12 @@ RUN_DEPENDS= p5-Archive-Zip>=0:archivers/p5-Archive-Zip \
p5-Text-Unidecode>=0:converters/p5-Text-Unidecode \
p5-IO-String>=0:devel/p5-IO-String \
p5-Parse-RecDescent>=0:devel/p5-Parse-RecDescent \
+ p5-Pod-Parser>=0:textproc/p5-Pod-Parser \
p5-Image-Size>=0:graphics/p5-Image-Size \
p5-URI>=0:net/p5-URI \
p5-File-Which>=0:sysutils/p5-File-Which \
p5-XML-LibXML>=1.62:textproc/p5-XML-LibXML \
p5-XML-LibXSLT>=1.58:textproc/p5-XML-LibXSLT \
- ${P5_POD_PARSER} \
p5-libwww>=0:www/p5-libwww
USES= perl5
diff --git a/databases/p5-DBIx-Class-Migration/Makefile b/databases/p5-DBIx-Class-Migration/Makefile
index bd6f51e72ace..aea59dbdd0fe 100644
--- a/databases/p5-DBIx-Class-Migration/Makefile
+++ b/databases/p5-DBIx-Class-Migration/Makefile
@@ -10,6 +10,7 @@ COMMENT= Perl extension to make migrating your DBIx::Class databases easier
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= \
p5-Class-Load>0.22:devel/p5-Class-Load \
p5-Config-MySQL>=0.02:devel/p5-Config-MySQL \
@@ -25,11 +26,10 @@ RUN_DEPENDS= \
p5-MooX-Attribute-ENV>=0.02:devel/p5-MooX-Attribute-ENV \
p5-MooX-Options>=4.103:devel/p5-MooX-Options \
p5-MooX-Traits>=0.005:devel/p5-MooX-Traits \
- ${P5_POD_PARSER} \
+ p5-Pod-Parser>=1.63:textproc/p5-Pod-Parser \
p5-SQL-Translator>=0.11021:databases/p5-SQL-Translator \
p5-Text-Brew>=0.02:textproc/p5-Text-Brew \
p5-version>=0.9924:devel/p5-version
-BUILD_DEPENDS= ${RUN_DEPENDS}
TEST_DEPENDS= \
p5-Test-Most>=0.34:devel/p5-Test-Most \
p5-Test-Requires>=0.10:devel/p5-Test-Requires
diff --git a/devel/p5-Pod-Coverage/Makefile b/devel/p5-Pod-Coverage/Makefile
index afc567712ae8..503fd9077635 100644
--- a/devel/p5-Pod-Coverage/Makefile
+++ b/devel/p5-Pod-Coverage/Makefile
@@ -13,7 +13,7 @@ LICENSE_COMB= dual
BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-Devel-Symdump>=2.01:devel/p5-Devel-Symdump \
- ${P5_POD_PARSER}
+ p5-Pod-Parser>=1.13:textproc/p5-Pod-Parser
TEST_DEPENDS= p5-Test-Pod>=1:devel/p5-Test-Pod
USES= perl5
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index c24d4dfc34dd..32354e1c3b7c 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -15,7 +15,7 @@ ONLY_FOR_ARCHS= aarch64 amd64 powerpc64le
ONLY_FOR_ARCHS_REASON= uses 64-bit address space
BUILD_DEPENDS= iso-codes>=0:misc/iso-codes \
- ${P5_POD_PARSER} \
+ p5-Pod-Parser>=0:textproc/p5-Pod-Parser \
po4a-translate:textproc/po4a \
xsltproc:textproc/libxslt \
bash:shells/bash
diff --git a/lang/parrot/Makefile b/lang/parrot/Makefile
index 916b5f2b36b6..b8c734bc9269 100644
--- a/lang/parrot/Makefile
+++ b/lang/parrot/Makefile
@@ -13,7 +13,7 @@ COMMENT= Virtual machine for dynamic languages
LICENSE= ART20
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex \
- ${P5_POD_PARSER} \
+ p5-Pod-Parser>=0:textproc/p5-Pod-Parser \
pcre-config:devel/pcre
LIB_DEPENDS= libgmp.so:math/gmp \
libicudata.so:devel/icu
diff --git a/mail/sqlgrey/Makefile b/mail/sqlgrey/Makefile
index 20e2a4d57b9d..cda459687d57 100644
--- a/mail/sqlgrey/Makefile
+++ b/mail/sqlgrey/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= p5-Net-Server>=0:net/p5-Net-Server \
p5-IO-Multiplex>=0:devel/p5-IO-Multiplex \
- ${P5_POD_PARSER} \
+ p5-Pod-Parser>=0:textproc/p5-Pod-Parser \
${LOCALBASE}/bin/bash:shells/bash \
${LOCALBASE}/bin/gmd5sum:sysutils/coreutils
diff --git a/math/PDL/Makefile b/math/PDL/Makefile
index b36bba2f840f..bf5941e0ca99 100644
--- a/math/PDL/Makefile
+++ b/math/PDL/Makefile
@@ -17,7 +17,7 @@ BROKEN_i386= ld: error: can't create dynamic relocation R_386_32 against local s
.endif
BUILD_DEPENDS= p5-Devel-CheckLib>=1.01:devel/p5-Devel-CheckLib \
- ${P5_POD_PARSER} \
+ p5-Pod-Parser>=0:textproc/p5-Pod-Parser \
${RUN_DEPENDS}
RUN_DEPENDS= p5-Astro-FITS-Header>=0:astro/p5-Astro-FITS-Header \
p5-Convert-UU>=0:converters/p5-Convert-UU \
diff --git a/net/p5-URI-Fast/Makefile b/net/p5-URI-Fast/Makefile
index 6e5215f8c4f1..328f4bae55bd 100644
--- a/net/p5-URI-Fast/Makefile
+++ b/net/p5-URI-Fast/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-URI-Encode-XS>=0.11:net/p5-URI-Encode-XS \
p5-URI>=0:net/p5-URI \
p5-Unicode-LineBreak>=0:textproc/p5-Unicode-LineBreak
-TEST_DEPENDS= ${P5_POD_PARSER} \
+TEST_DEPENDS= p5-Pod-Parser>=0:textproc/p5-Pod-Parser \
p5-Test-LeakTrace>=0.16:devel/p5-Test-LeakTrace \
p5-Test2-Suite>=0.000141:devel/p5-Test2-Suite
diff --git a/security/silktools/Makefile b/security/silktools/Makefile
index 9c8e7aa755f9..80af62aa94ec 100644
--- a/security/silktools/Makefile
+++ b/security/silktools/Makefile
@@ -17,7 +17,7 @@ LICENSE_PERMS_GPLR= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libfixbuf.so:net/libfixbuf
BUILD_DEPENDS= p5-DBI>=0:databases/p5-DBI \
- ${P5_POD_PARSER}
+ p5-Pod-Parser>=0:textproc/p5-Pod-Parser
RUN_DEPENDS= p5-DBI>=0:databases/p5-DBI
GNU_CONFIGURE= yes
diff --git a/textproc/p5-Perl-Critic/Makefile b/textproc/p5-Perl-Critic/Makefile
index b9c80cb68c25..b7ed761c06e5 100644
--- a/textproc/p5-Perl-Critic/Makefile
+++ b/textproc/p5-Perl-Critic/Makefile
@@ -30,7 +30,7 @@ RUN_DEPENDS= p5-B-Keywords>=1.05:devel/p5-B-Keywords \
p5-Readonly>=2:devel/p5-Readonly \
p5-String-Format>=1.13:textproc/p5-String-Format \
p5-Task-Weaken>=0:devel/p5-Task-Weaken \
- ${P5_POD_PARSER}
+ p5-Pod-Parser>=0:textproc/p5-Pod-Parser
TEST_DEPENDS= p5-Test-Deep>=0:devel/p5-Test-Deep
USES= perl5
diff --git a/textproc/p5-pod2pdf/Makefile b/textproc/p5-pod2pdf/Makefile
index 4ef96b5abbca..42b89d982347 100644
--- a/textproc/p5-pod2pdf/Makefile
+++ b/textproc/p5-pod2pdf/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-Getopt-ArgvFile>0:devel/p5-Getopt-ArgvFile \
p5-PDF-API2>=0.60:textproc/p5-PDF-API2 \
p5-Pod-Escapes>0:textproc/p5-Pod-Escapes \
- ${P5_POD_PARSER}
+ p5-Pod-Parser>=0:textproc/p5-Pod-Parser
USES= perl5
USE_PERL5= configure
diff --git a/textproc/po4a/Makefile b/textproc/po4a/Makefile
index ab267a087808..2806352fc17e 100644
--- a/textproc/po4a/Makefile
+++ b/textproc/po4a/Makefile
@@ -17,7 +17,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${RUN_DEPENDS} \
- ${P5_POD_PARSER}
+ p5-Pod-Parser>=0:textproc/p5-Pod-Parser
RUN_DEPENDS= p5-Term-ReadKey>=2.30:devel/p5-Term-ReadKey \
p5-Text-WrapI18N>=0.06:textproc/p5-Text-WrapI18N \
p5-SGMLSpm>=1.03:textproc/p5-SGMLSpm \
diff --git a/www/rt44/Makefile.cpan b/www/rt44/Makefile.cpan
index d7145d50b4cd..2d810c46833e 100644
--- a/www/rt44/Makefile.cpan
+++ b/www/rt44/Makefile.cpan
@@ -140,7 +140,7 @@ CORE_DEPS= p5-Apache-Session>=1.53:www/p5-Apache-Session \
p5-Net-IP>=0:net-mgmt/p5-Net-IP \
p5-Parallel-ForkManager>=0:devel/p5-Parallel-ForkManager \
p5-Plack>=1.0002:www/p5-Plack \
- ${P5_POD_PARSER} \
+ p5-Pod-Parser>=0:textproc/p5-Pod-Parser \
p5-Starlet>0:www/p5-Starlet \
p5-Regexp-Common-net-CIDR>0:textproc/p5-Regexp-Common-net-CIDR \
p5-Regexp-Common>0:textproc/p5-Regexp-Common \
diff --git a/www/rt50/Makefile.cpan b/www/rt50/Makefile.cpan
index 4e5689c2f82d..677d9b1ef77e 100644
--- a/www/rt50/Makefile.cpan
+++ b/www/rt50/Makefile.cpan
@@ -151,7 +151,7 @@ CORE_DEPS= p5-Apache-Session>=1.53:www/p5-Apache-Session \
p5-Net-IP>=0:net-mgmt/p5-Net-IP \
p5-Parallel-ForkManager>=0:devel/p5-Parallel-ForkManager \
p5-Plack>=1.0002:www/p5-Plack \
- ${P5_POD_PARSER} \
+ p5-Pod-Parser>=0:textproc/p5-Pod-Parser \
p5-Starlet>0:www/p5-Starlet \
p5-Regexp-Common-net-CIDR>0:textproc/p5-Regexp-Common-net-CIDR \
p5-Regexp-Common>0:textproc/p5-Regexp-Common \
diff --git a/x11-toolkits/p5-Gtk2-Ex-PodViewer/Makefile b/x11-toolkits/p5-Gtk2-Ex-PodViewer/Makefile
index f2c6e2788fab..28068a00ba93 100644
--- a/x11-toolkits/p5-Gtk2-Ex-PodViewer/Makefile
+++ b/x11-toolkits/p5-Gtk2-Ex-PodViewer/Makefile
@@ -14,7 +14,7 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
BUILD_DEPENDS= ${RUN_DEPENDS} \
- ${P5_POD_PARSER}
+ p5-Pod-Parser>=0:textproc/p5-Pod-Parser
RUN_DEPENDS= p5-Gtk2>=0:x11-toolkits/p5-Gtk2 \
p5-IO-Stringy>=0:devel/p5-IO-Stringy \
p5-Locale-gettext>=0:devel/p5-Locale-gettext \