aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin Bowling <kbowling@FreeBSD.org>2021-06-12 00:53:50 +0000
committerKevin Bowling <kbowling@FreeBSD.org>2021-06-12 00:54:18 +0000
commit69c9420a212a14fd8d00f4bade2dddb85eabbefc (patch)
treede229e898c234caea9a0c2426fc2f8435fa6d686
parent6d19e625a2f26f21a76241b86cb5243216ea2987 (diff)
downloadports-69c9420a212a14fd8d00f4bade2dddb85eabbefc.tar.gz
ports-69c9420a212a14fd8d00f4bade2dddb85eabbefc.zip
news/inn-CURRENT: New port to follow CURRENT snaps
-rw-r--r--news/inn-CURRENT/Makefile20
-rw-r--r--news/inn-CURRENT/distinfo3
-rw-r--r--news/inn-CURRENT/pkg-descr8
-rw-r--r--news/inn/Makefile40
-rw-r--r--news/inn/pkg-plist6
5 files changed, 70 insertions, 7 deletions
diff --git a/news/inn-CURRENT/Makefile b/news/inn-CURRENT/Makefile
new file mode 100644
index 000000000000..aed70c2ddbad
--- /dev/null
+++ b/news/inn-CURRENT/Makefile
@@ -0,0 +1,20 @@
+# Created by: kbowling
+
+PORTNAME= inn-CURRENT
+PORTVERSION= ${SNAPSHOT}
+MASTER_SITE_SUBDIR= inn/snapshots
+DISTNAME= ${PORTNAME}-${SNAPSHOT}
+
+BRANCH= CURRENT
+SNAPSHOT= 20210610
+
+CONFLICTS= inn-2.[0-9]*
+
+DISTINFO_FILE= ${.CURDIR}/distinfo
+FILESDIR= ${.CURDIR}/../inn/files
+PATCHDIR= ${.CURDIR}/../inn/files
+PLIST= ${.CURDIR}/../inn/pkg-plist
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+.include "${.CURDIR}/../inn/Makefile"
+
diff --git a/news/inn-CURRENT/distinfo b/news/inn-CURRENT/distinfo
new file mode 100644
index 000000000000..d06ed321fe4a
--- /dev/null
+++ b/news/inn-CURRENT/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1623451171
+SHA256 (inn-CURRENT-20210610.tar.gz) = 262821a7e270d4d1c0e022c125b229509c8fd1eba0955337f4091f55413af4c6
+SIZE (inn-CURRENT-20210610.tar.gz) = 2647364
diff --git a/news/inn-CURRENT/pkg-descr b/news/inn-CURRENT/pkg-descr
new file mode 100644
index 000000000000..6fa82bd23a93
--- /dev/null
+++ b/news/inn-CURRENT/pkg-descr
@@ -0,0 +1,8 @@
+InterNetNews is a complete Usenet system. The cornerstone of the package
+is innd, an NNTP server that multiplexes all I/O. Newsreading is handled
+by a separate server, nnrpd, that is spawned for each client. Both innd
+and nnrpd have some slight variances from the NNTP protocol.
+
+This version follows the CURRENT snapshots.
+
+WWW: http://www.eyrie.org/~eagle/software/inn/
diff --git a/news/inn/Makefile b/news/inn/Makefile
index 671fe891f69d..6d4c5e0d7110 100644
--- a/news/inn/Makefile
+++ b/news/inn/Makefile
@@ -1,9 +1,11 @@
# Created by: torstenb
-PORTNAME= inn
-PORTVERSION= 2.6.4
-CATEGORIES= news
-MASTER_SITES= ISC/${PORTNAME}
+PORTNAME?= inn
+PORTVERSION?= 2.6.4
+PORTREVISION?= 0
+CATEGORIES= news
+MASTER_SITES= ISC
+MASTER_SITE_SUBDIR?= ${PORTNAME}
MAINTAINER= kbowling@FreeBSD.org
COMMENT= InterNetNews -- the Internet meets Netnews
@@ -19,7 +21,7 @@ SUB_FILES= pkg-install
USES= cpe gmake libtool perl5 uidfix
CPE_VENDOR= isc
-CONFLICTS?= inn-stable-[0-9]* inn-current-[0-9]*
+CONFLICTS?= inn-CURRENT-[0-9]*
OPTIONS_DEFINE= BERKELEYDB GNUPG KERBEROS PYTHON SASL KEYWORDS \
LARGE_FILES OPENSSL SETGID_INEWS TAGGED_HASH \
@@ -40,6 +42,16 @@ GNUPG_DESC= GnuPG support (for pgpverify control message)
UUCP_RNEWS_DESC= Install rnews suitable for use with net/freebsd-uucp
SETGID_INEWS_DESC= Enable posting articles locally for all users
+.if ${BRANCH:U} == CURRENT
+OPTIONS_DEFINE+= SQLITE
+OPTIONS_DEFAULT+= SQLITE
+SQLITE_DESC= Enable SQLite (for ovsqlite overview method)
+
+PLIST_SUB+= SNAPSHOT=""
+.else
+PLIST_SUB+= SNAPSHOT="@comment "
+.endif
+
VARBASE?= /var
.include "Makefile.layout"
@@ -67,6 +79,20 @@ PLIST_SUB+= LIBVER=${LIBVER_LONG:R:R} LIBVER_LONG=${LIBVER_LONG} \
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MSQLITE}
+USES+= sqlite
+CONFIGURE_ARGS+= --with-sqlite3=${LOCALBASE}
+PLIST_SUB+= SQLITE=""
+
+TO_BE_STRIPPED+= bin/ovsqlite-server
+CONFIG_FILES+= ovsqlite.conf
+.else
+. if ${BRANCH:U} == CURRENT
+CONFIGURE_ARGS+= --without-sqlite3
+. endif
+PLIST_SUB+= SQLITE="@comment "
+.endif
+
.if ${PORT_OPTIONS:MBERKELEYDB}
USES+= bdb
CONFIGURE_ARGS+= --with-bdb=${LOCALBASE} \
@@ -139,7 +165,7 @@ PLIST_SUB+= MODE_INEWS=""
.endif
PORTDOCS= CONTRIBUTORS HACKING INSTALL LICENSE MANIFEST NEWS README TODO
-TO_BE_STRIPPED= bin/actsync bin/archive bin/auth/passwd/auth_krb5 \
+TO_BE_STRIPPED+= bin/actsync bin/archive bin/auth/passwd/auth_krb5 \
bin/auth/passwd/ckpasswd bin/auth/passwd/radius bin/auth/resolv/domain \
bin/auth/resolv/ident bin/batcher bin/buffchan bin/buffindexed_d \
bin/convdate bin/ctlinnd bin/cvtbatch bin/expire bin/expireover \
@@ -153,7 +179,7 @@ TO_BE_STRIPPED= bin/actsync bin/archive bin/auth/passwd/auth_krb5 \
lib/libinn.so.${INNLIB_LONG} lib/libinnhist.so.${LIBVER_LONG} \
lib/libstorage.so.${LIBVER_LONG}
-CONFIG_FILES= actsync.cfg actsync.ign buffindexed.conf control.ctl \
+CONFIG_FILES+= actsync.cfg actsync.ign buffindexed.conf control.ctl \
control.ctl.local cycbuff.conf distrib.pats distributions expire.ctl \
localgroups incoming.conf inn.conf innfeed.conf innreport.conf \
innshellvars.local innshellvars.pl.local innshellvars.tcl.local \
diff --git a/news/inn/pkg-plist b/news/inn/pkg-plist
index f086f964265c..b19aa31dbc31 100644
--- a/news/inn/pkg-plist
+++ b/news/inn/pkg-plist
@@ -78,6 +78,7 @@ bin/ovdb_monitor
bin/ovdb_server
bin/ovdb_stat
bin/overchan
+%%SQLITE%%bin/ovsqlite-server
bin/perl-nocem
bin/pgpverify
bin/procbatch
@@ -113,6 +114,7 @@ doc/INSTALL
doc/LICENSE
doc/NEWS
doc/README
+%%SNAPSHOT%%doc/README.snapshot
doc/TODO
doc/config-design
doc/config-semantics
@@ -240,6 +242,7 @@ man/man5/nnrpd.track.5.gz
man/man5/nntpsend.ctl.5.gz
man/man5/nocem.ctl.5.gz
man/man5/ovdb.5.gz
+%%SQLITE%%man/man5/ovsqlite.5.gz
man/man5/passwd.nntp.5.gz
man/man5/readers.conf.5.gz
man/man5/storage.conf.5.gz
@@ -289,6 +292,7 @@ man/man8/ovdb_init.8.gz
man/man8/ovdb_monitor.8.gz
man/man8/ovdb_server.8.gz
man/man8/ovdb_stat.8.gz
+%%SQLITE%%man/man8/ovsqlite-server.8.gz
man/man8/overchan.8.gz
man/man8/perl-nocem.8.gz
man/man8/procbatch.8.gz
@@ -333,6 +337,7 @@ man/man8/writelog.8.gz
%%EXAMPLESDIR%%/nntpsend.ctl
%%EXAMPLESDIR%%/nocem.ctl
%%EXAMPLESDIR%%/ovdb.conf
+%%SQLITE%%%%EXAMPLESDIR%%/ovsqlite.conf
%%EXAMPLESDIR%%/passwd.nntp
%%EXAMPLESDIR%%/readers.conf
%%EXAMPLESDIR%%/send-uucp.cf
@@ -375,6 +380,7 @@ man/man8/writelog.8.gz
@sample %%CONFDIR%%/nntpsend.ctl.sample
@sample %%CONFDIR%%/nocem.ctl.sample
@sample %%CONFDIR%%/ovdb.conf.sample
+%%SQLITE%%@sample %%CONFDIR%%/ovsqlite.conf.sample
@sample %%CONFDIR%%/passwd.nntp.sample
@sample %%CONFDIR%%/readers.conf.sample
@sample %%CONFDIR%%/send-uucp.cf.sample