aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-10-09 19:24:09 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-10-09 19:43:26 +0000
commit6a1d5ade9227f36e8b0ecfb01559a1ca974cd0df (patch)
treee7d1598f9166256ba4fec32f248d9add895c16cc
parentc76de315944078eac241ceff1ae3926678c25f23 (diff)
graphics/mandelbulber: Fix build with tiff 4.7.0
Use TIFF:tiff to define the library instead of ${TIFF_LIBRARY} PR: 281747 Approved by: portmgr (blanket, build fix)
-rw-r--r--graphics/mandelbulber/files/patch-mandelbulber2_cmake_CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/graphics/mandelbulber/files/patch-mandelbulber2_cmake_CMakeLists.txt b/graphics/mandelbulber/files/patch-mandelbulber2_cmake_CMakeLists.txt
index a8eb70476056..3e9221c96d05 100644
--- a/graphics/mandelbulber/files/patch-mandelbulber2_cmake_CMakeLists.txt
+++ b/graphics/mandelbulber/files/patch-mandelbulber2_cmake_CMakeLists.txt
@@ -1,4 +1,4 @@
---- mandelbulber2/cmake/CMakeLists.txt.orig 2024-02-11 08:21:17 UTC
+--- mandelbulber2/cmake/CMakeLists.txt.orig 2024-08-23 15:11:23 UTC
+++ mandelbulber2/cmake/CMakeLists.txt
@@ -41,6 +41,7 @@ find_package(Qt5Concurrent REQUIRED)
find_package(Qt5Test REQUIRED)
@@ -8,7 +8,7 @@
# Find other required libraries.
find_package(PNG REQUIRED)
-@@ -90,7 +90,7 @@ add_executable(mandelbulber2 WIN32
+@@ -90,7 +91,7 @@ add_executable(mandelbulber2 WIN32
${SOURCE_FILES} ${ADDITIONAL_EXECUTABLE} ${qt_UI_H})
# Link qt libraries.
@@ -17,3 +17,12 @@
# Link other required libraries.
include_directories(${PNG_INCLUDE_DIR} ${GSL_INCLUDE_DIRS} ${LZO_INCLUDE_DIR})
+@@ -99,7 +100,7 @@ IF(TIFF_FOUND)
+ # Link other optional libraries and set corresponding flag definitions .
+ IF(TIFF_FOUND)
+ include_directories(${TIFF_INCLUDE_DIR})
+- target_link_libraries(mandelbulber2 ${TIFF_LIBRARY})
++ target_link_libraries(mandelbulber2 TIFF::tiff)
+ add_definitions(-DUSE_TIFF)
+ ENDIF()
+