aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2023-10-20 09:44:48 +0000
committerMikael Urankar <mikael@FreeBSD.org>2023-10-20 09:57:40 +0000
commit6a311f77ac4b737e6de3f0f9f0c1f9726517ac04 (patch)
tree6cb676c11edb3dddbbf595f6652112bc1632666d
parentc2238ca0584db3a01ad35c33589efdb2f2761b51 (diff)
downloadports-6a311f77ac4b737e6de3f0f9f0c1f9726517ac04.tar.gz
ports-6a311f77ac4b737e6de3f0f9f0c1f9726517ac04.zip
net-im/signal-desktop: Update to 6.35.0
-rw-r--r--net-im/signal-desktop/Makefile6
-rw-r--r--net-im/signal-desktop/distinfo10
-rw-r--r--net-im/signal-desktop/files/patch-app_main.ts11
-rw-r--r--net-im/signal-desktop/files/patch-signal-desktop149
-rw-r--r--net-im/signal-desktop/files/patch-ts_scripts_fuse-electron.ts11
-rw-r--r--net-im/signal-desktop/files/patch-ts_state_ducks_user.ts29
-rw-r--r--net-im/signal-desktop/files/patch-ts_state_getInitialState.ts20
-rw-r--r--net-im/signal-desktop/files/patch-ts_types_Settings.ts11
-rw-r--r--net-im/signal-desktop/files/patch-ts_updater_index.ts4
-rw-r--r--net-im/signal-desktop/files/patch-ts_util_getUserAgent.ts10
-rw-r--r--net-im/signal-desktop/files/patch-ts_util_os_shared.ts37
-rw-r--r--net-im/signal-desktop/get_deps.sh2
12 files changed, 138 insertions, 162 deletions
diff --git a/net-im/signal-desktop/Makefile b/net-im/signal-desktop/Makefile
index 7f56e8ba93a1..7b054fb3bded 100644
--- a/net-im/signal-desktop/Makefile
+++ b/net-im/signal-desktop/Makefile
@@ -1,6 +1,6 @@
PORTNAME= signal-desktop
DISTVERSIONPREFIX= v
-DISTVERSION= 6.34.0
+DISTVERSION= 6.35.0
CATEGORIES= net-im
MASTER_SITES= LOCAL/mikael/signal-desktop/:npm \
LOCAL/mikael/signal-desktop/:sqlite \
@@ -133,10 +133,6 @@ fetch-yarn:
${RM} -r ${WRKDIR}; \
fi
-post-patch:
- ${REINPLACE_CMD} "s#%%EPOCH%%#${_BUILD_DATE}#" \
- ${WRKSRC}/ts/scripts/get-expire-time.ts
-
post-extract:
# install yarn modules and fail silently
${ECHO_CMD} 'yarn-offline-mirror "../yarn-offline-cache"' > ${WRKSRC}/.yarnrc
diff --git a/net-im/signal-desktop/distinfo b/net-im/signal-desktop/distinfo
index bf5efd9a4ece..6d3b5b1d95bb 100644
--- a/net-im/signal-desktop/distinfo
+++ b/net-im/signal-desktop/distinfo
@@ -1,9 +1,9 @@
-TIMESTAMP = 1697273870
-SHA256 (signal-desktop-6.34.0-yarn-cache.tar.gz) = fc3e8ef83cd33da3c2cb61377d5b261550b8e4a7d328be6db64f1fcd5304d608
-SIZE (signal-desktop-6.34.0-yarn-cache.tar.gz) = 374320508
+TIMESTAMP = 1697785584
+SHA256 (signal-desktop-6.35.0-yarn-cache.tar.gz) = fc3e8ef83cd33da3c2cb61377d5b261550b8e4a7d328be6db64f1fcd5304d608
+SIZE (signal-desktop-6.35.0-yarn-cache.tar.gz) = 374320508
SHA256 (signal-desktop-6.4.1-npm-cache.tar.gz) = 8acc503a579760faf8ea660d504f3b3ffadc495bf09584228da4cc9af20e33fe
SIZE (signal-desktop-6.4.1-npm-cache.tar.gz) = 4466353
SHA256 (sqlcipher-4.5.5-fts5-fix--3.0.7--0.2.1-ef53ea45ed92b928ecfd33c552d8d405263e86e63dec38e1ec63e1b0193b630b.tar.gz) = ef53ea45ed92b928ecfd33c552d8d405263e86e63dec38e1ec63e1b0193b630b
SIZE (sqlcipher-4.5.5-fts5-fix--3.0.7--0.2.1-ef53ea45ed92b928ecfd33c552d8d405263e86e63dec38e1ec63e1b0193b630b.tar.gz) = 75708533
-SHA256 (signalapp-Signal-Desktop-v6.34.0_GH0.tar.gz) = 62cb1f6a3c835eca3a23fe379b43f93576e7d9a0e4d6098e8edab948fb671c10
-SIZE (signalapp-Signal-Desktop-v6.34.0_GH0.tar.gz) = 42556130
+SHA256 (signalapp-Signal-Desktop-v6.35.0_GH0.tar.gz) = 822a4f5b722c6288e28c2d697093fa90a2d71c63bb336ef1f6194bb11b26dc80
+SIZE (signalapp-Signal-Desktop-v6.35.0_GH0.tar.gz) = 42554576
diff --git a/net-im/signal-desktop/files/patch-app_main.ts b/net-im/signal-desktop/files/patch-app_main.ts
new file mode 100644
index 000000000000..abd04e0d996e
--- /dev/null
+++ b/net-im/signal-desktop/files/patch-app_main.ts
@@ -0,0 +1,11 @@
+--- app/main.ts.orig 2023-10-19 19:29:53 UTC
++++ app/main.ts
+@@ -648,7 +648,7 @@ if (OS.isWindows()) {
+
+ if (OS.isWindows()) {
+ windowIcon = join(__dirname, '../build/icons/win/icon.ico');
+-} else if (OS.isLinux()) {
++} else if (OS.isLinux() || OS.isFreeBSD()) {
+ windowIcon = join(__dirname, '../images/signal-logo-desktop-linux.png');
+ } else {
+ windowIcon = join(__dirname, '../build/icons/png/512x512.png');
diff --git a/net-im/signal-desktop/files/patch-signal-desktop b/net-im/signal-desktop/files/patch-signal-desktop
deleted file mode 100644
index 13a8755a56bd..000000000000
--- a/net-im/signal-desktop/files/patch-signal-desktop
+++ /dev/null
@@ -1,149 +0,0 @@
---- ts/models/messages.ts.orig 2023-02-02 21:51:07.000000000 +0100
-+++ ts/models/messages.ts 2023-02-03 18:17:14.799327000 +0100
-@@ -908,7 +908,7 @@ export class MessageModel extends window.Backbone.Mode
- });
- }
-
-- if (!window.Signal.OS.isLinux()) {
-+ if (!(window.Signal.OS.isLinux() || window.Signal.OS.isFreeBSD())) {
- return attributes.storyReaction.emoji;
- }
-
-@@ -927,7 +927,7 @@ export class MessageModel extends window.Backbone.Mode
-
- // Linux emoji support is mixed, so we disable it. (Note that this doesn't touch
- // the `text`, which can contain emoji.)
-- const shouldIncludeEmoji = Boolean(emoji) && !window.Signal.OS.isLinux();
-+ const shouldIncludeEmoji = Boolean(emoji) && !(window.Signal.OS.isLinux() || window.Signal.OS.isFreeBSD());
- if (shouldIncludeEmoji) {
- return window.i18n('message--getNotificationText--text-with-emoji', {
- text: modifiedText,
---- ts/util/getUserAgent.ts 2022-02-12 02:48:01.000000000 +0100
-+++ ts/util/getUserAgent.ts 2022-02-18 20:43:07.232944000 +0100
-@@ -7,6 +7,7 @@ const PLATFORM_STRINGS: { [platform: string]: string }
- win32: 'Windows',
- darwin: 'macOS',
- linux: 'Linux',
-+ freebsd: 'FreeBSD',
- };
-
- export function getUserAgent(appVersion: string): string {
---- ts/types/Settings.ts.orig 2022-02-16 16:11:39.000000000 +0100
-+++ ts/types/Settings.ts 2022-02-19 22:18:16.945135000 +0100
-@@ -60,7 +60,7 @@ export const getTitleBarVisibility = (): TitleBarVisib
- */
- export const isSystemTraySupported = (appVersion: string): boolean =>
- // We eventually want to support Linux in production.
-- OS.isWindows() || (OS.isLinux() && !isProduction(appVersion));
-+ OS.isWindows() || (OS.isLinux() && !isProduction(appVersion)) || (OS.isFreeBSD() && !isProduction(appVersion));
-
- export const isAutoDownloadUpdatesSupported = (): boolean =>
- OS.isWindows() || OS.isMacOS();
---- app/main.ts.orig 2022-02-24 15:35:11.986213000 +0100
-+++ app/main.ts 2022-02-24 15:34:26.610207000 +0100
-@@ -451,7 +451,7 @@ let windowIcon: string;
-
- if (OS.isWindows()) {
- windowIcon = join(__dirname, '../build/icons/win/icon.ico');
--} else if (OS.isLinux()) {
-+} else if (OS.isLinux() || OS.isFreeBSD()) {
- windowIcon = join(__dirname, '../images/signal-logo-desktop-linux.png');
- } else {
- windowIcon = join(__dirname, '../build/icons/png/512x512.png');
---- ts/state/getInitialState.ts.orig 2023-02-05 14:58:42.686190000 +0100
-+++ ts/state/getInitialState.ts 2023-02-05 14:59:18.608061000 +0100
-@@ -69,7 +69,7 @@ export function getInitialState({
-
- const theme = getThemeType();
-
-- let osName: 'windows' | 'macos' | 'linux' | undefined;
-+ let osName: 'windows' | 'macos' | 'linux' | 'freebsd' | undefined;
-
- if (OS.isWindows()) {
- osName = 'windows';
-@@ -77,6 +77,8 @@ export function getInitialState({
- osName = 'macos';
- } else if (OS.isLinux()) {
- osName = 'linux';
-+ } else if (OS.isFreeBSD()) {
-+ osName = 'freebsd';
- }
-
- return {
---- ts/scripts/fuse-electron.ts.orig 2023-02-05 15:01:26.625383000 +0100
-+++ ts/scripts/fuse-electron.ts 2023-02-05 15:02:05.602959000 +0100
-@@ -17,7 +17,7 @@ export async function afterPack({
- target = `${productFilename}.app`;
- } else if (electronPlatformName === 'win32') {
- target = `${productFilename}.exe`;
-- } else if (electronPlatformName === 'linux') {
-+ } else if (electronPlatformName === 'linux' || electronPlatformName === 'freebsd') {
- // Sadly, `LinuxPackager` type is not exported by electron-builder so we
- // have to improvise
- target = (packager as unknown as { executableName: string }).executableName;
---- ts/state/ducks/user.ts.orig 2023-09-06 22:21:55.000000000 +0200
-+++ ts/state/ducks/user.ts 2023-09-07 19:44:10.838670000 +0200
-@@ -23,7 +23,7 @@ export type UserStateType = Readonly<{
- isMainWindowMaximized: boolean;
- localeMessages: LocaleMessagesType;
- menuOptions: MenuOptionsType;
-- osName: 'linux' | 'macos' | 'windows' | undefined;
-+ osName: 'linux' | 'macos' | 'windows' | 'freebsd' | undefined;
- ourAci: AciString | undefined;
- ourConversationId: string | undefined;
- ourDeviceId: number | undefined;
-@@ -114,7 +114,7 @@ export function getEmptyState(): UserStateType {
- // Reducer
-
- export function getEmptyState(): UserStateType {
-- let osName: 'windows' | 'macos' | 'linux' | undefined;
-+ let osName: 'windows' | 'macos' | 'linux' | 'freebsd' | undefined;
-
- if (OS.isWindows()) {
- osName = 'windows';
-@@ -122,6 +122,8 @@ export function getEmptyState(): UserStateType {
- osName = 'macos';
- } else if (OS.isLinux()) {
- osName = 'linux';
-+ } else if (OS.isFreeBSD()) {
-+ osName = 'freebsd';
- }
-
- return {
---- ts/util/os/shared.ts.orig 2023-05-11 11:10:27.504955000 +0200
-+++ ts/util/os/shared.ts 2023-05-11 11:11:17.326542000 +0200
-@@ -32,6 +32,7 @@ export function getOSFunctions(osRelease: string): OST
- const isMacOS = createIsPlatform('darwin', osRelease);
- const isLinux = createIsPlatform('linux', osRelease);
- const isWindows = createIsPlatform('win32', osRelease);
-+ const isFreeBSD = createIsPlatform('freebsd', osRelease);
-
- // Windows 10 and above
- const hasCustomTitleBar = (): boolean =>
-@@ -44,6 +45,9 @@ export function getOSFunctions(osRelease: string): OST
- if (isWindows()) {
- return 'Windows';
- }
-+ if (isFreeBSD()) {
-+ return 'FreeBSD';
-+ }
- return 'Linux';
- };
-
-@@ -54,6 +58,9 @@ export function getOSFunctions(osRelease: string): OST
- if (isWindows()) {
- return 'os-windows';
- }
-+ if (isFreeBSD()) {
-+ return 'os-freebsd';
-+ }
- return 'os-linux';
- };
-
-@@ -64,5 +71,6 @@ export function getOSFunctions(osRelease: string): OST
- isLinux,
- isMacOS,
- isWindows,
-+ isFreeBSD,
- };
- }
diff --git a/net-im/signal-desktop/files/patch-ts_scripts_fuse-electron.ts b/net-im/signal-desktop/files/patch-ts_scripts_fuse-electron.ts
new file mode 100644
index 000000000000..c5628e9f2e78
--- /dev/null
+++ b/net-im/signal-desktop/files/patch-ts_scripts_fuse-electron.ts
@@ -0,0 +1,11 @@
+--- ts/scripts/fuse-electron.ts.orig 2023-10-19 19:29:53 UTC
++++ ts/scripts/fuse-electron.ts
+@@ -17,7 +17,7 @@ export async function afterPack({
+ target = `${productFilename}.app`;
+ } else if (electronPlatformName === 'win32') {
+ target = `${productFilename}.exe`;
+- } else if (electronPlatformName === 'linux') {
++ } else if (electronPlatformName === 'linux' || electronPlatformName === 'freebsd') {
+ // Sadly, `LinuxPackager` type is not exported by electron-builder so we
+ // have to improvise
+ target = (packager as unknown as { executableName: string }).executableName;
diff --git a/net-im/signal-desktop/files/patch-ts_state_ducks_user.ts b/net-im/signal-desktop/files/patch-ts_state_ducks_user.ts
new file mode 100644
index 000000000000..12f1493dab46
--- /dev/null
+++ b/net-im/signal-desktop/files/patch-ts_state_ducks_user.ts
@@ -0,0 +1,29 @@
+--- ts/state/ducks/user.ts.orig 2023-10-19 19:29:53 UTC
++++ ts/state/ducks/user.ts
+@@ -23,7 +23,7 @@ export type UserStateType = Readonly<{
+ isMainWindowMaximized: boolean;
+ localeMessages: LocaleMessagesType;
+ menuOptions: MenuOptionsType;
+- osName: 'linux' | 'macos' | 'windows' | undefined;
++ osName: 'linux' | 'macos' | 'windows' | 'freebsd' | undefined;
+ ourAci: AciString | undefined;
+ ourConversationId: string | undefined;
+ ourDeviceId: number | undefined;
+@@ -114,7 +114,7 @@ export function getEmptyState(): UserStateType {
+ // Reducer
+
+ export function getEmptyState(): UserStateType {
+- let osName: 'windows' | 'macos' | 'linux' | undefined;
++ let osName: 'windows' | 'macos' | 'linux' | 'freebsd' | undefined;
+
+ if (OS.isWindows()) {
+ osName = 'windows';
+@@ -122,6 +122,8 @@ export function getEmptyState(): UserStateType {
+ osName = 'macos';
+ } else if (OS.isLinux()) {
+ osName = 'linux';
++ } else if (OS.isFreeBSD()) {
++ osName = 'freebsd';
+ }
+
+ return {
diff --git a/net-im/signal-desktop/files/patch-ts_state_getInitialState.ts b/net-im/signal-desktop/files/patch-ts_state_getInitialState.ts
new file mode 100644
index 000000000000..92ba02386fe6
--- /dev/null
+++ b/net-im/signal-desktop/files/patch-ts_state_getInitialState.ts
@@ -0,0 +1,20 @@
+--- ts/state/getInitialState.ts.orig 2023-10-19 19:29:53 UTC
++++ ts/state/getInitialState.ts
+@@ -72,7 +72,7 @@ export function getInitialState({
+
+ const theme = getThemeType();
+
+- let osName: 'windows' | 'macos' | 'linux' | undefined;
++ let osName: 'windows' | 'macos' | 'linux' | 'freebsd' | undefined;
+
+ if (OS.isWindows()) {
+ osName = 'windows';
+@@ -80,6 +80,8 @@ export function getInitialState({
+ osName = 'macos';
+ } else if (OS.isLinux()) {
+ osName = 'linux';
++ } else if (OS.isFreeBSD()) {
++ osName = 'freebsd';
+ }
+
+ return {
diff --git a/net-im/signal-desktop/files/patch-ts_types_Settings.ts b/net-im/signal-desktop/files/patch-ts_types_Settings.ts
new file mode 100644
index 000000000000..950e6adf8fb4
--- /dev/null
+++ b/net-im/signal-desktop/files/patch-ts_types_Settings.ts
@@ -0,0 +1,11 @@
+--- ts/types/Settings.ts.orig 2023-10-19 19:29:53 UTC
++++ ts/types/Settings.ts
+@@ -34,7 +34,7 @@ export const isSystemTraySupported = (
+ appVersion: string
+ ): boolean =>
+ // We eventually want to support Linux in production.
+- OS.isWindows() || (OS.isLinux() && !isProduction(appVersion));
++ OS.isWindows() || (OS.isLinux() && !isProduction(appVersion)) || (OS.isFreeBSD() && !isProduction(appVersion));
+
+ // On Windows minimize and start in system tray is default when app is selected
+ // to launch at login, because we can provide `['--start-in-tray']` args.
diff --git a/net-im/signal-desktop/files/patch-ts_updater_index.ts b/net-im/signal-desktop/files/patch-ts_updater_index.ts
index b2882bff6384..b87f5678d1a7 100644
--- a/net-im/signal-desktop/files/patch-ts_updater_index.ts
+++ b/net-im/signal-desktop/files/patch-ts_updater_index.ts
@@ -1,6 +1,6 @@
---- ts/updater/index.ts.orig 2022-12-04 09:57:09 UTC
+--- ts/updater/index.ts.orig 2023-10-19 19:29:53 UTC
+++ ts/updater/index.ts
-@@ -61,6 +61,6 @@ function autoUpdateDisabled() {
+@@ -72,6 +72,6 @@ function autoUpdateDisabled() {
function autoUpdateDisabled() {
return (
diff --git a/net-im/signal-desktop/files/patch-ts_util_getUserAgent.ts b/net-im/signal-desktop/files/patch-ts_util_getUserAgent.ts
new file mode 100644
index 000000000000..4d540e455587
--- /dev/null
+++ b/net-im/signal-desktop/files/patch-ts_util_getUserAgent.ts
@@ -0,0 +1,10 @@
+--- ts/util/getUserAgent.ts.orig 2023-10-19 19:29:53 UTC
++++ ts/util/getUserAgent.ts
+@@ -9,6 +9,7 @@ const PLATFORM_STRINGS: { [platform: string]: string }
+ win32: 'Windows',
+ darwin: 'macOS',
+ linux: 'Linux',
++ freebsd: 'FreeBSD',
+ };
+
+ export function getUserAgent(
diff --git a/net-im/signal-desktop/files/patch-ts_util_os_shared.ts b/net-im/signal-desktop/files/patch-ts_util_os_shared.ts
new file mode 100644
index 000000000000..01fb523e2d3a
--- /dev/null
+++ b/net-im/signal-desktop/files/patch-ts_util_os_shared.ts
@@ -0,0 +1,37 @@
+--- ts/util/os/shared.ts.orig 2023-10-19 19:29:53 UTC
++++ ts/util/os/shared.ts
+@@ -32,6 +32,7 @@ export function getOSFunctions(osRelease: string): OST
+ const isMacOS = createIsPlatform('darwin', osRelease);
+ const isLinux = createIsPlatform('linux', osRelease);
+ const isWindows = createIsPlatform('win32', osRelease);
++ const isFreeBSD = createIsPlatform('freebsd', osRelease);
+
+ // Windows 10 and above
+ const hasCustomTitleBar = (): boolean =>
+@@ -44,6 +45,9 @@ export function getOSFunctions(osRelease: string): OST
+ if (isWindows()) {
+ return 'Windows';
+ }
++ if (isFreeBSD()) {
++ return 'FreeBSD';
++ }
+ return 'Linux';
+ };
+
+@@ -54,6 +58,9 @@ export function getOSFunctions(osRelease: string): OST
+ if (isWindows()) {
+ return 'os-windows';
+ }
++ if (isFreeBSD()) {
++ return 'os-freebsd';
++ }
+ return 'os-linux';
+ };
+
+@@ -64,5 +71,6 @@ export function getOSFunctions(osRelease: string): OST
+ isLinux,
+ isMacOS,
+ isWindows,
++ isFreeBSD,
+ };
+ }
diff --git a/net-im/signal-desktop/get_deps.sh b/net-im/signal-desktop/get_deps.sh
index 573200e4c5ce..bc504e3101b3 100644
--- a/net-im/signal-desktop/get_deps.sh
+++ b/net-im/signal-desktop/get_deps.sh
@@ -1,5 +1,5 @@
#!/bin/sh
-SIGNAL_VERS=v6.34.0
+SIGNAL_VERS=v6.35.0
fetch -qo /tmp/package.json https://raw.githubusercontent.com/signalapp/Signal-Desktop/${SIGNAL_VERS}/package.json
node_version=$(awk /'"node":'/'{print $2}' /tmp/package.json | sed 's/"//g')