aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-05-02 22:29:01 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-06-10 11:49:19 +0000
commit6a35e5955febec016fa521f90e1dca83233644cf (patch)
tree37049e4607c7ab53dee5d677899059cd2fedf3b9
parent1b2eb54f09d898e37df357a5c63621bc966d8d83 (diff)
downloadports-6a35e5955febec016fa521f90e1dca83233644cf.tar.gz
ports-6a35e5955febec016fa521f90e1dca83233644cf.zip
lang/php8*: Remove stale NOOP codes
json module is by default built into php and these module configs were stale. (cherry picked from commit 1d1273b22cfd4f5f044f93faa3be4d2982d0d255)
-rw-r--r--lang/php81/Makefile5
-rw-r--r--lang/php82/Makefile5
-rw-r--r--lang/php83/Makefile5
3 files changed, 0 insertions, 15 deletions
diff --git a/lang/php81/Makefile b/lang/php81/Makefile
index 3e84b20992aa..4fc722c97c01 100644
--- a/lang/php81/Makefile
+++ b/lang/php81/Makefile
@@ -357,11 +357,6 @@ USES+= pkgconfig
CPPFLAGS+= -DU_USING_ICU_NAMESPACE=1
.endif
-.if ${PHP_MODNAME} == "json"
-CONFIGURE_ARGS+= --enable-json
-BUILD_DEPENDS= re2c:devel/re2c
-.endif
-
.if ${PHP_MODNAME} == "ldap"
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE} --with-ldap-sasl=${LOCALBASE}
USES+= ldap
diff --git a/lang/php82/Makefile b/lang/php82/Makefile
index 15d7041e8ac7..1cdb8385392e 100644
--- a/lang/php82/Makefile
+++ b/lang/php82/Makefile
@@ -354,11 +354,6 @@ USES+= pkgconfig
CPPFLAGS+= -DU_USING_ICU_NAMESPACE=1
.endif
-.if ${PHP_MODNAME} == "json"
-CONFIGURE_ARGS+= --enable-json
-BUILD_DEPENDS= re2c:devel/re2c
-.endif
-
.if ${PHP_MODNAME} == "ldap"
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE} --with-ldap-sasl=${LOCALBASE}
USES+= ldap
diff --git a/lang/php83/Makefile b/lang/php83/Makefile
index e653aac29e4f..cc6d68e1bce2 100644
--- a/lang/php83/Makefile
+++ b/lang/php83/Makefile
@@ -372,11 +372,6 @@ USES+= pkgconfig
CPPFLAGS+= -DU_USING_ICU_NAMESPACE=1
.endif
-.if ${PHP_MODNAME} == "json"
-CONFIGURE_ARGS+= --enable-json
-BUILD_DEPENDS= re2c:devel/re2c
-.endif
-
.if ${PHP_MODNAME} == "ldap"
LIB_DEPENDS+=libsasl2.so:security/cyrus-sasl2
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE} --with-ldap-sasl=${LOCALBASE}