aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-04 13:56:39 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-04 15:00:13 +0000
commit6a53dee4f524aae69186288bf4c19e00f4e237cb (patch)
treeaf03c52a65bbf01483b4a0e4af59492ffc176a0c
parenta2e1cfa6d7c88e66b6d48873496c21e8c560932b (diff)
downloadports-6a53dee4f524aae69186288bf4c19e00f4e237cb.tar.gz
ports-6a53dee4f524aae69186288bf4c19e00f4e237cb.zip
security/gost-engine: Fix build with OpenSSL 3.0.0
- Although this ports sets up different flavor for base and openssl30 however it was not checking the SSL_DEFAULT and was always building with base even though SSL_DEFAULT was openssl30. This commit fixes this by checking the SSL_DEFAULT and changing the default FLAVOR. - Add additional pkg-plist for openssl30 flavor - Remove unused BROKEN_SSL_REASON_* which were not mentioned in BROKEN_SSL Approved by: portmgr (blanket)
-rw-r--r--security/gost-engine/Makefile7
-rw-r--r--security/gost-engine/pkg-plist-openssl3016
2 files changed, 21 insertions, 2 deletions
diff --git a/security/gost-engine/Makefile b/security/gost-engine/Makefile
index 7d8729e52a98..22881074bb70 100644
--- a/security/gost-engine/Makefile
+++ b/security/gost-engine/Makefile
@@ -11,12 +11,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
FLAVORS= base openssl30
openssl30_PKGNAMESUFFIX= -${FLAVOR}
+openssl30_PLIST= ${.CURDIR}/pkg-plist-${FLAVOR}
BROKEN_SSL= libressl libressl-devel openssl31
BROKEN_SSL_REASON_libressl= needs features only available in OpenSSL 1.1.1+
BROKEN_SSL_REASON_libressl-devel= needs features only available in OpenSSL 1.1.1+
-BROKEN_SSL_REASON_base= needs either ssl=${FLAVOR} or FLAVOR=base
-BROKEN_SSL_REASON_openssl30= needs either ssl=${FLAVOR} or FLAVOR=openssl30
BROKEN_SSL_REASON_openssl31= not ready for openssl31
BUILD_DEPENDS= cmake>=3.18.1:devel/cmake
@@ -55,6 +54,10 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
+.if ${SSL_DEFAULT} == openssl30
+FLAVOR= openssl30
+.endif
+
.if ${FLAVOR:U} == base
post-patch:
${REINPLACE_CMD} 's/-Werror //' ${WRKSRC}/CMakeLists.txt
diff --git a/security/gost-engine/pkg-plist-openssl30 b/security/gost-engine/pkg-plist-openssl30
new file mode 100644
index 000000000000..a4c8b49c89c9
--- /dev/null
+++ b/security/gost-engine/pkg-plist-openssl30
@@ -0,0 +1,16 @@
+bin/gost12sum
+bin/gostsum
+%%EDIR%%/gost.so
+%%EDIRV%%/libgost.so.1.1
+lib/libgost.so
+lib/libgostprov.so
+lib/ossl-modules/gostprov.so
+share/cmake/GostEngine/GostEngineConfig-%%CMAKE_BUILD_TYPE%%.cmake
+share/cmake/GostEngine/GostEngineConfig.cmake
+share/cmake/GostProvider/GostProviderConfig-%%CMAKE_BUILD_TYPE%%.cmake
+share/cmake/GostProvider/GostProviderConfig.cmake
+%%PORTDOCS%%share/man/man1/gost12sum.1.gz
+%%PORTDOCS%%share/man/man1/gostsum.1.gz
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL.md
+%%PORTDOCS%%%%DOCSDIR%%/README.gost
+%%PORTDOCS%%%%DOCSDIR%%/README.md