aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-05 17:25:21 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-05 17:31:48 +0000
commit6ab64b0e47928f8dea9baf9a7a17ed8abb75781c (patch)
treeee2704c6786eb2d982aad87bc41c0fb47e1b0106
parente7106b3555202000c2ef6dbf23ada43be146b6b1 (diff)
downloadports-6ab64b0e47928f8dea9baf9a7a17ed8abb75781c.tar.gz
ports-6ab64b0e47928f8dea9baf9a7a17ed8abb75781c.zip
devel/py-nbconvert: Update to 7.2.10
- Convert to USE_PYTHON=pep517 Changes: https://github.com/jupyter/nbconvert/releases
-rw-r--r--devel/py-nbconvert/Makefile16
-rw-r--r--devel/py-nbconvert/distinfo6
-rw-r--r--devel/py-nbconvert/files/setup.py108
-rw-r--r--devel/py-nbconvert/pkg-plist48
4 files changed, 9 insertions, 169 deletions
diff --git a/devel/py-nbconvert/Makefile b/devel/py-nbconvert/Makefile
index 7aea25d7e06d..6e65b2e28e79 100644
--- a/devel/py-nbconvert/Makefile
+++ b/devel/py-nbconvert/Makefile
@@ -1,5 +1,5 @@
PORTNAME= nbconvert
-PORTVERSION= 7.2.9
+PORTVERSION= 7.2.10
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,6 +11,7 @@ WWW= https://jupyter.org/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0.25:devel/py-hatchling@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=0:www/py-beautifulsoup@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}bleach>=0:www/py-bleach@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}defusedxml>=0:devel/py-defusedxml@${PY_FLAVOR} \
@@ -27,22 +28,17 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=0:www/py-beautifulsoup@${PY_F
${PYTHON_PKGNAMEPREFIX}tinycss2>=0:textproc/py-tinycss2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}traitlets>=5.0:devel/py-traitlets@${PY_FLAVOR}
-USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USES= python:3.7+ shebangfix
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
+SHEBANG_FILES= nbconvert/nbconvertapp.py
+
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 31000
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=3.6:devel/py-importlib-metadata@${PY_FLAVOR}
.endif
-post-patch:
- @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
-
-post-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/jupyter/nbconvert
- cd ${WRKSRC}/share && ${COPYTREE_SHARE} templates ${STAGEDIR}${PREFIX}/share/jupyter/nbconvert
-
.include <bsd.port.post.mk>
diff --git a/devel/py-nbconvert/distinfo b/devel/py-nbconvert/distinfo
index 9cab187925dd..fda5e85d4f3c 100644
--- a/devel/py-nbconvert/distinfo
+++ b/devel/py-nbconvert/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1675192019
-SHA256 (nbconvert-7.2.9.tar.gz) = a42c3ac137c64f70cbe4d763111bf358641ea53b37a01a5c202ed86374af5234
-SIZE (nbconvert-7.2.9.tar.gz) = 870386
+TIMESTAMP = 1679499200
+SHA256 (nbconvert-7.2.10.tar.gz) = 8eed67bd8314f3ec87c4351c2f674af3a04e5890ab905d6bd927c05aec1cf27d
+SIZE (nbconvert-7.2.10.tar.gz) = 870708
diff --git a/devel/py-nbconvert/files/setup.py b/devel/py-nbconvert/files/setup.py
deleted file mode 100644
index e3dac6ab74c9..000000000000
--- a/devel/py-nbconvert/files/setup.py
+++ /dev/null
@@ -1,108 +0,0 @@
-# -*- coding: utf-8 -*-
-from setuptools import setup
-
-setup(
- name='nbconvert',
- version='%%PORTVERSION%%',
- description='Converting Jupyter Notebooks',
- long_description='# nbconvert\n\n### Jupyter Notebook Conversion\n\n[![Build Status](https://travis-ci.org/jupyter/nbconvert.svg?branch=main)](https://travis-ci.org/jupyter/nbconvert)\n[![Documentation Status](https://readthedocs.org/projects/nbconvert/badge/?version=latest)](https://nbconvert.readthedocs.io/en/latest/?badge=latest)\n[![codecov.io](https://codecov.io/gh/jupyter/nbconvert/coverage.svg?branch=main)](https://codecov.io/gh/gh/nbconvert?branch=main)\n\nThe **nbconvert** tool, `jupyter nbconvert`, converts notebooks to various other\nformats via [Jinja] templates. The nbconvert tool allows you to convert an\n`.ipynb` notebook file into various static formats including:\n\n- HTML\n- LaTeX\n- PDF\n- Reveal JS\n- Markdown (md)\n- ReStructured Text (rst)\n- executable script\n\n## Usage\n\nFrom the command line, use nbconvert to convert a Jupyter notebook (_input_) to a\na different format (_output_). The basic command structure is:\n\n```\n$ jupyter nbconvert --to <output format> <input notebook>\n```\n\nwhere `<output format>` is the desired output format and `<input notebook>` is the\nfilename of the Jupyter notebook.\n\n### Example: Convert a notebook to HTML\n\nConvert Jupyter notebook file, `mynotebook.ipynb`, to HTML using:\n\n```\n$ jupyter nbconvert --to html mynotebook.ipynb\n```\n\nThis command creates an HTML output file named `mynotebook.html`.\n\n## Dev Install\n\nCheck if pandoc is installed (`pandoc --version`); if needed, install:\n\n```\nsudo apt-get install pandoc\n```\n\nOr\n\n```\nbrew install pandoc\n```\n\nInstall nbconvert for development using:\n\n```\ngit clone https://github.com/jupyter/nbconvert.git\ncd nbconvert\npip install -e .\n```\n\nRunning the tests after a dev install above:\n\n```\npip install nbconvert[test]\npy.test --pyargs nbconvert\n```\n\n## Documentation\n\n- [Documentation for Jupyter nbconvert](https://nbconvert.readthedocs.io/en/latest/)\n \\[[PDF](https://media.readthedocs.org/pdf/nbconvert/latest/nbconvert.pdf)\\]\n- [nbconvert examples on GitHub](https://github.com/jupyter/nbconvert-examples)\n- [Documentation for Project Jupyter](https://jupyter.readthedocs.io/en/latest/index.html)\n \\[[PDF](https://media.readthedocs.org/pdf/jupyter/latest/jupyter.pdf)\\]\n\n## Technical Support\n\n- [Issues and Bug Reports](https://github.com/jupyter/nbconvert/issues): A place to report\n bugs or regressions found for nbconvert\n- [Community Technical Support and Discussion - Discourse](https://discourse.jupyter.org/): A place for\n installation, configuration, and troubleshooting assistannce by the Jupyter community.\n As a non-profit project and maintainers who are primarily volunteers, we encourage you\n to ask questions and share your knowledge on Discourse.\n\n## Jupyter Resources\n\n- [Jupyter mailing list](https://groups.google.com/forum/#!forum/jupyter)\n- [Project Jupyter website](https://jupyter.org)\n\n[jinja]: http://jinja.pocoo.org/\n',
- author_email='Jupyter Development Team <jupyter@googlegroups.com>',
- classifiers=[
- 'Intended Audience :: Developers',
- 'Intended Audience :: Science/Research',
- 'Intended Audience :: System Administrators',
- 'License :: OSI Approved :: BSD License',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 3',
- ],
- install_requires=[
- 'beautifulsoup4',
- 'bleach',
- 'defusedxml',
- 'importlib-metadata>=3.6; python_version < "3.10"',
- 'jinja2>=3.0',
- 'jupyter-core>=4.7',
- 'jupyterlab-pygments',
- 'markupsafe>=2.0',
- 'mistune<3,>=2.0.3',
- 'nbclient>=0.5.0',
- 'nbformat>=5.1',
- 'packaging',
- 'pandocfilters>=1.4.1',
- 'pygments>=2.4.1',
- 'tinycss2',
- 'traitlets>=5.0',
- ],
- extras_require={
- 'all': [
- 'nbconvert[docs,qtpdf,serve,test,webpdf]',
- ],
- 'docs': [
- 'ipykernel',
- 'ipython',
- 'myst-parser',
- 'nbsphinx>=0.2.12',
- 'pydata-sphinx-theme',
- 'sphinx==5.0.2',
- 'sphinxcontrib-spelling',
- ],
- 'qtpdf': [
- 'nbconvert[qtpng]',
- ],
- 'qtpng': [
- 'pyqtwebengine>=5.15',
- ],
- 'serve': [
- 'tornado>=6.1',
- ],
- 'test': [
- 'ipykernel',
- 'ipywidgets>=7',
- 'pre-commit',
- 'pytest',
- 'pytest-dependency',
- ],
- 'webpdf': [
- 'pyppeteer<1.1,>=1',
- ],
- },
- entry_points={
- 'console_scripts': [
- 'jupyter-dejavu = nbconvert.nbconvertapp:dejavu_main',
- 'jupyter-nbconvert = nbconvert.nbconvertapp:main',
- ],
- 'nbconvert.exporters': [
- 'asciidoc = nbconvert.exporters:ASCIIDocExporter',
- 'custom = nbconvert.exporters:TemplateExporter',
- 'html = nbconvert.exporters:HTMLExporter',
- 'latex = nbconvert.exporters:LatexExporter',
- 'markdown = nbconvert.exporters:MarkdownExporter',
- 'notebook = nbconvert.exporters:NotebookExporter',
- 'pdf = nbconvert.exporters:PDFExporter',
- 'python = nbconvert.exporters:PythonExporter',
- 'qtpdf = nbconvert.exporters:QtPDFExporter',
- 'qtpng = nbconvert.exporters:QtPNGExporter',
- 'rst = nbconvert.exporters:RSTExporter',
- 'script = nbconvert.exporters:ScriptExporter',
- 'slides = nbconvert.exporters:SlidesExporter',
- 'webpdf = nbconvert.exporters:WebPDFExporter',
- ],
- },
- packages=[
- 'nbconvert',
- 'nbconvert.exporters',
- 'nbconvert.exporters.tests',
- 'nbconvert.filters',
- 'nbconvert.filters.tests',
- 'nbconvert.postprocessors',
- 'nbconvert.postprocessors.tests',
- 'nbconvert.preprocessors',
- 'nbconvert.preprocessors.tests',
- 'nbconvert.resources',
- 'nbconvert.tests',
- 'nbconvert.utils',
- 'nbconvert.utils.tests',
- 'nbconvert.writers',
- 'nbconvert.writers.tests',
- ],
-)
diff --git a/devel/py-nbconvert/pkg-plist b/devel/py-nbconvert/pkg-plist
deleted file mode 100644
index 4fa14600657b..000000000000
--- a/devel/py-nbconvert/pkg-plist
+++ /dev/null
@@ -1,48 +0,0 @@
-share/jupyter/nbconvert/templates/asciidoc/conf.json
-share/jupyter/nbconvert/templates/asciidoc/index.asciidoc.j2
-share/jupyter/nbconvert/templates/base/celltags.j2
-share/jupyter/nbconvert/templates/base/display_priority.j2
-share/jupyter/nbconvert/templates/base/jupyter_widgets.html.j2
-share/jupyter/nbconvert/templates/base/mathjax.html.j2
-share/jupyter/nbconvert/templates/base/null.j2
-share/jupyter/nbconvert/templates/basic/conf.json
-share/jupyter/nbconvert/templates/basic/index.html.j2
-share/jupyter/nbconvert/templates/classic/base.html.j2
-share/jupyter/nbconvert/templates/classic/conf.json
-share/jupyter/nbconvert/templates/classic/index.html.j2
-share/jupyter/nbconvert/templates/classic/static/style.css
-share/jupyter/nbconvert/templates/compatibility/display_priority.tpl
-share/jupyter/nbconvert/templates/compatibility/full.tpl
-share/jupyter/nbconvert/templates/lab/base.html.j2
-share/jupyter/nbconvert/templates/lab/conf.json
-share/jupyter/nbconvert/templates/lab/index.html.j2
-share/jupyter/nbconvert/templates/lab/static/index.css
-share/jupyter/nbconvert/templates/lab/static/theme-dark.css
-share/jupyter/nbconvert/templates/lab/static/theme-light.css
-share/jupyter/nbconvert/templates/latex/base.tex.j2
-share/jupyter/nbconvert/templates/latex/conf.json
-share/jupyter/nbconvert/templates/latex/display_priority.j2
-share/jupyter/nbconvert/templates/latex/document_contents.tex.j2
-share/jupyter/nbconvert/templates/latex/index.tex.j2
-share/jupyter/nbconvert/templates/latex/null.j2
-share/jupyter/nbconvert/templates/latex/report.tex.j2
-share/jupyter/nbconvert/templates/latex/style_bw_ipython.tex.j2
-share/jupyter/nbconvert/templates/latex/style_bw_python.tex.j2
-share/jupyter/nbconvert/templates/latex/style_ipython.tex.j2
-share/jupyter/nbconvert/templates/latex/style_jupyter.tex.j2
-share/jupyter/nbconvert/templates/latex/style_python.tex.j2
-share/jupyter/nbconvert/templates/markdown/conf.json
-share/jupyter/nbconvert/templates/markdown/index.md.j2
-share/jupyter/nbconvert/templates/python/conf.json
-share/jupyter/nbconvert/templates/python/index.py.j2
-share/jupyter/nbconvert/templates/reveal/base.html.j2
-share/jupyter/nbconvert/templates/reveal/cellslidedata.j2
-share/jupyter/nbconvert/templates/reveal/conf.json
-share/jupyter/nbconvert/templates/reveal/index.html.j2
-share/jupyter/nbconvert/templates/reveal/static/custom_reveal.css
-share/jupyter/nbconvert/templates/rst/conf.json
-share/jupyter/nbconvert/templates/rst/index.rst.j2
-share/jupyter/nbconvert/templates/script/conf.json
-share/jupyter/nbconvert/templates/script/script.j2
-share/jupyter/nbconvert/templates/webpdf/conf.json
-share/jupyter/nbconvert/templates/webpdf/index.pdf.j2