aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2023-11-24 12:38:32 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2023-11-24 12:39:58 +0000
commit6abf052d171d602a9b3c5de1f94061b9fb4bfb16 (patch)
tree9af8186b7c4d618ea63d7035c23196de73ffa445
parentc213ae832537a857e0a98f90e69f774bb918e4f0 (diff)
downloadports-6abf052d171d602a9b3c5de1f94061b9fb4bfb16.tar.gz
ports-6abf052d171d602a9b3c5de1f94061b9fb4bfb16.zip
graphics/mesa: Re-add --undefined-version
This is needed for linking with lld 17 and it was lost in the update to 23.1.8 Reported by: dim Fixes: 29d855b6f775 ("graphics/mesa: update to 23.1.8") Sponsored by: Beckohh Automation GmbH & Co. KG
-rw-r--r--graphics/mesa-dri/Makefile.common6
1 files changed, 6 insertions, 0 deletions
diff --git a/graphics/mesa-dri/Makefile.common b/graphics/mesa-dri/Makefile.common
index c046d4f0eb4e..1095a78d359c 100644
--- a/graphics/mesa-dri/Makefile.common
+++ b/graphics/mesa-dri/Makefile.common
@@ -82,6 +82,12 @@ BINARY_ALIAS+= python3=${PYTHON_VERSION}
CONFIGURE_ENV+= LLVM_CONFIG=${LLVM_CONFIG}
+
+# Some symbols in mesa's linker version scripts are not always defined,
+# depending on configuration options. Suppress errors with lld >= 17 due to
+# these undefined symbols.
+LDFLAGS+= -Wl,--undefined-version
+
LDFLAGS+= -Wl,-rpath=${LOCALBASE}/llvm${LLVM_VERSION}/lib
MESON_ARGS+= -Dllvm=enabled \
-Dlibunwind=disabled \