aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2011-06-11 19:28:36 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2011-06-11 19:28:36 +0000
commit6b24cc548e440c5cc46ad7265daa1cfe51aa453e (patch)
tree99ea00093742d1bc0b4541d44f3593a5cffeeb35
parenta6593cd0926794afc9791fc5bfc442ea8bc05434 (diff)
downloadports-6b24cc548e440c5cc46ad7265daa1cfe51aa453e.tar.gz
ports-6b24cc548e440c5cc46ad7265daa1cfe51aa453e.zip
- Update to 2.6.6
PR: ports/157352 Submitted by: Niclas Zeising <niclas.zeising@gmail.com>
Notes
Notes: svn path=/head/; revision=275397
-rw-r--r--security/amavisd-new/Makefile5
-rw-r--r--security/amavisd-new/distinfo4
-rw-r--r--security/amavisd-new/files/patch-amavisd72
3 files changed, 5 insertions, 76 deletions
diff --git a/security/amavisd-new/Makefile b/security/amavisd-new/Makefile
index 78c2aa62e624..d4face39f755 100644
--- a/security/amavisd-new/Makefile
+++ b/security/amavisd-new/Makefile
@@ -7,8 +7,7 @@
# Based on amavisd ports makefile.
PORTNAME= amavisd-new
-PORTVERSION= 2.6.4
-PORTREVISION= 11
+PORTVERSION= 2.6.6
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= http://www.ijs.si/software/amavisd/ \
@@ -18,6 +17,8 @@ MASTER_SITES= http://www.ijs.si/software/amavisd/ \
MAINTAINER= gabor@FreeBSD.org
COMMENT= Performance-enhanced daemonized version of amavis-perl
+LICENCE= GPLv2
+
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Unix/Syslog.pm:${PORTSDIR}/sysutils/p5-Unix-Syslog \
${SITE_PERL}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools \
${SITE_PERL}/Convert/TNEF.pm:${PORTSDIR}/converters/p5-Convert-TNEF \
diff --git a/security/amavisd-new/distinfo b/security/amavisd-new/distinfo
index 6f8fbcd83696..3badf8f6dde3 100644
--- a/security/amavisd-new/distinfo
+++ b/security/amavisd-new/distinfo
@@ -1,2 +1,2 @@
-SHA256 (amavisd-new-2.6.4.tar.gz) = 40fe1b655deb934c7a655a6b5b430df268ec9ac80754b120795bc45d4ae769ef
-SIZE (amavisd-new-2.6.4.tar.gz) = 947596
+SHA256 (amavisd-new-2.6.6.tar.gz) = 4d3ce005f63dce8ce474e07bec001dac545871e2bf5641c1ffebff6b979e33d5
+SIZE (amavisd-new-2.6.6.tar.gz) = 952177
diff --git a/security/amavisd-new/files/patch-amavisd b/security/amavisd-new/files/patch-amavisd
deleted file mode 100644
index c79491a8c807..000000000000
--- a/security/amavisd-new/files/patch-amavisd
+++ /dev/null
@@ -1,72 +0,0 @@
---- amavisd.orig 2009-06-25 14:39:01.000000000 +0200
-+++ amavisd 2009-08-01 13:51:53.000000000 +0200
-@@ -1492,6 +1492,7 @@
- CC_BANNED, sub { c('final_banned_destiny') },
- CC_SPAM, sub { c('final_spam_destiny') },
- CC_BADH, sub { c('final_bad_header_destiny') },
-+ CC_MTA.',2', D_REJECT,
- CC_OVERSIZED, D_BOUNCE,
- CC_CATCHALL, D_PASS,
- );
-@@ -11316,6 +11317,32 @@
- $r->blocking_ccat($blocking_ccat) if !defined($r->blocking_ccat);
- $msginfo->blocking_ccat($blocking_ccat)
- if !defined($msginfo->blocking_ccat);
-+ my($final_destiny) =
-+ $r->setting_by_contents_category(cr('final_destiny_by_ccat'));
-+ if ($final_destiny == D_PASS) {
-+ $final_destiny = D_REJECT; # impossible to pass, change to reject
-+ }
-+ local($1,$2);
-+ $r->recip_destiny($final_destiny);
-+ if ($final_destiny == D_DISCARD && $smtp_resp =~ /^5/) {
-+ $smtp_resp =~ s{^5(\d\d) 5(\.\d\.\d)}{250 2$2}; # 5xx -> 250
-+ }
-+ my($smtp_reason) = # get the custom smtp response reason text
-+ $r->setting_by_contents_category(cr('smtp_reason_by_ccat'));
-+ $smtp_reason = '' if !defined $smtp_reason;
-+ if ($smtp_reason ne '') {
-+ my(%mybuiltins) = %builtins; # make a local copy
-+ $smtp_reason = expand(\$smtp_reason, \%mybuiltins);
-+ $smtp_reason = !ref($smtp_reason) ? '' : $$smtp_reason;
-+ chomp($smtp_reason); $smtp_reason = sanitize_str($smtp_reason,1);
-+ $smtp_reason = substr($smtp_reason,0,100) . "..."
-+ if length($smtp_reason) > 100+3;
-+ }
-+ $smtp_resp =~ /^(\d\d\d(?: \d\.\d\.\d)?)\s*(.*)\z/;
-+ my($dis) = $final_destiny == D_DISCARD ? ' Discarded' : '';
-+ $r->recip_smtp_response("$1$dis $smtp_reason, $2");
-+ $r->recip_done(1); # fake a delivery (confirm delivery to a bit bucket)
-+ # note that 5xx status rejects may later be converted to bounces
- }
- $msginfo->header_edits($hdr_edits); # restore original edits just in case
- $elapsed{'TimeElapsedForwarding'} = Time::HiRes::time - $t0_sect;
-@@ -17774,23 +17801,21 @@
- #
- sub enhance_smtp_response($$$$$) {
- my($smtp_resp,$am_id,$mta_id,$dflt_enhcode,$cmd_name) = @_;
-- local($1,$2,$3); my($resp_shortmsg,$resp_msg);
-+ local($1,$2,$3); my($resp_msg);
- my($resp_code,$resp_enhcode) = ('451', '4.5.0');
- if (!defined($smtp_resp) || $smtp_resp eq '') {
-- $resp_shortmsg = 'No resp. to '.$cmd_name;
-+ $smtp_resp = sprintf('No resp. to %s', $cmd_name);
- } elsif ($smtp_resp !~ /^[245]\d{2}/) {
-- $resp_shortmsg = 'Bad resp. to '.$cmd_name;
-+ $smtp_resp = sprintf('Bad resp. to %s: %s', $cmd_name,$smtp_resp);
- } elsif ($smtp_resp =~ /^ (\d{3}) [ \t]+ ([245] \. \d{1,3} \. \d{1,3})?
- \s* (.*) \z/xs) {
- ($resp_code, $resp_enhcode, $resp_msg) = ($1, $2, $3);
- my($c) = substr($resp_code,0,1);
- if ($resp_enhcode eq '' && $resp_code =~ /^[245]/)
- { $resp_enhcode = $dflt_enhcode; $resp_enhcode =~ s/^\d*/$c/ }
-- $resp_shortmsg = $c eq '2' ? 'Ok' : $c eq '4' ? 'TempFailed' : 'Failed';
- }
-- sprintf("%s %s %s, id=%s, from MTA(%s): %s",
-- $resp_code, $resp_enhcode, $resp_shortmsg,
-- $am_id, $mta_id, $smtp_resp);
-+ sprintf("%s %s from MTA(%s): %s",
-+ $resp_code, $resp_enhcode, $mta_id, $smtp_resp);
- }
-
- # Send mail using SMTP - single transaction