aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-19 01:37:20 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-19 01:37:20 +0000
commit6b2d11a23dfcfa1763c3ded7a157599cc691fd8c (patch)
tree2472bab25d844b939400947ef9a19235618a6eba
parent485b6b3dfec37a8ed1d768b871dd4695c9500829 (diff)
downloadports-6b2d11a23dfcfa1763c3ded7a157599cc691fd8c.tar.gz
ports-6b2d11a23dfcfa1763c3ded7a157599cc691fd8c.zip
- Add LICENSE_FILE
- Switch to options helpers - Regenerate patches with `make makepatch`
Notes
Notes: svn path=/head/; revision=403997
-rw-r--r--devel/dparser/Makefile26
-rw-r--r--devel/dparser/files/patch-Makefile14
-rw-r--r--devel/dparser/files/patch-arg.c6
3 files changed, 21 insertions, 25 deletions
diff --git a/devel/dparser/Makefile b/devel/dparser/Makefile
index bc7692a454cc..14d8c0eaa729 100644
--- a/devel/dparser/Makefile
+++ b/devel/dparser/Makefile
@@ -11,9 +11,9 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Simple but powerful tool for parsing
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-OPTIONS_DEFINE= BOEHM DOCS
-BOEHM_DESC= Boehm garbage collector support
+BROKEN_ia64= does not build on ia64
WRKSRC= ${WRKDIR}/d
@@ -26,20 +26,14 @@ PLIST_FILES= bin/make_dparser include/dparse.h include/dparse_tables.h \
include/dparse_tree.h include/dsymtab.h lib/${LIBDPARSE} \
man/man1/make_dparser.1.gz
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MBOEHM}
-LIB_DEPENDS+= libgc.so:${PORTSDIR}/devel/boehm-gc
-MAKE_ARGS+= D_USE_GC=1 \
- GC_CFLAGS="-I${LOCALBASE}/include -L${LOCALBASE}/lib"
-LIBDPARSE= libdparse_gc.a
-.else
-LIBDPARSE= libdparse.a
-.endif
+OPTIONS_DEFINE= BOEHM DOCS
+BOEHM_DESC= Boehm garbage collector support
-.if ${ARCH} == "ia64"
-BROKEN= Does not build on ia64
-.endif
+BOEHM_LIB_DEPENDS= libgc.so:${PORTSDIR}/devel/boehm-gc
+BOEHM_MAKE_ARGS= D_USE_GC=1 \
+ GC_CFLAGS="-I${LOCALBASE}/include -L${LOCALBASE}/lib"
+BOEHM_VARS= LIBDPARSE=libdparse_gc.a
+BOEHM_VARS_OFF= LIBDPARSE=libdparse.a
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/make_dparser ${STAGEDIR}${PREFIX}/bin
@@ -49,6 +43,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/dparse_tree.h ${STAGEDIR}${PREFIX}/include
${INSTALL_DATA} ${WRKSRC}/dsymtab.h ${STAGEDIR}${PREFIX}/include
${INSTALL_DATA} ${WRKSRC}/${LIBDPARSE} ${STAGEDIR}${PREFIX}/lib
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.html ${STAGEDIR}${DOCSDIR}
diff --git a/devel/dparser/files/patch-Makefile b/devel/dparser/files/patch-Makefile
index 88bf594ae64c..92032d0f102b 100644
--- a/devel/dparser/files/patch-Makefile
+++ b/devel/dparser/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2013-04-02 10:00:17.000000000 +0200
-+++ Makefile 2013-04-02 10:01:34.000000000 +0200
-@@ -11,7 +11,7 @@
+--- Makefile.orig 2013-03-02 21:22:20 UTC
++++ Makefile
+@@ -11,7 +11,7 @@ MAJOR=1
MINOR=30
RELEASE=$(MAJOR).$(MINOR)
@@ -9,7 +9,7 @@
ifndef PREFIX
PREFIX=/usr/local
-@@ -38,7 +38,7 @@
+@@ -38,7 +38,7 @@ ifeq ($(ARCH),i686)
ARCH = x86
endif
@@ -18,7 +18,7 @@
CFLAGS += -fPIC
endif
-@@ -64,10 +64,10 @@
+@@ -64,10 +64,10 @@ ifdef D_USE_FREELISTS
CFLAGS += -DUSE_FREELISTS
endif
@@ -32,7 +32,7 @@
CFLAGS += -DD_MAJOR_VERSION=$(MAJOR) -DD_MINOR_VERSION=$(MINOR) -DD_BUILD_VERSION=\"$(D_BUILD_VERSION)\"
CFLAGS += -Wall
-@@ -94,7 +94,7 @@
+@@ -94,7 +94,7 @@ TEST_FILES = d/parser_tests d/baseline $
PYTHON_FILES = d/python/Makefile d/python/*.py d/python/*.c d/python/*.h d/python/*.i d/python/README d/python/*.html d/python/contrib/d* d/python/tests/*.py
VERILOG_FILES = d/verilog/Makefile d/verilog/verilog.g d/verilog/README d/verilog/ambig.c \
d/verilog/main.c d/verilog/vparse.c d/verilog/vparse.h d/verilog/verilog_tests
@@ -41,7 +41,7 @@
d/grammar.g d/sample.g d/my.g
LIB_SRCS = arg.c parse.c scan.c symtab.c util.c read_binary.c dparse_tree.c
-@@ -141,7 +141,7 @@
+@@ -141,7 +141,7 @@ endif
ALL_SRCS = $(MAKE_PARSER_SRCS) $(BASE_SAMPLE_PARSER_SRCS) $(LIB_SRCS) $(MK_LIB_SRCS)
diff --git a/devel/dparser/files/patch-arg.c b/devel/dparser/files/patch-arg.c
index e108b88411dd..698c8a724af6 100644
--- a/devel/dparser/files/patch-arg.c
+++ b/devel/dparser/files/patch-arg.c
@@ -1,6 +1,6 @@
---- arg.c.orig Fri Nov 7 03:03:52 2003
-+++ arg.c Mon Feb 2 18:35:43 2004
-@@ -40,7 +40,7 @@
+--- arg.c.orig 2013-01-23 02:14:58 UTC
++++ arg.c
+@@ -40,7 +40,7 @@ process_arg(ArgumentState *arg_state, in
*(double *)desc[i].location = atof(arg);
break;
case 'L':