aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-05 07:35:31 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-05 07:37:41 +0000
commit6bbd7896410cec76cd9f723b1ccd388a57cbe88b (patch)
tree9d5a158663d72a26cb7c9b32d85870ffa9c62209
parentd2b7472bd8b1bdab97c5ed585910b10e561a0751 (diff)
downloadports-6bbd7896410cec76cd9f723b1ccd388a57cbe88b.tar.gz
ports-6bbd7896410cec76cd9f723b1ccd388a57cbe88b.zip
math/hpipm: Fix build on i386
... by removing hardcoded -m64. Reported by: fallout (cherry picked from commit 76c7602fdb8216f6b10c957add54671111c27af0)
-rw-r--r--math/hpipm/files/patch-CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/math/hpipm/files/patch-CMakeLists.txt b/math/hpipm/files/patch-CMakeLists.txt
index 5223658667cb..3f86ec49de06 100644
--- a/math/hpipm/files/patch-CMakeLists.txt
+++ b/math/hpipm/files/patch-CMakeLists.txt
@@ -18,6 +18,15 @@
if(BUILD_SHARED_LIBS MATCHES OFF)
set(HPIPM_BLASFEO_LIB "Static" CACHE STRING "BLASFEO library link type")
else()
+@@ -140,7 +140,7 @@ endif()
+ if(${TARGET} MATCHES AVX)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DTARGET_AVX")
+ if(CMAKE_C_COMPILER_ID STREQUAL "GNU" OR CMAKE_C_COMPILER_ID STREQUAL "Clang")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -m64 -mavx")
++ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mavx")
+ endif()
+ elseif(${TARGET} MATCHES GENERIC)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DTARGET_GENERIC")
@@ -151,7 +151,7 @@ if(${REF_BLAS} MATCHES 0)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ")
endif(${REF_BLAS} MATCHES 0)
@@ -32,7 +41,7 @@
endif(${REF_BLAS} MATCHES NETLIB)
if(${REF_BLAS} MATCHES MKL)
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DREF_BLAS_MKL -m64 -I/opt/intel/mkl/include")
-+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DREF_BLAS_MKL -m64")
++ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DREF_BLAS_MKL")
endif(${REF_BLAS} MATCHES MKL)
if(${REF_BLAS} MATCHES ATLAS)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DREF_BLAS_ATLAS")