aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2024-01-05 08:07:48 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2024-01-05 08:07:48 +0000
commit6bc8fc471978d23791951785458d94a2daa99e21 (patch)
tree0bde9b7e112e9be82c593f0fe7df575986637200
parent5e43376d4d5d2abf4c60f67c5bc0e0dded2007fb (diff)
downloadports-6bc8fc471978d23791951785458d94a2daa99e21.tar.gz
ports-6bc8fc471978d23791951785458d94a2daa99e21.zip
print/dymo-cups-drivers: the port had been improved (+)
- Replace `std::auto_ptr' with `std::unique_ptr' rather than limiting Clang/LLVM version to 15 - Chase HTTP/1.1 301 redirection in the MASTER_SITES and finish WWW line update from the previous commit Fixes: 08760e525115, 9d66bcf09923
-rw-r--r--print/dymo-cups-drivers/Makefile13
-rw-r--r--print/dymo-cups-drivers/files/patch-src-common-CupsFilter.h9
2 files changed, 12 insertions, 10 deletions
diff --git a/print/dymo-cups-drivers/Makefile b/print/dymo-cups-drivers/Makefile
index 19669d28d042..097dd8773bb0 100644
--- a/print/dymo-cups-drivers/Makefile
+++ b/print/dymo-cups-drivers/Makefile
@@ -2,27 +2,20 @@ PORTNAME= dymo-cups-drivers
PORTVERSION= 1.4.0
PORTREVISION= 4
CATEGORIES= print
-MASTER_SITES= http://download.dymo.com/Software/Linux/
+MASTER_SITES= https://download.dymo.com/Software/Linux/
MAINTAINER= ports@FreeBSD.org
COMMENT= Open source DYMO CUPS driver
-WWW= https://www.dymo.com
+WWW= https://www.dymo.com/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libcupsimage.so:print/cups
-USES= localbase:ldflags
-
+USES= localbase:ldflags
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/dymo-cups-drivers-1.4.0.5
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
-USES+= llvm:max=15
-.endif
-
.include <bsd.port.mk>
diff --git a/print/dymo-cups-drivers/files/patch-src-common-CupsFilter.h b/print/dymo-cups-drivers/files/patch-src-common-CupsFilter.h
index ecb79b728861..e9a5a56b0926 100644
--- a/print/dymo-cups-drivers/files/patch-src-common-CupsFilter.h
+++ b/print/dymo-cups-drivers/files/patch-src-common-CupsFilter.h
@@ -8,3 +8,12 @@
#include <cups/raster.h>
#include <memory>
#include <string>
+@@ -132,7 +133,7 @@ CCupsFilter<D, DI, LM>::Run(int argc, char* argv[])
+ bool UseCustomHalftoning = PageHeader.cupsBitsPerPixel > 1;
+ bool IsProcessLineSupported = true;
+
+- std::auto_ptr<CHalftoneFilter> H;
++ std::unique_ptr<CHalftoneFilter> H;
+ if (UseCustomHalftoning)
+ {
+ if (HalftoningMethod_ == "NLL")