aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTatsuki Makino <tatsuki_makino@hotmail.com>2021-09-01 23:10:00 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-09-01 23:10:00 +0000
commit6bd5f3f99a0024a5b2799c6496fcc54214d7cc08 (patch)
tree3cd89e359e2d03eb0a8791928647be95d24458a7
parent76a124ab0b40e1a20689431f28e70d19a376cc29 (diff)
downloadports-6bd5f3f99a0024a5b2799c6496fcc54214d7cc08.tar.gz
ports-6bd5f3f99a0024a5b2799c6496fcc54214d7cc08.zip
audio/libopenshot-audio: Update to 0.2.1
-rw-r--r--audio/libopenshot-audio/Makefile5
-rw-r--r--audio/libopenshot-audio/distinfo6
-rw-r--r--audio/libopenshot-audio/files/patch-CMakeLists.txt10
-rw-r--r--audio/libopenshot-audio/pkg-plist38
4 files changed, 46 insertions, 13 deletions
diff --git a/audio/libopenshot-audio/Makefile b/audio/libopenshot-audio/Makefile
index 4fbe23db0c02..57d5d0cd486f 100644
--- a/audio/libopenshot-audio/Makefile
+++ b/audio/libopenshot-audio/Makefile
@@ -1,7 +1,6 @@
PORTNAME= libopenshot-audio
DISTVERSIONPREFIX= v
-DISTVERSION= 0.2.0-59
-DISTVERSIONSUFFIX= -g92ff608
+DISTVERSION= 0.2.1
CATEGORIES= audio multimedia
MAINTAINER= tatsuki_makino@hotmail.com
@@ -14,7 +13,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:audio/alsa-pl
LIB_DEPENDS= libasound.so:audio/alsa-lib \
libsysinfo.so:devel/libsysinfo
-USES= cmake compiler:c++11-lang
+USES= cmake compiler:c++14-lang
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= OpenShot
diff --git a/audio/libopenshot-audio/distinfo b/audio/libopenshot-audio/distinfo
index aac4057e3671..a72949ee796a 100644
--- a/audio/libopenshot-audio/distinfo
+++ b/audio/libopenshot-audio/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1622257200
-SHA256 (OpenShot-libopenshot-audio-v0.2.0-59-g92ff608_GH0.tar.gz) = 757c4305a99427955299f9c32214d1df63a5e42e49a76690d24b9d24764661a7
-SIZE (OpenShot-libopenshot-audio-v0.2.0-59-g92ff608_GH0.tar.gz) = 1711214
+TIMESTAMP = 1629968400
+SHA256 (OpenShot-libopenshot-audio-v0.2.1_GH0.tar.gz) = b502041044d07be3c22787eb9a422bf338ef47b88b1af547002d1ec1bc7b07a4
+SIZE (OpenShot-libopenshot-audio-v0.2.1_GH0.tar.gz) = 1808335
diff --git a/audio/libopenshot-audio/files/patch-CMakeLists.txt b/audio/libopenshot-audio/files/patch-CMakeLists.txt
index 019ef1951105..3932d4af253e 100644
--- a/audio/libopenshot-audio/files/patch-CMakeLists.txt
+++ b/audio/libopenshot-audio/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2021-05-09 14:57:33 UTC
+--- CMakeLists.txt.orig 2021-08-19 20:33:46 UTC
+++ CMakeLists.txt
-@@ -170,6 +170,13 @@ set_target_properties(openshot-audio PROPERTIES
+@@ -171,6 +171,13 @@ set_target_properties(openshot-audio PROPERTIES
EXPORT_NAME Audio # Exports as OpenShot::Audio target
)
@@ -14,7 +14,7 @@
# Require language features we use
if(CMAKE_VERSION VERSION_GREATER 3.8)
target_compile_features(openshot-audio PUBLIC
-@@ -188,7 +195,8 @@ endif()
+@@ -189,7 +196,8 @@ endif()
# Enable stack-unwinding support in c objects on gcc-based platforms.
# Failing to do so will cause your program to be terminated when a png
# or a jpeg exception is thrown on linux or macosx.
@@ -24,7 +24,7 @@
target_compile_options(openshot-audio PRIVATE -fexceptions)
endif()
-@@ -249,8 +257,8 @@ if(UNIX AND NOT APPLE)
+@@ -250,8 +258,8 @@ if(UNIX AND NOT APPLE)
INTERFACE_INCLUDE_DIRECTORIES ${ALSA_INCLUDE_DIR}
INTERFACE_LINK_LIBRARIES ${ALSA_LIBRARIES})
endif()
@@ -35,7 +35,7 @@
else()
# For EXPORTED Config
set(NEED_ALSA FALSE)
-@@ -258,10 +266,24 @@ endif()
+@@ -259,10 +267,24 @@ endif()
# ZLIB -- uses IMPORTED target ZLIB::ZLIB which has existed since CMake 3.1
find_package(ZLIB REQUIRED)
diff --git a/audio/libopenshot-audio/pkg-plist b/audio/libopenshot-audio/pkg-plist
index 36440bffe873..495b3aa86557 100644
--- a/audio/libopenshot-audio/pkg-plist
+++ b/audio/libopenshot-audio/pkg-plist
@@ -298,6 +298,40 @@ include/libopenshot-audio/juce_data_structures/values/juce_Value.h
include/libopenshot-audio/juce_data_structures/values/juce_ValueTree.h
include/libopenshot-audio/juce_data_structures/values/juce_ValueTreeSynchroniser.h
include/libopenshot-audio/juce_data_structures/values/juce_ValueWithDefault.h
+include/libopenshot-audio/juce_dsp/containers/juce_AudioBlock.h
+include/libopenshot-audio/juce_dsp/containers/juce_SIMDRegister.h
+include/libopenshot-audio/juce_dsp/containers/juce_SIMDRegister_Impl.h
+include/libopenshot-audio/juce_dsp/filter_design/juce_FilterDesign.h
+include/libopenshot-audio/juce_dsp/frequency/juce_Convolution.h
+include/libopenshot-audio/juce_dsp/frequency/juce_FFT.h
+include/libopenshot-audio/juce_dsp/frequency/juce_Windowing.h
+include/libopenshot-audio/juce_dsp/juce_dsp.h
+include/libopenshot-audio/juce_dsp/maths/juce_FastMathApproximations.h
+include/libopenshot-audio/juce_dsp/maths/juce_LogRampedValue.h
+include/libopenshot-audio/juce_dsp/maths/juce_LookupTable.h
+include/libopenshot-audio/juce_dsp/maths/juce_Matrix.h
+include/libopenshot-audio/juce_dsp/maths/juce_Phase.h
+include/libopenshot-audio/juce_dsp/maths/juce_Polynomial.h
+include/libopenshot-audio/juce_dsp/maths/juce_SpecialFunctions.h
+include/libopenshot-audio/juce_dsp/native/juce_avx_SIMDNativeOps.h
+include/libopenshot-audio/juce_dsp/native/juce_fallback_SIMDNativeOps.h
+include/libopenshot-audio/juce_dsp/native/juce_neon_SIMDNativeOps.h
+include/libopenshot-audio/juce_dsp/native/juce_sse_SIMDNativeOps.h
+include/libopenshot-audio/juce_dsp/processors/juce_Bias.h
+include/libopenshot-audio/juce_dsp/processors/juce_FIRFilter.h
+include/libopenshot-audio/juce_dsp/processors/juce_Gain.h
+include/libopenshot-audio/juce_dsp/processors/juce_IIRFilter.h
+include/libopenshot-audio/juce_dsp/processors/juce_IIRFilter_Impl.h
+include/libopenshot-audio/juce_dsp/processors/juce_LadderFilter.h
+include/libopenshot-audio/juce_dsp/processors/juce_Oscillator.h
+include/libopenshot-audio/juce_dsp/processors/juce_Oversampling.h
+include/libopenshot-audio/juce_dsp/processors/juce_ProcessContext.h
+include/libopenshot-audio/juce_dsp/processors/juce_ProcessorChain.h
+include/libopenshot-audio/juce_dsp/processors/juce_ProcessorDuplicator.h
+include/libopenshot-audio/juce_dsp/processors/juce_ProcessorWrapper.h
+include/libopenshot-audio/juce_dsp/processors/juce_Reverb.h
+include/libopenshot-audio/juce_dsp/processors/juce_StateVariableFilter.h
+include/libopenshot-audio/juce_dsp/processors/juce_WaveShaper.h
include/libopenshot-audio/juce_events/broadcasters/juce_ActionBroadcaster.h
include/libopenshot-audio/juce_events/broadcasters/juce_ActionListener.h
include/libopenshot-audio/juce_events/broadcasters/juce_AsyncUpdater.h
@@ -329,8 +363,8 @@ lib/cmake/OpenShotAudio/OpenShotAudioConfigVersion.cmake
lib/cmake/OpenShotAudio/OpenShotAudioTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/OpenShotAudio/OpenShotAudioTargets.cmake
lib/libopenshot-audio.so
-lib/libopenshot-audio.so.0.2.0
-lib/libopenshot-audio.so.7
+lib/libopenshot-audio.so.0.2.1
+lib/libopenshot-audio.so.8
man/man1/openshot-audio-demo.1.gz
@dir include/libopenshot-audio/juce_audio_devices/native/java/app/com/roli/juce
@dir include/libopenshot-audio/juce_core/native/java/app/com/roli/juce