aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2022-04-30 19:22:41 +0000
committerJason E. Hale <jhale@FreeBSD.org>2022-04-30 19:22:41 +0000
commit6c2c407eeff27aa5d77e044a57d987612b339a0e (patch)
tree3cdb72550e30e37a641ad4249261bde5b1b3573a
parentbbc5af41f84dafcf33bd5389abbbdb626ccac444 (diff)
downloadports-6c2c407eeff27aa5d77e044a57d987612b339a0e.tar.gz
ports-6c2c407eeff27aa5d77e044a57d987612b339a0e.zip
security/pinentry-gnome3: De-version and rename
Due to the new GNOME versioning scheme, security/pinentry-gnome3 has been renamed to security/pinentry-gnome and all references to "GNOME 3" have been dropped in favor of just "GNOME". The binary itself still installs as pinentry-gnome3 at this time, however. Rename the option GNOME3 -> GNOME in security/pinentry. PR: 263681 Reported by: PauAmma <pauamma@gundo.com>
-rw-r--r--MOVED1
-rw-r--r--security/Makefile2
-rw-r--r--security/pinentry-gnome/Makefile (renamed from security/pinentry-gnome3/Makefile)4
-rw-r--r--security/pinentry/Makefile18
-rw-r--r--security/pinentry/pkg-message.gnome26
-rw-r--r--security/pinentry/pkg-message.gnome326
6 files changed, 39 insertions, 38 deletions
diff --git a/MOVED b/MOVED
index 17a4eaec9e81..6d11155f0496 100644
--- a/MOVED
+++ b/MOVED
@@ -17140,3 +17140,4 @@ net/google-cloud-sdk-app-engine-go||2022-04-27|Obsolete, not supported by the cu
www/py-dj32-django-modelcluster|www/py-django-modelcluster|2022-04-30|Remove obsoleted port. Use www/py-django-modelcluster instead
www/rubygem-rack-proxy06|www/rubygem-rack-proxy|2022-04-30|Remove obsoleted port. Use www/rubygem-rack-proxy instead
security/py-ssh|security/py-paramiko|2022-04-30|Remove obsoleted port. Use security/py-paramiko instead
+security/pinentry-gnome3|security/pinentry-gnome|2022-04-30|De-versioned due to new GNOME versioning scheme
diff --git a/security/Makefile b/security/Makefile
index 66f61f6149ac..ed80372f48a9 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -781,7 +781,7 @@
SUBDIR += pinentry-curses
SUBDIR += pinentry-efl
SUBDIR += pinentry-fltk
- SUBDIR += pinentry-gnome3
+ SUBDIR += pinentry-gnome
SUBDIR += pinentry-gtk2
SUBDIR += pinentry-qt5
SUBDIR += pinentry-tty
diff --git a/security/pinentry-gnome3/Makefile b/security/pinentry-gnome/Makefile
index 0e8076f68bba..713d3747a985 100644
--- a/security/pinentry-gnome3/Makefile
+++ b/security/pinentry-gnome/Makefile
@@ -1,9 +1,9 @@
PORTNAME= pinentry
PORTREVISION= 0
-COMMENT= GNOME 3 version of the GnuPG password dialog
+COMMENT= GNOME version of the GnuPG password dialog
-PINENTRY_GUI= gnome3
+PINENTRY_GUI= gnome
MASTERDIR= ${.CURDIR}/../pinentry
diff --git a/security/pinentry/Makefile b/security/pinentry/Makefile
index 05470ffba39b..d6c09217f9f5 100644
--- a/security/pinentry/Makefile
+++ b/security/pinentry/Makefile
@@ -2,7 +2,7 @@
PORTNAME= pinentry
PORTVERSION= 1.2.0
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= security
MASTER_SITES= GNUPG/pinentry
@@ -21,7 +21,7 @@ NO_BUILD= yes
PLIST_FILES= bin/pinentry
OPTIONS_SINGLE= FRONTEND
-OPTIONS_SINGLE_FRONTEND= TTY NCURSES EFL FLTK GTK2 QT5 GNOME3
+OPTIONS_SINGLE_FRONTEND= EFL FLTK GNOME GTK2 NCURSES QT5 TTY
OPTIONS_DEFAULT= NCURSES
FRONTEND_DESC= Default frontend
@@ -50,13 +50,13 @@ QT5_DESC= Qt 5 frontend
PINENTRY_QT5= pinentry-qt5
QT5_RUN_DEPENDS= ${PINENTRY_QT5}:security/pinentry-qt5
-GNOME3_DESC= GNOME 3 frontend
-PINENTRY_GNOME3= pinentry-gnome3
-# Due to a dependency loop that exists between security/pinentry-gnome3,
+GNOME_DESC= GNOME frontend
+PINENTRY_GNOME= pinentry-gnome3
+# Due to a dependency loop that exists between security/pinentry-gnome,
# security/gcr, security/gnupg and security/pinentry, the user must install
-# pinentry-gnome3 manually. See pkg-message.gnome3 for more details.
-#GNOME3_RUN_DEPENDS= ${PINENTRY_GNOME3}:security/pinentry-gnome3
-GNOME3_VARS= PKGMESSAGE+=${.CURDIR}/pkg-message.gnome3
+# pinentry-gnome manually. See pkg-message.gnome for more details.
+#GNOME_RUN_DEPENDS= ${PINENTRY_GNOME}:security/pinentry-gnome
+GNOME_VARS= PKGMESSAGE+=${.CURDIR}/pkg-message.gnome
.include <bsd.port.options.mk>
@@ -88,7 +88,7 @@ LIBSECRET_LIB_DEPENDS= libsecret-1.so:security/libsecret
LIBSECRET_USES= gnome
LIBSECRET_USE= GNOME=glib20
-.if ${PINENTRY_GUI} == "gnome3"
+.if ${PINENTRY_GUI} == "gnome"
OPTIONS_SLAVE= LIBSECRET
LIB_DEPENDS+= libgcr-base-3.so:security/gcr
PLIST_FILES= bin/pinentry-gnome3
diff --git a/security/pinentry/pkg-message.gnome b/security/pinentry/pkg-message.gnome
new file mode 100644
index 000000000000..7e8734df7d66
--- /dev/null
+++ b/security/pinentry/pkg-message.gnome
@@ -0,0 +1,26 @@
+[
+{ type: install
+ message: <<EOM
+Due to a dependency loop, you must install security/pinentry-gnome manually.
+A symlink has been created for you so that pinentry-gnome will be the default
+pinentry binary after you install it, but bear in mind that the package system
+will not keep track of this dependency.
+
+You may install pinentry-gnome with one of the following commands:
+
+# pkg install security/pinentry-gnome
+ or
+# make -C /usr/ports/security/pinentry-gnome install clean
+EOM
+}
+{ type: remove
+ message: <<EOM
+The pinentry package has been removed. If you no longer plan on using this
+package, you may remove the pinentry-gnome package as well.
+
+You may remove the pinentry-gnome package with the following command:
+
+# pkg delete pinentry-gnome
+EOM
+}
+]
diff --git a/security/pinentry/pkg-message.gnome3 b/security/pinentry/pkg-message.gnome3
deleted file mode 100644
index e800fc4b0104..000000000000
--- a/security/pinentry/pkg-message.gnome3
+++ /dev/null
@@ -1,26 +0,0 @@
-[
-{ type: install
- message: <<EOM
-Due to a dependency loop, you must install security/pinentry-gnome3 manually.
-A symlink has been created for you so that pinentry-gnome3 will be the default
-pinentry binary after you install it, but bear in mind that the package system
-will not keep track of this dependency.
-
-You may install pinentry-gnome3 with one of the following commands:
-
-# pkg install security/pinentry-gnome3
- or
-# make -C /usr/ports/security/pinentry-gnome3 install clean
-EOM
-}
-{ type: remove
- message: <<EOM
-The pinentry package has been removed. If you no longer plan on using this
-package, you may remove the pinentry-gnome3 package as well.
-
-You may remove the pinentry-gnome3 package with the following command:
-
-# pkg delete pinentry-gnome3
-EOM
-}
-]