aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 09:39:44 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 09:40:13 +0000
commit6cafaa52b4d335f4d7f22fb4cf594575a73c0f72 (patch)
tree241783a5687e6b9d4fdb74db8593af10997b0f93
parent70dac127ed051f5c004753baebfc9e9adda4acbd (diff)
downloadports-6cafaa52b4d335f4d7f22fb4cf594575a73c0f72.tar.gz
ports-6cafaa52b4d335f4d7f22fb4cf594575a73c0f72.zip
misc/bb: Fix build with llvm16
Sponsored by: The FreeBSD Foundation
-rw-r--r--misc/bb/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/misc/bb/Makefile b/misc/bb/Makefile
index 07ce9e14b555..834adea34e96 100644
--- a/misc/bb/Makefile
+++ b/misc/bb/Makefile
@@ -27,6 +27,10 @@ OPTIONS_DEFINE= DOCS
USES+= compiler:gcc-c++11-lib
.endif
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
pre-patch:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -E -e "s@#include +<malloc.h>@#include <stdlib.h>@g" \
-e 's, REGISTERS \(3\),,g'