aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-18 14:41:42 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-18 15:50:38 +0000
commit6cf6266abfee5a401ff89bf4ce0cfa9ac42a26d4 (patch)
tree13d38e87a2a6f358840661f72241e1e3be7de748
parent29e3d406ff3583fca47401bcc05868b9889ee116 (diff)
downloadports-6cf6266abfee5a401ff89bf4ce0cfa9ac42a26d4.tar.gz
ports-6cf6266abfee5a401ff89bf4ce0cfa9ac42a26d4.zip
math/givaro: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--math/givaro/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/math/givaro/Makefile b/math/givaro/Makefile
index 77311cc3694f..e510c9dfab1f 100644
--- a/math/givaro/Makefile
+++ b/math/givaro/Makefile
@@ -16,21 +16,24 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libgmp.so:math/gmp
USES= autoreconf compiler:c++11-lang gmake libtool pathfix pkgconfig
+USE_CXXSTD= c++11
+USE_GITHUB= yes
+GH_ACCOUNT= linbox-team
+USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gmp="${LOCALBASE}"
-USE_LDCONFIG= yes
+
INSTALL_TARGET= install-strip
TEST_TARGET= check
-USE_GITHUB= yes
-GH_ACCOUNT= linbox-team
OPTIONS_DEFINE= DOCS
OPTIONS_SUB= yes
DOCS_BUILD_DEPENDS= doxygen:devel/doxygen \
dot:graphics/graphviz
-DOCS_CONFIGURE_ON= --enable-doc --with-docdir=${DOCSDIR}
DOCS_USE= TEX=base:build,dvipsk:build,latex:build,pdftex:build
+DOCS_CONFIGURE_ON= --enable-doc --with-docdir=${DOCSDIR}
post-install-DOCS-on:
${RMDIR} ${STAGEDIR}${DOCSDIR}/givaro-dev-html