aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Sébastien Pédron <dumbbell@FreeBSD.org>2018-07-23 07:32:23 +0000
committerJean-Sébastien Pédron <dumbbell@FreeBSD.org>2018-07-23 07:32:23 +0000
commit6d4a3088baa09c63cd66f30e1c0d2634fdd0cbe0 (patch)
tree0de64852701da22780696a862d097ecc710276e7
parent672a731a16af4141c41284a6fd3e0859d94b9e53 (diff)
downloadports-6d4a3088baa09c63cd66f30e1c0d2634fdd0cbe0.tar.gz
ports-6d4a3088baa09c63cd66f30e1c0d2634fdd0cbe0.zip
lang/rust: Udpate checksums in libgit2-sys/.cargo-checksum.json
It was part of the initial patch from Charlie Li to support LibreSSL 2.7. However, I misread it and though he was only removing bits which were not needed anymore (updating checksums for openssl and openssl-sys). Now, we update all three: libgit2-sys, openssl and openssl-sys. PR: 226955 Submitted by: Charlie Li <ml+freebsd@vishwin.info> Reported by: Charlie Li <ml+freebsd@vishwin.info>
Notes
Notes: svn path=/head/; revision=475150
-rw-r--r--lang/rust/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index f3a855c72b0e..24321431c88b 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -156,7 +156,10 @@ post-patch:
${WRKSRC}/src/stage0.txt
# After patching crates, we need to update their corresponding
# `.cargo-checksum.json` to reflect the new checksums verified by Cargo.
- @for dir in "${WRKSRC}/src/vendor/libc" "${WRKSRC}/src/vendor/openssl" "${WRKSRC}/src/vendor/openssl-sys"; do \
+ @for dir in "${WRKSRC}/src/vendor/libc" \
+ "${WRKSRC}/src/vendor/libgit2-sys" \
+ "${WRKSRC}/src/vendor/openssl" \
+ "${WRKSRC}/src/vendor/openssl-sys"; do \
if ! test -d "$$dir"; then \
continue; \
fi; \