aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-08-23 22:24:23 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-08-23 22:24:23 +0000
commit6d70e99cc0ef2383dea151621d47238a4691531b (patch)
tree4a0e3a76ce9cb0aa4e77482eed2853b2eb0e5d00
parentdce394d95efbb8be2c4e530402fb897b4f3d9790 (diff)
downloadports-6d70e99cc0ef2383dea151621d47238a4691531b.tar.gz
ports-6d70e99cc0ef2383dea151621d47238a4691531b.zip
devel/juce: fix build on powerpc*
/wrkdirs/usr/ports/devel/juce/work/JUCE-7.0.6/modules/juce_dsp/containers/juce_AudioBlock_test.cpp:32:34: error: no template named 'SIMDRegister' String& operator<< (String& str, SIMDRegister<SampleType>) { return str; }
-rw-r--r--devel/juce/Makefile3
-rw-r--r--devel/juce/files/patch-modules_juce__dsp_containers_juce__AudioBlock__test.cpp13
2 files changed, 15 insertions, 1 deletions
diff --git a/devel/juce/Makefile b/devel/juce/Makefile
index 00e395124a56..408cc18da514 100644
--- a/devel/juce/Makefile
+++ b/devel/juce/Makefile
@@ -24,7 +24,8 @@ LIB_DEPENDS= libasound.so:audio/alsa-lib \
libsysinfo.so:devel/libsysinfo
USES= cmake compiler:c++11-lang dos2unix gl gnome localbase:ldflags pkgconfig xorg
-DOS2UNIX_FILES= modules/juce_core/juce_core.h
+DOS2UNIX_FILES= modules/juce_core/juce_core.h \
+ modules/juce_dsp/containers/juce_AudioBlock_test.cpp
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 pango
USE_GL= gl
USE_XORG= x11 xcomposite xcursor xext xinerama xorgproto xrandr
diff --git a/devel/juce/files/patch-modules_juce__dsp_containers_juce__AudioBlock__test.cpp b/devel/juce/files/patch-modules_juce__dsp_containers_juce__AudioBlock__test.cpp
new file mode 100644
index 000000000000..0e1571f86135
--- /dev/null
+++ b/devel/juce/files/patch-modules_juce__dsp_containers_juce__AudioBlock__test.cpp
@@ -0,0 +1,13 @@
+--- modules/juce_dsp/containers/juce_AudioBlock_test.cpp.orig 2023-08-23 16:47:58 UTC
++++ modules/juce_dsp/containers/juce_AudioBlock_test.cpp
+@@ -28,8 +28,10 @@ namespace juce
+ namespace dsp
+ {
+
++#if JUCE_USE_SIMD
+ template <typename SampleType>
+ String& operator<< (String& str, SIMDRegister<SampleType>) { return str; }
++#endif
+
+ template <typename SampleType>
+ class AudioBlockUnitTests : public UnitTest