aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-08-28 08:33:34 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-08-28 08:33:34 +0000
commit6da1ee7cb0a6066a6dbe24f016ecc90be7ae2d64 (patch)
tree5f1a55fb5c9794d876b247bfc697501862fc750e
parent51380ba8ca05870558dbcaa47ae58921f96e0a95 (diff)
downloadports-6da1ee7cb0a6066a6dbe24f016ecc90be7ae2d64.tar.gz
ports-6da1ee7cb0a6066a6dbe24f016ecc90be7ae2d64.zip
- Use autoconf and automake on build time (avoid re-run of configure)
- Remove AUTOTOOLS knobs from slave ports
Notes
Notes: svn path=/head/; revision=260119
-rw-r--r--www/lighttpd-mod_geoip/Makefile2
-rw-r--r--www/lighttpd-mod_h264_streaming/Makefile2
-rw-r--r--www/lighttpd/Makefile10
3 files changed, 3 insertions, 11 deletions
diff --git a/www/lighttpd-mod_geoip/Makefile b/www/lighttpd-mod_geoip/Makefile
index 96b81023d830..2abd80bcaff3 100644
--- a/www/lighttpd-mod_geoip/Makefile
+++ b/www/lighttpd-mod_geoip/Makefile
@@ -25,8 +25,6 @@ LATEST_LINK= lighttpd-${PORTNAME}
PATCH_SITES+= ${MASTER_SITE_LOCAL}
PATCHFILES+= lighttpd-1.4.26_mod_geoip.patch.gz
PATCH_SITE_SUBDIR+= mm
-USE_AUTOTOOLS+= autoconf:262 autoheader:262 aclocal:110 automake:110
-ACLOCAL_ARGS+= -I m4
BUILD_WRKSRC= ${WRKSRC}/src
ALL_TARGET= ${PORTNAME}.la
diff --git a/www/lighttpd-mod_h264_streaming/Makefile b/www/lighttpd-mod_h264_streaming/Makefile
index e17af48b728b..35cc42784d1d 100644
--- a/www/lighttpd-mod_h264_streaming/Makefile
+++ b/www/lighttpd-mod_h264_streaming/Makefile
@@ -26,8 +26,6 @@ MANUAL_PACKAGE_BUILD= free for non-commercial use only
PATCH_SITES+= ${MASTER_SITE_LOCAL}
PATCHFILES+= lighttpd-1.4.26_mod_h264_streaming-2.2.9.patch.gz
PATCH_SITE_SUBDIR+= mm
-USE_AUTOTOOLS+= autoconf:262 autoheader:262 aclocal:110 automake:110
-ACLOCAL_ARGS+= -I m4
BUILD_WRKSRC= ${WRKSRC}/src
ALL_TARGET= ${PORTNAME}.la
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index b0677c3ada95..0786a765e65c 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -20,13 +20,9 @@ LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GNOME= lthack
-.if defined(_BUILDING_LIGHTTPD_MODULE)
-USE_AUTOTOOLS?= libtool:22
-CONFIGURE_ARGS?= --libdir=${PREFIX}/lib/lighttpd --enable-static
-.else
-USE_AUTOTOOLS= libtool:22
-CONFIGURE_ARGS= --libdir=${PREFIX}/lib/lighttpd --enable-static
-.endif # defined(_BUILDING_LIGHTTPD_MODULE)
+USE_AUTOTOOLS= autoconf:262 autoheader:262 aclocal:110 automake:110 libtool:22
+ACLOCAL_ARGS= -I m4
+CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/lighttpd --enable-static
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib