aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-12-25 18:24:02 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-12-25 18:24:02 +0000
commit6dee558eb48ae24fb69713f62be3a394cf063a1f (patch)
tree3e8f400c0f45b369ee398fa7cd0ab3242afa2e52
parent7bae555e202be321f4f698ca9ed1072de3b11c4d (diff)
downloadports-6dee558eb48ae24fb69713f62be3a394cf063a1f.tar.gz
ports-6dee558eb48ae24fb69713f62be3a394cf063a1f.zip
- update to 2.2
Notes
Notes: svn path=/head/; revision=246617
-rw-r--r--emulators/vice/Makefile17
-rw-r--r--emulators/vice/distinfo6
-rw-r--r--emulators/vice/files/patch-configure43
-rw-r--r--emulators/vice/files/patch-dynlib.c11
-rw-r--r--emulators/vice/files/patch-joy_usb.c16
-rw-r--r--emulators/vice/files/patch-soundsdl.c11
-rw-r--r--emulators/vice/pkg-plist16
7 files changed, 51 insertions, 69 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 5d846cba372a..1082d78749b0 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= vice
-PORTVERSION= 2.1
-PORTREVISION= 1
+PORTVERSION= 2.2
CATEGORIES= emulators
MASTER_SITES= http://www.viceteam.org/online/ \
http://www.zimmers.net/anonftp/pub/cbm/crossplatform/emulators/VICE/ \
@@ -18,7 +17,8 @@ COMMENT= Emulator for Commodore C64, C128, VIC20, PET, and CBM-II
BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf \
mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
- mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
+ mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale \
+ pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= png:${PORTSDIR}/graphics/png
.if defined(VICE_WITH_XAW3D)
LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
@@ -52,7 +52,10 @@ USE_XORG+= xaw
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
+PKG_CONFIG?= ${LOCALBASE}/bin/pkg-config
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV+= PKG_CONFIG="${LOCALBASE}/bin/pkg-config"
+CONFIGURE_ARGS+= --enable-fullscreen --enable-ipv6 --disable-dependency-tracking
MAN1= vice.1 c1541.1 petcat.1
MLINKS= vice.1 x64.1 \
vice.1 x128.1 \
@@ -67,6 +70,14 @@ INFO= vice
.include <bsd.port.pre.mk>
+.if defined(WITH_LIBUSB)
+.if ${OSVERSION}<800063
+LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
+.endif
+.else
+CONFIGURE_ARGS+= --disable-libusb
+.endif
+
.if exists(${LOCALBASE}/bin/fc-cache)
PLIST_SUB+= FCCACHE=""
PLIST_SUB+= NOFCCACHE="@comment "
diff --git a/emulators/vice/distinfo b/emulators/vice/distinfo
index 00583cd34d92..e2ae2c3892f2 100644
--- a/emulators/vice/distinfo
+++ b/emulators/vice/distinfo
@@ -1,3 +1,3 @@
-MD5 (vice-2.1.tar.gz) = a4cca1aad12e12ac7f37d6c85310ade8
-SHA256 (vice-2.1.tar.gz) = dc42df924bd4b4ab4af43e372d873a79ea035059f31f2f5c297c234b1c532c66
-SIZE (vice-2.1.tar.gz) = 8097482
+MD5 (vice-2.2.tar.gz) = 6737f540806205384e9129026898b0a1
+SHA256 (vice-2.2.tar.gz) = 5d581bf817c97f1887651f92e73dd1f5e3c14627fa86fc70732491be7cba1551
+SIZE (vice-2.2.tar.gz) = 9597027
diff --git a/emulators/vice/files/patch-configure b/emulators/vice/files/patch-configure
deleted file mode 100644
index f3a6479e3b69..000000000000
--- a/emulators/vice/files/patch-configure
+++ /dev/null
@@ -1,43 +0,0 @@
---- configure.orig Sun Aug 27 22:15:37 2006
-+++ configure Thu Sep 7 21:18:29 2006
-@@ -6486,7 +6486,7 @@
- fi
-
- if test x"$with_sdl" = "xyes"; then
-- for ac_prog in sdl-config
-+ for ac_prog in ${SDL_CONFIG##*/}
- do
- # Extract the first word of "$ac_prog", so it can be a program name with args.
- set dummy $ac_prog; ac_word=$2
-@@ -14392,6 +14392,7 @@
- else
- ac_check_lib_save_LIBS=$LIBS
- LIBS="-lesd $SOUND_LIBS $LIBS"
-+CPPFLAGS="`esd-config --cflags` $CPPFLAGS"
- cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
- /* confdefs.h. */
-@@ -14458,10 +14459,10 @@
- if test x"$with_sdl" = "xyes"; then
- old_cflags=$CFLAGS
- old_libs=$LIBS
-- CFLAGS="$CFLAGS `sdl-config --cflags`"
-- LIBS="$LIBS `sdl-config --libs`"
-+ CFLAGS="$CFLAGS `${SDL_CONFIG} --cflags`"
-+ LIBS="$LIBS `${SDL_CONFIG} --libs`"
-
--for ac_header in SDL/SDL_audio.h
-+for ac_header in SDL_audio.h
- do
- as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
- if eval "test \"\${$as_ac_Header+set}\" = set"; then
-@@ -14603,7 +14604,8 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lSDL $SOUND_LIBS $LIBS"
-+LIBS="`${SDL_CONFIG} --libs` $SOUND_LIBS $LIBS"
-+CFLAGS="`${SDL_CONFIG} --cflags` $CFLAGS"
- cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
- /* confdefs.h. */
diff --git a/emulators/vice/files/patch-dynlib.c b/emulators/vice/files/patch-dynlib.c
new file mode 100644
index 000000000000..3a1582bb98b0
--- /dev/null
+++ b/emulators/vice/files/patch-dynlib.c
@@ -0,0 +1,11 @@
+--- src/arch/unix/dynlib.c.orig 2009-10-21 18:46:46.000000000 +0200
++++ src/arch/unix/dynlib.c 2009-12-25 19:00:10.000000000 +0100
+@@ -51,6 +51,8 @@
+
+ #else
+
++#include <string.h>
++
+ void *vice_dynlib_open(const char *name)
+ {
+ return NULL;
diff --git a/emulators/vice/files/patch-joy_usb.c b/emulators/vice/files/patch-joy_usb.c
new file mode 100644
index 000000000000..915bbd072b9d
--- /dev/null
+++ b/emulators/vice/files/patch-joy_usb.c
@@ -0,0 +1,16 @@
+--- src/arch/unix/joy_usb.c.orig 2009-10-21 18:46:46.000000000 +0200
++++ src/arch/unix/joy_usb.c 2009-12-25 18:32:15.000000000 +0100
+@@ -179,11 +179,9 @@
+ found = 0;
+ is_joy = 0;
+ #if !defined(HAVE_USBHID_H) && !defined(HAVE_LIBUSB_H) && defined(HAVE_LIBUSBHID)
+- for (d = hid_start_parse(report, id) {
+- }
++ for (d = hid_start_parse(report, id);
+ #else
+- for (d = hid_start_parse(report, 1 << hid_input, id) {
+- }
++ for (d = hid_start_parse(report, 1 << hid_input, id);
+ #endif
+ hid_get_item(d, &h);
+ )
diff --git a/emulators/vice/files/patch-soundsdl.c b/emulators/vice/files/patch-soundsdl.c
deleted file mode 100644
index 4cae0d658793..000000000000
--- a/emulators/vice/files/patch-soundsdl.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/sounddrv/soundsdl.c.orig Sat Jan 12 21:35:58 2002
-+++ src/sounddrv/soundsdl.c Fri Feb 14 03:13:41 2003
-@@ -26,7 +26,7 @@
-
- /* XXX: includes */
-
--#include <SDL/SDL_audio.h>
-+#include <SDL_audio.h>
- #include <unistd.h>
-
- #include "vice.h"
diff --git a/emulators/vice/pkg-plist b/emulators/vice/pkg-plist
index 1a6139077092..21e0f055e10f 100644
--- a/emulators/vice/pkg-plist
+++ b/emulators/vice/pkg-plist
@@ -39,6 +39,7 @@ lib/vice/C128/kernalit
lib/vice/C128/kernalno
lib/vice/C128/kernalse
lib/vice/C128/pc64.vpl
+lib/vice/C128/vdc_comp.vpl
lib/vice/C128/vdc_deft.vpl
lib/vice/C128/vice.vpl
lib/vice/C128/x11_pos.vkm
@@ -57,21 +58,15 @@ lib/vice/C64/kernal
lib/vice/C64/pc64.vpl
lib/vice/C64/vice.vpl
lib/vice/C64/x11_pos.vkm
+lib/vice/C64/x11_posger.vkm
lib/vice/C64/x11_sym.vkm
+lib/vice/C64/x11_symger.vkm
lib/vice/C64DTV/basic
-lib/vice/C64DTV/c64hq.vpl
lib/vice/C64DTV/c64mem.sym
-lib/vice/C64DTV/c64s.vpl
-lib/vice/C64DTV/ccs64.vpl
lib/vice/C64DTV/chargen
-lib/vice/C64DTV/default.vpl
lib/vice/C64DTV/default.vrs
lib/vice/C64DTV/dtvrom.bin
-lib/vice/C64DTV/frodo.vpl
-lib/vice/C64DTV/godot.vpl
lib/vice/C64DTV/kernal
-lib/vice/C64DTV/pc64.vpl
-lib/vice/C64DTV/vice.vpl
lib/vice/C64DTV/x11_pos.vkm
lib/vice/C64DTV/x11_sym.vkm
lib/vice/CBM-II/amber.vpl
@@ -165,9 +160,12 @@ lib/vice/fonts/CBM.ttf
%%PORTDOCS%%%%DOCSDIR%%/64doc.txt
%%PORTDOCS%%%%DOCSDIR%%/BUGS
%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/CommodoreInnovationPriceSoftware2008.jpg
%%PORTDOCS%%%%DOCSDIR%%/GP2X-Howto.txt
%%PORTDOCS%%%%DOCSDIR%%/MSDOS-Ethernet-Howto.txt
%%PORTDOCS%%%%DOCSDIR%%/MSDOS-Howto.txt
+%%PORTDOCS%%%%DOCSDIR%%/MacOSX-Build.txt
+%%PORTDOCS%%%%DOCSDIR%%/MacOSX-ResourceTree.txt
%%PORTDOCS%%%%DOCSDIR%%/Minix-Howto.txt
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/NLS-Howto.txt
@@ -176,6 +174,7 @@ lib/vice/fonts/CBM.ttf
%%PORTDOCS%%%%DOCSDIR%%/Readme.beos
%%PORTDOCS%%%%DOCSDIR%%/Readme.dos
%%PORTDOCS%%%%DOCSDIR%%/ReadmeMacOSX.txt
+%%PORTDOCS%%%%DOCSDIR%%/ReadmeSDL.txt
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/Walkthrough-Howto.txt
%%PORTDOCS%%%%DOCSDIR%%/Win32-Cygwin-HOWTO.txt
@@ -186,7 +185,6 @@ lib/vice/fonts/CBM.ttf
%%PORTDOCS%%%%DOCSDIR%%/cbm_basic_tokens.txt
%%PORTDOCS%%%%DOCSDIR%%/coding-guidelines.txt
%%PORTDOCS%%%%DOCSDIR%%/drive_info.txt
-%%PORTDOCS%%%%DOCSDIR%%/hpux.html
%%PORTDOCS%%%%DOCSDIR%%/iec-bus.txt
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/macosx.html