aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2024-10-02 23:22:08 +0000
committerDima Panov <fluffy@FreeBSD.org>2024-10-03 10:24:51 +0000
commit6e08df7a700e25093228b2d9a02d6dbc99a9c06a (patch)
tree6a23d377eef08511d8e93b3cf9155540c9d02df9
parentd62e2fd749c41c26c5b88b822cab14545ee17639 (diff)
downloadports-6e08df7a700e25093228b2d9a02d6dbc99a9c06a.tar.gz
ports-6e08df7a700e25093228b2d9a02d6dbc99a9c06a.zip
comms/gnuradio: unbreak build with boost-1.85
With hat: office Sponsored by: Future Crew, LLC
-rw-r--r--comms/gnuradio/Makefile2
-rw-r--r--comms/gnuradio/files/patch-cmake_Modules_FindQwt.cmake6
-rw-r--r--comms/gnuradio/files/patch-gnuradio-runtime_lib_prefs.cc10
3 files changed, 14 insertions, 4 deletions
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index 8fb7adac66fd..c4f176fa4e56 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -1,7 +1,7 @@
PORTNAME= gnuradio
DISTVERSIONPREFIX= v
DISTVERSION= 3.8.4.0
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES= comms astro hamradio
MAINTAINER= hamradio@FreeBSD.org
diff --git a/comms/gnuradio/files/patch-cmake_Modules_FindQwt.cmake b/comms/gnuradio/files/patch-cmake_Modules_FindQwt.cmake
index 47cf94e557b3..d9d21d762403 100644
--- a/comms/gnuradio/files/patch-cmake_Modules_FindQwt.cmake
+++ b/comms/gnuradio/files/patch-cmake_Modules_FindQwt.cmake
@@ -1,14 +1,14 @@
---- cmake/Modules/FindQwt.cmake.orig 2020-04-01 19:08:22 UTC
+--- cmake/Modules/FindQwt.cmake.orig 2021-09-30 14:10:55 UTC
+++ cmake/Modules/FindQwt.cmake
@@ -15,6 +15,7 @@ find_path(QWT_INCLUDE_DIRS
${CMAKE_INSTALL_PREFIX}/include/qwt
- ${CMAKE_PREFIX_PATH}/include/qwt
+ list(APPEND ${CMAKE_PREFIX_PATH} /include/qwt)
PATHS
+ /usr/local/include/qt5/qwt6
/usr/local/include/qwt-${QWT_QT_VERSION}
/usr/local/include/qwt
/usr/include/qwt6
-@@ -29,9 +30,10 @@ find_path(QWT_INCLUDE_DIRS
+@@ -29,9 +30,10 @@ find_library (QWT_LIBRARIES
)
find_library (QWT_LIBRARIES
diff --git a/comms/gnuradio/files/patch-gnuradio-runtime_lib_prefs.cc b/comms/gnuradio/files/patch-gnuradio-runtime_lib_prefs.cc
new file mode 100644
index 000000000000..b22758d7d69b
--- /dev/null
+++ b/comms/gnuradio/files/patch-gnuradio-runtime_lib_prefs.cc
@@ -0,0 +1,10 @@
+--- gnuradio-runtime/lib/prefs.cc.orig 2021-09-30 14:10:55 UTC
++++ gnuradio-runtime/lib/prefs.cc
+@@ -32,6 +32,7 @@
+ #include <fstream>
+ #include <iostream>
+
++#include <boost/filesystem/directory.hpp>
+ #include <boost/filesystem/fstream.hpp>
+ #include <boost/filesystem/operations.hpp>
+ #include <boost/filesystem/path.hpp>