aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 05:29:03 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 06:00:04 +0000
commit6e47d94d470552abba2e10423a8b9e1316fbc7e7 (patch)
tree86a09ff38acabcf5a0d287ea36dd30a69bd96245
parent86b1bef7112d5f8e5544ee66ea1ff665bbee1092 (diff)
downloadports-6e47d94d470552abba2e10423a8b9e1316fbc7e7.tar.gz
ports-6e47d94d470552abba2e10423a8b9e1316fbc7e7.zip
devel/pear-PHP_UML: Fix *_DEPENDS
- Remove duplicate BUILD_DEPENDS and RUN_DEPENDS - Add NO_ARCH - pkg-descr - Bump PORTREVISION for dependency change
-rw-r--r--devel/pear-PHP_UML/Makefile8
-rw-r--r--devel/pear-PHP_UML/pkg-descr9
2 files changed, 11 insertions, 6 deletions
diff --git a/devel/pear-PHP_UML/Makefile b/devel/pear-PHP_UML/Makefile
index 76b392ebd04a..016e12ee94d8 100644
--- a/devel/pear-PHP_UML/Makefile
+++ b/devel/pear-PHP_UML/Makefile
@@ -9,11 +9,11 @@ COMMENT= PEAR Class to Create UML Representation of PHP Code
LICENSE= LGPL3
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:devel/pear@${PHP_FLAVOR} \
- ${PEARDIR}/Console/CommandLine.php:devel/pear-Console_CommandLine@${PHP_FLAVOR}
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:devel/pear@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEAR_PKGNAMEPREFIX}Console_CommandLine>=0:devel/pear-Console_CommandLine@${PHP_FLAVOR}
-USES= pear php
+USES= pear
USE_PHP= spl xsl
+NO_ARCH= yes
+
.include <bsd.port.mk>
diff --git a/devel/pear-PHP_UML/pkg-descr b/devel/pear-PHP_UML/pkg-descr
index 1fb139a9848b..614e706eb2bd 100644
--- a/devel/pear-PHP_UML/pkg-descr
+++ b/devel/pear-PHP_UML/pkg-descr
@@ -1,4 +1,9 @@
-PHP_UML is a reverse-engineering package that scans PHP files and directories,
-and delivers an UML/XMI representation of the classes and packages found.
+PHP_UML is a PHP parser, an XMI generator and a documentation tool.
+
+Practically, with PHP_UML, you will be able to feed a UML CASE tool, like
+Rational Rose or Argouml, with a UML representation of existing PHP source code.
+This way, you get an instant overview of a PHP application, with all the usual
+functions of a software design tool (such as class diagrams exportation,
+refactoring of object-oriented applications, or automatic code generation).
WWW: https://pear.php.net/package/PHP_UML