aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Jensen <erik@tenku.dk>2023-03-26 17:51:25 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-03-27 09:59:28 +0000
commit6e66e8aa832e22ec7bf21dd9dea8439023f224e0 (patch)
tree25ae7567b18f5a8e7b8dae7c626d1e9ef2a89453
parenteba6f6e1e4066117cf90310be077e3eedb8cf179 (diff)
downloadports-6e66e8aa832e22ec7bf21dd9dea8439023f224e0.tar.gz
ports-6e66e8aa832e22ec7bf21dd9dea8439023f224e0.zip
devel/ptl: new port. Lightweight C++11 multithreading tasking system
Parallel Tasking Library is a needed dependency for the upcoming update of science/geant4. ChangeLog: https://github.com/jrmadsen/PTL PR: 268992 Reported by: erik@tenku.dk
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ptl/Makefile25
-rw-r--r--devel/ptl/distinfo3
-rw-r--r--devel/ptl/pkg-descr2
-rw-r--r--devel/ptl/pkg-plist35
5 files changed, 66 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4abfd541fa59..b1e09116d0b6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4133,6 +4133,7 @@
SUBDIR += pth-hard
SUBDIR += pthreadpool
SUBDIR += pthsem
+ SUBDIR += ptl
SUBDIR += ptlib
SUBDIR += ptmalloc
SUBDIR += ptmalloc2
diff --git a/devel/ptl/Makefile b/devel/ptl/Makefile
new file mode 100644
index 000000000000..d2fad40a7871
--- /dev/null
+++ b/devel/ptl/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= ptl
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.3.3
+CATEGORIES= devel
+
+MAINTAINER= erik@tenku.dk
+COMMENT= Lightweight C++11 multithreading tasking system
+WWW= https://github.com/jrmadsen/PTL
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libtbb.so:devel/onetbb
+
+USES= cmake compiler:c++11-lang
+USE_GITHUB= yes
+GH_ACCOUNT= jrmadsen
+GH_PROJECT= PTL
+
+CMAKE_OFF= BUILD_STATIC_LIBS
+
+PLIST_SUB+= SHLIB_SHVER="${DISTVERSION:R:R}" \
+ SHLIB_VER="${DISTVERSION}"
+
+.include <bsd.port.mk>
diff --git a/devel/ptl/distinfo b/devel/ptl/distinfo
new file mode 100644
index 000000000000..6e149b292a63
--- /dev/null
+++ b/devel/ptl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1672757282
+SHA256 (jrmadsen-PTL-v2.3.3_GH0.tar.gz) = 3275ad8ec2971c89aacb3b922717dc4e774fa4e59fc3f4035053225c802aee52
+SIZE (jrmadsen-PTL-v2.3.3_GH0.tar.gz) = 302890
diff --git a/devel/ptl/pkg-descr b/devel/ptl/pkg-descr
new file mode 100644
index 000000000000..95db92a36cb7
--- /dev/null
+++ b/devel/ptl/pkg-descr
@@ -0,0 +1,2 @@
+Lightweight C++11 multithreading tasking system featuring
+thread-pool, task-groups, and lock-free task queue
diff --git a/devel/ptl/pkg-plist b/devel/ptl/pkg-plist
new file mode 100644
index 000000000000..99a7e95ff158
--- /dev/null
+++ b/devel/ptl/pkg-plist
@@ -0,0 +1,35 @@
+include/PTL/AutoLock.hh
+include/PTL/Backtrace.hh
+include/PTL/Config.hh
+include/PTL/Globals.hh
+include/PTL/JoinFunction.hh
+include/PTL/PTL.hh
+include/PTL/Singleton.hh
+include/PTL/Task.hh
+include/PTL/TaskGroup.hh
+include/PTL/TaskGroup.icc
+include/PTL/TaskManager.hh
+include/PTL/TaskRunManager.hh
+include/PTL/TBBTaskGroup.hh
+include/PTL/ThreadData.hh
+include/PTL/Threading.hh
+include/PTL/ThreadPool.hh
+include/PTL/Timer.hh
+include/PTL/Timer.icc
+include/PTL/Tuple.hh
+include/PTL/Types.hh
+include/PTL/UserTaskQueue.hh
+include/PTL/UserTaskQueue.icc
+include/PTL/Utility.hh
+include/PTL/Version.hh
+include/PTL/VTask.hh
+include/PTL/VUserTaskQueue.hh
+lib/cmake/PTL/Modules/FindTBB.cmake
+lib/cmake/PTL/PTLConfig.cmake
+lib/cmake/PTL/PTLConfigVersion.cmake
+lib/cmake/PTL/PTLTargets-release.cmake
+lib/cmake/PTL/PTLTargets.cmake
+lib/libptl.so
+lib/libptl.so.%%SHLIB_SHVER%%
+lib/libptl.so.%%SHLIB_VER%%
+libdata/pkgconfig/ptl.pc