aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2022-04-27 06:15:20 +0000
committerJason E. Hale <jhale@FreeBSD.org>2022-04-27 06:36:08 +0000
commit6eacb27771de8e407e06debe3f62aa09ba4a43ae (patch)
treedd1fb853d8e75a1258060090ff5edec76460fc13
parent96ee80b0c99281191ffb8f508043177793e6eac4 (diff)
downloadports-6eacb27771de8e407e06debe3f62aa09ba4a43ae.tar.gz
ports-6eacb27771de8e407e06debe3f62aa09ba4a43ae.zip
x11-themes/qtcurve-gtk2: Fix configure
Fix configure with KDE Frameworks 5.93.0 https://cgit.freebsd.org/ports/commit/?id=cbf73704b339d4c617d45b442a845c596b955c29 After changes to the CMake modules, it now expects to find qmake and the Qt buildtools. CMake Error at /usr/local/lib/cmake/Qt5Core/Qt5CoreConfig.cmake:14 (message): The imported target "Qt5::Core" references the file "/usr/local/lib/qt5/bin/qmake" but this file does not exist. Possible reasons include: * The file was deleted, renamed, or moved to another location. * An install or uninstall procedure did not complete successfully. * The installation package was faulty and contained "/usr/local/lib/cmake/Qt5Core/Qt5CoreConfigExtras.cmake" but not all the files it references. Call Stack (most recent call first): /usr/local/lib/cmake/Qt5Core/Qt5CoreConfigExtras.cmake:9 (_qt5_Core_check_file_exists) /usr/local/lib/cmake/Qt5Core/Qt5CoreConfig.cmake:232 (include) /usr/local/share/cmake/Modules/CMakeFindDependencyMacro.cmake:47 (find_package) /usr/local/lib/cmake/KF5I18n/KF5I18nConfig.cmake:28 (find_dependency) CMakeLists.txt:257 (find_package) Reported by: pkg-fallout
-rw-r--r--x11-themes/qtcurve/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/x11-themes/qtcurve/Makefile b/x11-themes/qtcurve/Makefile
index 997f58ff8cde..a09d2043595c 100644
--- a/x11-themes/qtcurve/Makefile
+++ b/x11-themes/qtcurve/Makefile
@@ -64,8 +64,9 @@ LIB_DEPENDS+= libqtcurve-utils.so:x11-themes/qtcurve-utils
.if ${QTCURVE_SLAVE} == "gtk2"
PKGNAMEPREFIX= gtk2-
PKGNAMESUFFIX= -theme
-USES+= gettext-runtime gnome kde:5
+USES+= gettext-runtime gnome kde:5 qt:5
USE_KDE= i18n_build
+USE_QT+= buildtools_build qmake_build
USE_GNOME= cairo gdkpixbuf2 gtk20 pango
USE_LDCONFIG= yes