aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVidar Karlsen <vidar@karlsen.tech>2022-05-06 12:05:11 +0000
committerNeel Chauhan <nc@FreeBSD.org>2022-08-27 02:23:47 +0000
commit6ef20e1815c7eea2a3213a44777e3ea0ce518baf (patch)
tree40c2d40be3bed6f5dfa3e6d31b93f90f3942aac3
parent14283c778ff58c5f5035af88bd3a4a0dbec6e4ab (diff)
downloadports-6ef20e1815c7eea2a3213a44777e3ea0ce518baf.tar.gz
ports-6ef20e1815c7eea2a3213a44777e3ea0ce518baf.zip
x11/openrgb: New port
PR: 263815
-rw-r--r--x11/Makefile1
-rw-r--r--x11/openrgb/Makefile35
-rw-r--r--x11/openrgb/distinfo3
-rw-r--r--x11/openrgb/files/patch-OpenRGB.pro11
-rw-r--r--x11/openrgb/pkg-descr3
5 files changed, 53 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index d2f513fa00a9..d7dbf4814d9a 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -266,6 +266,7 @@
SUBDIR += nwg-look
SUBDIR += nwg-menu
SUBDIR += nxcomp
+ SUBDIR += openrgb
SUBDIR += p5-Clipboard
SUBDIR += p5-X11-GUITest
SUBDIR += p5-X11-IdleTime
diff --git a/x11/openrgb/Makefile b/x11/openrgb/Makefile
new file mode 100644
index 000000000000..a9d80a988883
--- /dev/null
+++ b/x11/openrgb/Makefile
@@ -0,0 +1,35 @@
+PORTNAME= openrgb
+PORTVERSION= 0.7.20220505
+CATEGORIES= x11
+
+MAINTAINER= vidar@karlsen.tech
+COMMENT= Software to control a multitude of (a)RGB devices
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= git>0:devel/git \
+ hidapi>0:comms/hidapi \
+ mbedtls>0:security/mbedtls \
+ qt5-qmake>0:devel/qt5-qmake
+LIB_DEPENDS= libGL.so:graphics/libglvnd \
+ libhidapi.so:comms/hidapi \
+ libmbedcrypto.so:security/mbedtls \
+ libmbedtls.so:security/mbedtls \
+ libmbedx509.so:security/mbedtls
+
+USES= gmake gl qmake qt:5
+
+USE_GITLAB= yes
+GL_ACCOUNT= CalcProgrammer1
+GL_PROJECT= OpenRGB
+GL_COMMIT= 817d5d55dfb2baf932effe9fec9c557ad1529eb9
+
+USE_GL= gl
+USE_QT= buildtools core gui widgets
+
+PLIST_FILES= bin/openrgb
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/openrgb ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/x11/openrgb/distinfo b/x11/openrgb/distinfo
new file mode 100644
index 000000000000..ab06e9449700
--- /dev/null
+++ b/x11/openrgb/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1651760910
+SHA256 (CalcProgrammer1-OpenRGB-817d5d55dfb2baf932effe9fec9c557ad1529eb9_GL0.tar.gz) = fdc25136ccbd97c793f170fff14b45a9195136fe46e8f8c594048e786a97fe3d
+SIZE (CalcProgrammer1-OpenRGB-817d5d55dfb2baf932effe9fec9c557ad1529eb9_GL0.tar.gz) = 29236808
diff --git a/x11/openrgb/files/patch-OpenRGB.pro b/x11/openrgb/files/patch-OpenRGB.pro
new file mode 100644
index 000000000000..ed6d88129dcc
--- /dev/null
+++ b/x11/openrgb/files/patch-OpenRGB.pro
@@ -0,0 +1,11 @@
+--- OpenRGB.pro.orig 2022-05-05 02:48:58 UTC
++++ OpenRGB.pro
+@@ -40,7 +40,7 @@ TEMPLATE = app
+ # Automatically generated build information #
+ #-----------------------------------------------------------------------------------------------#
+ win32:BUILDDATE = $$system(date /t)
+-unix:BUILDDATE = $$system(date -R -d "@${SOURCE_DATE_EPOCH:-$(date +%s)}")
++unix:BUILDDATE = $$system(date -R)
+ GIT_COMMIT_ID = $$system(git --git-dir $$_PRO_FILE_PWD_/.git --work-tree $$_PRO_FILE_PWD_ rev-parse HEAD)
+ GIT_COMMIT_DATE = $$system(git --git-dir $$_PRO_FILE_PWD_/.git --work-tree $$_PRO_FILE_PWD_ show -s --format=%ci HEAD)
+ GIT_BRANCH = $$system(git --git-dir $$_PRO_FILE_PWD_/.git --work-tree $$_PRO_FILE_PWD_ rev-parse --abbrev-ref HEAD)
diff --git a/x11/openrgb/pkg-descr b/x11/openrgb/pkg-descr
new file mode 100644
index 000000000000..2de98194fa11
--- /dev/null
+++ b/x11/openrgb/pkg-descr
@@ -0,0 +1,3 @@
+Open source RGB lighting control that doesn't depend on manufacturer software.
+
+WWW: https://openrgb.org