aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-14 01:06:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-14 01:06:34 +0000
commit6ef437e7a029583fc63a6ca96fb93d54a7b47a2d (patch)
tree5a06d20718f5de22d7baa76bdfd754a464a2a2f9
parent417e26319ab62281334caf9d24274e11a958d2ce (diff)
downloadports-6ef437e7a029583fc63a6ca96fb93d54a7b47a2d.tar.gz
ports-6ef437e7a029583fc63a6ca96fb93d54a7b47a2d.zip
- Update to 0.2
PR: ports/62582 Submitted by: Yonatan Bokovza <Yonatan@Xpert.com>
Notes
Notes: svn path=/head/; revision=103923
-rw-r--r--net/xprobe/Makefile27
-rw-r--r--net/xprobe/distinfo3
-rw-r--r--net/xprobe/files/patch-Makefile_in28
-rw-r--r--net/xprobe/files/patch-USI++:src:Makefile.in11
-rw-r--r--net/xprobe/files/patch-configure22
-rw-r--r--net/xprobe/files/patch-docs:xprobe2.111
-rw-r--r--net/xprobe/files/patch-src:config_set.cc12
-rw-r--r--net/xprobe/files/patch-src:os_matrix.cc12
-rw-r--r--net/xprobe/pkg-plist3
9 files changed, 82 insertions, 47 deletions
diff --git a/net/xprobe/Makefile b/net/xprobe/Makefile
index 8a54e6f2fe1d..37e1686edb61 100644
--- a/net/xprobe/Makefile
+++ b/net/xprobe/Makefile
@@ -5,17 +5,30 @@
# $FreeBSD$
#
-PORTNAME= xprobe
-PORTVERSION= 0.0.2
-CATEGORIES= net security
-MASTER_SITES= http://www.sys-security.com/archive/tools/X/
+PORTNAME= xprobe2
+PORTVERSION= 0.2
+CATEGORIES= net
+MASTER_SITES= http://www.sys-security.com/archive/tools/xprobe2/
MAINTAINER= ports@FreeBSD.org
COMMENT= ICMP active OS fingerprint scanner
-GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
+USE_REINPLACE= yes
-MAN1= xprobe.1
-PLIST_FILES= bin/xprobe
+MAN1= xprobe2.1
+
+pre-configure:
+ ( cd ${WRKSRC}/libs-external/USI++/src ; CFLAGS="${CFLAGS}" ./configure --prefix=${PREFIX} ${CONFIGURE_TARGET} )
+
+# force -O0 for these modules otherwise gcc 3.3.3 20031106 dies with internal error
+post-configure:
+ @${FIND} ${WRKSRC}/src/xpmodules/os_probe -name Makefile | ${XARGS} ${REINPLACE_CMD} -e 's|${CFLAGS}|-O0|'
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/xprobe2 ${PREFIX}/bin
+ ${INSTALL} -d ${PREFIX}/etc/xprobe2
+ ${INSTALL_DATA} ${WRKSRC}/etc/xprobe2.conf ${PREFIX}/etc/xprobe2
+ ${INSTALL_MAN} ${WRKSRC}/docs/xprobe2.1 ${PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/net/xprobe/distinfo b/net/xprobe/distinfo
index 2d3e81d3c99b..2a8ae1e0ea95 100644
--- a/net/xprobe/distinfo
+++ b/net/xprobe/distinfo
@@ -1,2 +1,3 @@
-MD5 (xprobe-0.0.2.tar.gz) = 72761231d7829e0ce4eb8f7db9049405
+MD5 (xprobe2-0.2.tar.gz) = ca723a7e4c8c5001191efdb43e63bbee
+SIZE (xprobe2-0.2.tar.gz) = 474216
SIZE (xprobe-0.0.2.tar.gz) = 52117
diff --git a/net/xprobe/files/patch-Makefile_in b/net/xprobe/files/patch-Makefile_in
deleted file mode 100644
index 06078a1f1cc8..000000000000
--- a/net/xprobe/files/patch-Makefile_in
+++ /dev/null
@@ -1,28 +0,0 @@
---- Makefile.in.orig Wed Oct 16 22:23:24 2002
-+++ Makefile.in Wed Oct 16 22:25:19 2002
-@@ -28,8 +28,8 @@
- DESTDIR=
- prefix=@prefix@
- exec_prefix=@exec_prefix@
--bindir=@bindir@
--mandir=@mandir@
-+BINDIR=@bindir@
-+MANDIR=@mandir@
- PACKAGE=@PACKAGE@
- VERSION=@VERSION@
- CPPFLAGS=@CPPFLAGS@
-@@ -58,10 +58,10 @@
- rm -f config.h config.cache config.log config.status Makefile
-
- install: xprobe
-- $(INSTALL_PROGRAM) -d $(DESTDIR)/$(bindir)
-- $(INSTALL_PROGRAM) -d $(DESTDIR)/$(mandir)/man1
-- $(INSTALL_PROGRAM) -m 0755 xprobe $(DESTDIR)/$(bindir)
-- $(INSTALL_DATA) xprobe.1 $(mandir)/man1
-+ $(INSTALL) -d $(DESTDIR)$(BINDIR)
-+ $(INSTALL) -d $(DESTDIR)$(MANDIR)/man1
-+ $(INSTALL_PROGRAM) -m 0755 xprobe $(DESTDIR)$(BINDIR)
-+ $(INSTALL_DATA) xprobe.1 $(DESTDIR)$(MANDIR)/man1
-
- configure: configure.in
- autoheader
diff --git a/net/xprobe/files/patch-USI++:src:Makefile.in b/net/xprobe/files/patch-USI++:src:Makefile.in
new file mode 100644
index 000000000000..78ddaa92ce6d
--- /dev/null
+++ b/net/xprobe/files/patch-USI++:src:Makefile.in
@@ -0,0 +1,11 @@
+--- libs-external/USI++/src/Makefile.in.orig Sun Feb 8 21:56:52 2004
++++ libs-external/USI++/src/Makefile.in Sun Feb 8 22:02:00 2004
+@@ -2,7 +2,7 @@
+ #
+
+ LIBS=@LIBS@
+-CFLAGS=@CFLAGS@ -I/usr/include/pcap -I. -Wall
++CFLAGS=@CFLAGS@ -I/usr/include -I. -Wall
+ CXX=@CXX@
+ INSTALL=@INSTALL@
+ RANLIB=@RANLIB@
diff --git a/net/xprobe/files/patch-configure b/net/xprobe/files/patch-configure
index 7e92f3b0d0bf..a612209e511c 100644
--- a/net/xprobe/files/patch-configure
+++ b/net/xprobe/files/patch-configure
@@ -1,11 +1,11 @@
---- configure.orig Wed Oct 16 22:25:33 2002
-+++ configure Wed Oct 16 22:26:15 2002
-@@ -9,7 +9,7 @@
-
- # Defaults:
- ac_help=
--ac_default_prefix=/usr/local
-+ac_default_prefix=${LOCALBASE}
- # Any additions from configure.in:
- ac_help="$ac_help
- --enable-debug enable debugging )"
+--- configure.orig Fri Sep 26 11:40:23 2003
++++ configure Sun Feb 8 20:34:37 2004
+@@ -4095,7 +4095,7 @@
+ fi
+
+
+-subdirs="libs-external/USI++/src"
++#subdirs="libs-external/USI++/src"
+
+
+
diff --git a/net/xprobe/files/patch-docs:xprobe2.1 b/net/xprobe/files/patch-docs:xprobe2.1
new file mode 100644
index 000000000000..1df460011671
--- /dev/null
+++ b/net/xprobe/files/patch-docs:xprobe2.1
@@ -0,0 +1,11 @@
+--- docs/xprobe2.1.orig Sun Feb 8 21:35:27 2004
++++ docs/xprobe2.1 Sun Feb 8 21:24:29 2004
+@@ -21,7 +21,7 @@
+
+ .\" Generate man page: groff -man -Tascii xprobe.1
+
+-.TH XPROBE2 "$Id: xprobe2.1,v 1.9 2003/09/23 13:13:48 mederchik Exp $"
++.TH XPROBE2 1 "$Id: xprobe2.1,v 1.9 2003/09/23 13:13:48 mederchik Exp $"
+ .SH NAME
+ xprobe2 \- A Remote active operating system fingerprinting tool.
+ .SH SYNOPSIS
diff --git a/net/xprobe/files/patch-src:config_set.cc b/net/xprobe/files/patch-src:config_set.cc
new file mode 100644
index 000000000000..ca3c53130261
--- /dev/null
+++ b/net/xprobe/files/patch-src:config_set.cc
@@ -0,0 +1,12 @@
+--- src/config_set.cc.orig Fri Sep 26 13:40:23 2003
++++ src/config_set.cc Thu Feb 26 00:32:04 2004
+@@ -158,8 +158,7 @@
+
+ case XP_CONFIG_TK_SECEND:
+ if (get_state() != XP_CONFIG_TK_SECBEGIN) {
+- ui->error("[x] Multiple close sections on line:
+- %i\n", cf->get_linenum());
++ ui->error("[x] Multiple close sections on line: %i\n", cf->get_linenum());
+ return FAIL;
+ }
+ set_state(0);
diff --git a/net/xprobe/files/patch-src:os_matrix.cc b/net/xprobe/files/patch-src:os_matrix.cc
new file mode 100644
index 000000000000..72affbdc7bc2
--- /dev/null
+++ b/net/xprobe/files/patch-src:os_matrix.cc
@@ -0,0 +1,12 @@
+--- src/os_matrix.cc.orig Fri Sep 26 13:40:23 2003
++++ src/os_matrix.cc Thu Feb 26 00:33:20 2004
+@@ -84,8 +84,7 @@
+ xprobe_mdebug(XPROBE_DEBUG_OSMATRIX,"Following systems are recognizable\n");
+ for (osid_i = osid_name.begin();
+ osid_i != osid_name.end(); osid_i++) {
+- xprobe_debug(XPROBE_DEBUG_OSMATRIX,"Id: %i\tOS:
+- %s\n",(*osid_i).first, (*osid_i).second.c_str());
++ xprobe_debug(XPROBE_DEBUG_OSMATRIX,"Id: %i\tOS: %s\n",(*osid_i).first, (*osid_i).second.c_str());
+ }
+ }
+
diff --git a/net/xprobe/pkg-plist b/net/xprobe/pkg-plist
new file mode 100644
index 000000000000..4d4d6ba3f657
--- /dev/null
+++ b/net/xprobe/pkg-plist
@@ -0,0 +1,3 @@
+bin/xprobe2
+etc/xprobe2/xprobe2.conf
+@dirrm etc/xprobe2