aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-02-05 21:23:45 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-02-05 22:12:26 +0000
commit6f1a1bc8658a59f8e939b78baa7c596d6f74afa4 (patch)
tree08ee71a2f87e135fce1935a14e9c34c6cdcc82d2
parent9141bfa20a583cba873d4961ab31378447cd2dd4 (diff)
downloadports-6f1a1bc8658a59f8e939b78baa7c596d6f74afa4.tar.gz
ports-6f1a1bc8658a59f8e939b78baa7c596d6f74afa4.zip
devel/py-hunter: New port: Flexible code tracing toolkit
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-hunter/Makefile26
-rw-r--r--devel/py-hunter/distinfo3
-rw-r--r--devel/py-hunter/pkg-descr3
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3dd2972a6e5c..c5a6fedc8921 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4682,6 +4682,7 @@
SUBDIR += py-homebase
SUBDIR += py-http-prompt
SUBDIR += py-humanize
+ SUBDIR += py-hunter
SUBDIR += py-hupper
SUBDIR += py-hvac
SUBDIR += py-hypothesis
diff --git a/devel/py-hunter/Makefile b/devel/py-hunter/Makefile
new file mode 100644
index 000000000000..aeafbe99c4cc
--- /dev/null
+++ b/devel/py-hunter/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= hunter
+DISTVERSION= 3.5.1
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Flexible code tracing toolkit
+WWW= https://github.com/ionelmc/python-hunter
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=30.3.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.3.1:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= pep517 cython autoplist pytest # tests fail to run, see https://github.com/ionelmc/python-hunter/issues/114
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+post-install:
+ @${FIND} ${STAGEDIR}${PREFIX} -name "*.so" | ${XARGS} ${STRIP_CMD}
+
+.include <bsd.port.mk>
diff --git a/devel/py-hunter/distinfo b/devel/py-hunter/distinfo
new file mode 100644
index 000000000000..896a62491b44
--- /dev/null
+++ b/devel/py-hunter/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1675631477
+SHA256 (hunter-3.5.1.tar.gz) = cdf094a5f3c85b1f95bb9d4f508d505225984ae03fc1ad9c364866584b1dbc95
+SIZE (hunter-3.5.1.tar.gz) = 561530
diff --git a/devel/py-hunter/pkg-descr b/devel/py-hunter/pkg-descr
new file mode 100644
index 000000000000..1eff8579013d
--- /dev/null
+++ b/devel/py-hunter/pkg-descr
@@ -0,0 +1,3 @@
+Hunter is a flexible code tracing toolkit, not for measuring coverage, but for
+debugging, logging, inspection and other nefarious purposes. It has a simple
+Python API, a convenient terminal API and a CLI tool to attach to processes.