aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-27 04:06:37 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-27 04:06:37 +0000
commit6f35a7bf121af695812797c5715c25ab174646d9 (patch)
treef3fad0fc4127f2f8b06ad9ae9daa11e91181b6bf
parentc9fc03a86b66b91af8eb6985b6bd1a60f2fe2e34 (diff)
downloadports-6f35a7bf121af695812797c5715c25ab174646d9.tar.gz
ports-6f35a7bf121af695812797c5715c25ab174646d9.zip
devel/py-pytest-jupyter: Add py-pytest-jupyter 0.7.0
pytest-jupyter provides a set of pytest plugins for Jupyter libraries and extensions.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pytest-jupyter/Makefile35
-rw-r--r--devel/py-pytest-jupyter/distinfo3
-rw-r--r--devel/py-pytest-jupyter/pkg-descr2
4 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ea5a5db6acb7..fe5c5824b653 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5292,6 +5292,7 @@
SUBDIR += py-pytest-httpbin
SUBDIR += py-pytest-httpserver
SUBDIR += py-pytest-isort
+ SUBDIR += py-pytest-jupyter
SUBDIR += py-pytest-lazy-fixture
SUBDIR += py-pytest-localserver
SUBDIR += py-pytest-markdown
diff --git a/devel/py-pytest-jupyter/Makefile b/devel/py-pytest-jupyter/Makefile
new file mode 100644
index 000000000000..5b3778b906f0
--- /dev/null
+++ b/devel/py-pytest-jupyter/Makefile
@@ -0,0 +1,35 @@
+PORTNAME= pytest-jupyter
+PORTVERSION= 0.7.0
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pytest_jupyter-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= pytest plugin for testing Jupyter libraries and extensions
+WWW= https://github.com/jupyter-server/pytest-jupyter
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=1.10.0:devel/py-hatchling@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jupyter-core>=0:devel/py-jupyter-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=0,1:devel/py-pytest@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= CLIENT SERVER
+OPTIONS_DEFAULT=CLIENT
+CLIENT_DESC= Client-side support
+SERVER_DESC= Server-side support
+SERVER_IMPLIES= CLIENT
+
+CLIENT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ipykernel>=6.14:devel/py-ipykernel@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jupyter-client>=7.4.0:devel/py-jupyter-client@${PY_FLAVOR}
+SERVER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jupyter-server>=1.21:devel/py-jupyter-server@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nbformat>=5.3:devel/py-nbformat@${PY_FLAVOR}
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytest-jupyter/distinfo b/devel/py-pytest-jupyter/distinfo
new file mode 100644
index 000000000000..5a6aab59efc7
--- /dev/null
+++ b/devel/py-pytest-jupyter/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1684104290
+SHA256 (pytest_jupyter-0.7.0.tar.gz) = 6403b7f6f5eaaa5a9faffd73d2ff1097106a7dc5c3204292212487fc9fb71843
+SIZE (pytest_jupyter-0.7.0.tar.gz) = 15507
diff --git a/devel/py-pytest-jupyter/pkg-descr b/devel/py-pytest-jupyter/pkg-descr
new file mode 100644
index 000000000000..156262325214
--- /dev/null
+++ b/devel/py-pytest-jupyter/pkg-descr
@@ -0,0 +1,2 @@
+pytest-jupyter provides a set of pytest plugins for Jupyter libraries and
+extensions.