aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLev A. Serebryakov <lev@FreeBSD.org>2015-08-20 12:13:00 +0000
committerLev A. Serebryakov <lev@FreeBSD.org>2015-08-20 12:13:00 +0000
commit6f86cf86d6a38c4e4b1e21f9f7bd2644392958c8 (patch)
tree64159cf89c432b72c86387cd0e7456fb276bc4fb
parent6688e86a9f6e95fa2a6b2ed3395cf7d67a6d10c5 (diff)
downloadports-6f86cf86d6a38c4e4b1e21f9f7bd2644392958c8.tar.gz
ports-6f86cf86d6a38c4e4b1e21f9f7bd2644392958c8.zip
Fix detection of BDBv6.
PR: 202505 Submitted by: emz@norma.perm.ru
Notes
Notes: svn path=/head/; revision=394857
-rw-r--r--devel/subversion/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/devel/subversion/Makefile b/devel/subversion/Makefile
index 247342f6a2c4..594f7cda7a36 100644
--- a/devel/subversion/Makefile
+++ b/devel/subversion/Makefile
@@ -1,6 +1,8 @@
# Created by: rooneg@electricjellyfish.net
# $FreeBSD$
+PORTREVISION= 1
+
MAINTAINER= lev@FreeBSD.org
COMMENT= Version control system
@@ -121,9 +123,9 @@ pre-everything::
pre-configure:
.if ${PORT_OPTIONS:MBDB}
@BDB_VERSION=`${APR_APU_DIR}/${APU_CONFIG} --db-version`; \
- if [ "$${BDB_VERSION}" != "4" -a "$${BDB_VERSION}" != "5" ] ; then \
+ if [ "$${BDB_VERSION}" != "4" -a "$${BDB_VERSION}" != "5" -a "$${BDB_VERSION}" != "6" ] ; then \
${ECHO_MSG} "" ; \
- ${ECHO_MSG} 'You should build `'"devel/apr1' with Berkeley DB (4 or 5) support to use subversion with it." ; \
+ ${ECHO_MSG} 'You should build `'"devel/apr1' with Berkeley DB (4, 5 or 6) support to use subversion with it." ; \
${ECHO_MSG} 'Please rebuild `'"devel/apr1' with option "'`'"${OPT_NAME}' and try again." ; \
${ECHO_MSG} "" ; \
${ECHO_MSG} "Or you can disable Berkeley DB support. Only 'fs' repository backend will be available." ; \