aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-12-21 08:58:53 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-12-21 09:03:58 +0000
commit6ff39ce5e9687de3b29b28b1016f896ecfdc77f9 (patch)
treed35db8e70cfa79b38f557eaa5e6563953477266f
parent95377db43e6261dbc53afa6c26c448d5c71ef1a5 (diff)
downloadports-6ff39ce5e9687de3b29b28b1016f896ecfdc77f9.tar.gz
ports-6ff39ce5e9687de3b29b28b1016f896ecfdc77f9.zip
math/onednn: Update 2.4.4 -> 2.5
Reported by: portscout
-rw-r--r--math/onednn/Makefile2
-rw-r--r--math/onednn/distinfo6
-rw-r--r--math/onednn/files/patch-cmake_platform.cmake49
-rw-r--r--math/onednn/pkg-plist16
4 files changed, 34 insertions, 39 deletions
diff --git a/math/onednn/Makefile b/math/onednn/Makefile
index 08e0ac728ab8..699f8a729b89 100644
--- a/math/onednn/Makefile
+++ b/math/onednn/Makefile
@@ -1,6 +1,6 @@
PORTNAME= onednn
DISTVERSIONPREFIX= v
-DISTVERSION= 2.4.4
+DISTVERSION= 2.5
CATEGORIES= math # machine-learning
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/onednn/distinfo b/math/onednn/distinfo
index 69bece172445..474ec4c76005 100644
--- a/math/onednn/distinfo
+++ b/math/onednn/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1637870317
-SHA256 (oneapi-src-oneDNN-v2.4.4_GH0.tar.gz) = 29ce33da3eaf48cbc39cfd9e9af0d7d00e256dcd84168b906df48fb75f5f844e
-SIZE (oneapi-src-oneDNN-v2.4.4_GH0.tar.gz) = 5800188
+TIMESTAMP = 1640073289
+SHA256 (oneapi-src-oneDNN-v2.5_GH0.tar.gz) = d7a47caeb28d2c67dc8fa0d0f338b11fbf25b473a608f04cfed913aea88815a9
+SIZE (oneapi-src-oneDNN-v2.5_GH0.tar.gz) = 5805400
diff --git a/math/onednn/files/patch-cmake_platform.cmake b/math/onednn/files/patch-cmake_platform.cmake
index ac31cbbdf369..390741db48ac 100644
--- a/math/onednn/files/patch-cmake_platform.cmake
+++ b/math/onednn/files/patch-cmake_platform.cmake
@@ -1,6 +1,6 @@
---- cmake/platform.cmake.orig 2021-06-29 20:12:52 UTC
+--- cmake/platform.cmake.orig 2021-12-07 19:00:25 UTC
+++ cmake/platform.cmake
-@@ -171,7 +171,7 @@ elseif(UNIX OR MINGW)
+@@ -175,7 +175,7 @@ elseif(UNIX OR MINGW)
set(DEF_ARCH_OPT_FLAGS "-O3")
endif()
# For native compilation tune for the host processor
@@ -9,7 +9,7 @@
append(DEF_ARCH_OPT_FLAGS "-mcpu=native")
endif()
elseif(DNNL_TARGET_ARCH STREQUAL "PPC64")
-@@ -179,7 +179,7 @@ elseif(UNIX OR MINGW)
+@@ -183,7 +183,7 @@ elseif(UNIX OR MINGW)
set(DEF_ARCH_OPT_FLAGS "-O3")
endif()
# For native compilation tune for the host processor
@@ -18,7 +18,7 @@
append(DEF_ARCH_OPT_FLAGS "-mcpu=native")
endif()
elseif(DNNL_TARGET_ARCH STREQUAL "S390X")
-@@ -187,10 +187,10 @@ elseif(UNIX OR MINGW)
+@@ -191,10 +191,10 @@ elseif(UNIX OR MINGW)
set(DEF_ARCH_OPT_FLAGS "-O3")
endif()
# For native compilation tune for the host processor
@@ -31,21 +31,30 @@
set(DEF_ARCH_OPT_FLAGS "-msse4.1")
endif()
# Clang cannot vectorize some loops with #pragma omp simd and gets
-@@ -262,7 +262,7 @@ elseif(UNIX OR MINGW)
- set(DEF_ARCH_OPT_FLAGS "-O3")
- endif()
- # For native compilation tune for the host processor
-- if (CMAKE_SYSTEM_PROCESSOR STREQUAL CMAKE_HOST_SYSTEM_PROCESSOR)
-+ if (FALSE AND CMAKE_SYSTEM_PROCESSOR STREQUAL CMAKE_HOST_SYSTEM_PROCESSOR)
- append(DEF_ARCH_OPT_FLAGS "-mcpu=native")
- endif()
+@@ -272,7 +272,7 @@ elseif(UNIX OR MINGW)
+ set(DEF_ARCH_OPT_FLAGS "-O3")
+ endif()
+ # For native compilation tune for the host processor
+- if (CMAKE_SYSTEM_PROCESSOR STREQUAL CMAKE_HOST_SYSTEM_PROCESSOR)
++ if (FALSE AND CMAKE_SYSTEM_PROCESSOR STREQUAL CMAKE_HOST_SYSTEM_PROCESSOR)
+ append(DEF_ARCH_OPT_FLAGS "-mcpu=native")
+ endif()
elseif(DNNL_TARGET_ARCH STREQUAL "PPC64")
-@@ -271,7 +271,7 @@ elseif(UNIX OR MINGW)
- endif()
- # In GCC, -ftree-vectorize is turned on under -O3 since 2007.
- # For native compilation tune for the host processor
-- if (CMAKE_SYSTEM_PROCESSOR STREQUAL CMAKE_HOST_SYSTEM_PROCESSOR)
-+ if (FALSE AND CMAKE_SYSTEM_PROCESSOR STREQUAL CMAKE_HOST_SYSTEM_PROCESSOR)
- append(DEF_ARCH_OPT_FLAGS "-mcpu=native")
- endif()
+@@ -281,7 +281,7 @@ elseif(UNIX OR MINGW)
+ endif()
+ # In GCC, -ftree-vectorize is turned on under -O3 since 2007.
+ # For native compilation tune for the host processor
+- if (CMAKE_SYSTEM_PROCESSOR STREQUAL CMAKE_HOST_SYSTEM_PROCESSOR)
++ if (FALSE AND CMAKE_SYSTEM_PROCESSOR STREQUAL CMAKE_HOST_SYSTEM_PROCESSOR)
+ append(DEF_ARCH_OPT_FLAGS "-mcpu=native")
+ endif()
elseif(DNNL_TARGET_ARCH STREQUAL "S390X")
+@@ -290,7 +290,7 @@ elseif(UNIX OR MINGW)
+ endif()
+ # In GCC, -ftree-vectorize is turned on under -O3 since 2007.
+ # For native compilation tune for the host processor
+- if (CMAKE_SYSTEM_PROCESSOR STREQUAL CMAKE_HOST_SYSTEM_PROCESSOR)
++ if (FALSE AND CMAKE_SYSTEM_PROCESSOR STREQUAL CMAKE_HOST_SYSTEM_PROCESSOR)
+ append(DEF_ARCH_OPT_FLAGS "-march=native")
+ endif()
+ elseif(DNNL_TARGET_ARCH STREQUAL "RV64")
diff --git a/math/onednn/pkg-plist b/math/onednn/pkg-plist
index 4ace68bc7bff..24bd772e4f67 100644
--- a/math/onednn/pkg-plist
+++ b/math/onednn/pkg-plist
@@ -12,13 +12,6 @@ include/dnnl_threadpool.hpp
include/dnnl_threadpool_iface.hpp
include/dnnl_types.h
include/dnnl_version.h
-include/mkldnn.h
-include/mkldnn.hpp
-include/mkldnn_config.h
-include/mkldnn_debug.h
-include/mkldnn_dnnl_mangling.h
-include/mkldnn_types.h
-include/mkldnn_version.h
include/oneapi/dnnl/dnnl.h
include/oneapi/dnnl/dnnl.hpp
include/oneapi/dnnl/dnnl_config.h
@@ -38,13 +31,6 @@ lib/cmake/dnnl/dnnl-config-version.cmake
lib/cmake/dnnl/dnnl-config.cmake
lib/cmake/dnnl/dnnl-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/dnnl/dnnl-targets.cmake
-lib/cmake/mkldnn/mkldnn-config-version.cmake
-lib/cmake/mkldnn/mkldnn-config.cmake
-lib/cmake/mkldnn/mkldnn-targets-%%CMAKE_BUILD_TYPE%%.cmake
-lib/cmake/mkldnn/mkldnn-targets.cmake
lib/libdnnl.so
lib/libdnnl.so.2
-lib/libdnnl.so.2.4
-lib/libmkldnn.so
-lib/libmkldnn.so.2
-lib/libmkldnn.so.2.4
+lib/libdnnl.so.2.5