aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2024-02-22 12:49:53 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2024-02-23 08:09:27 +0000
commit703b5c87d8d79c5751912a1ed3d75f5a09b0d98c (patch)
tree09218689acae8927c77b7daa5490293e2ca72955
parent7d42429970081e5a319d2f8f8f695c090331f05c (diff)
downloadports-703b5c87d8d79c5751912a1ed3d75f5a09b0d98c.tar.gz
ports-703b5c87d8d79c5751912a1ed3d75f5a09b0d98c.zip
graphics/glfw: Update to 3.3.10
-rw-r--r--graphics/glfw/Makefile7
-rw-r--r--graphics/glfw/distinfo6
-rw-r--r--graphics/glfw/files/patch-evdev-hack32
3 files changed, 7 insertions, 38 deletions
diff --git a/graphics/glfw/Makefile b/graphics/glfw/Makefile
index 21536ec16726..a5fcadac768b 100644
--- a/graphics/glfw/Makefile
+++ b/graphics/glfw/Makefile
@@ -1,7 +1,7 @@
PORTNAME= glfw
-DISTVERSION= 3.3.9
+DISTVERSION= 3.3.10
CATEGORIES= graphics
-MASTER_SITES= https://github.com/glfw/glfw/releases/download/${PORTVERSION}/
+MASTER_SITES= https://github.com/glfw/glfw/releases/download/${DISTVERSION}/
MAINTAINER= eduardo@FreeBSD.org
COMMENT= Portable framework for OpenGL development
@@ -28,7 +28,8 @@ OPTIONS_SINGLE= PLATFORM
OPTIONS_SINGLE_PLATFORM= WAYLAND X11
PLATFORM_DESC= Window creation platform
-WAYLAND_BUILD_DEPENDS= libxkbcommon>0:x11/libxkbcommon \
+WAYLAND_BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
+ libxkbcommon>0:x11/libxkbcommon \
wayland-protocols>=0:graphics/wayland-protocols
WAYLAND_LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
libwayland-egl.so:graphics/wayland
diff --git a/graphics/glfw/distinfo b/graphics/glfw/distinfo
index b10a7d9f02ac..f84fb88c5fb9 100644
--- a/graphics/glfw/distinfo
+++ b/graphics/glfw/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1702569312
-SHA256 (glfw-3.3.9.zip) = 55261410f8c3a9cc47ce8303468a90f40a653cd8f25fb968b12440624fb26d08
-SIZE (glfw-3.3.9.zip) = 1465859
+TIMESTAMP = 1708588237
+SHA256 (glfw-3.3.10.zip) = e8433ef817f7b8199aab4868390639701b6b26f535ec1a6598bcf82019d1bdb8
+SIZE (glfw-3.3.10.zip) = 1467690
diff --git a/graphics/glfw/files/patch-evdev-hack b/graphics/glfw/files/patch-evdev-hack
deleted file mode 100644
index 917c4d581824..000000000000
--- a/graphics/glfw/files/patch-evdev-hack
+++ /dev/null
@@ -1,32 +0,0 @@
-Fix build with WAYLAND
-https://github.com/glfw/glfw/issues/2445
-
---- src/wl_init.c.orig 2023-12-12 18:00:27 UTC
-+++ src/wl_init.c
-@@ -32,7 +32,11 @@
-
- #include <errno.h>
- #include <limits.h>
--#include <linux/input.h>
-+#if defined(__FreeBSD__)
-+ #include <dev/evdev/input.h>
-+#else
-+ #include <linux/input.h>
-+#endif
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
-
---- src/wl_window.c.orig 2023-12-12 18:00:27 UTC
-+++ src/wl_window.c
-@@ -43,6 +43,10 @@
- #include <signal.h>
- #include <time.h>
-
-+#if defined(__FreeBSD__)
-+ #include <dev/evdev/input-event-codes.h>
-+#endif
-+
- #define GLFW_BORDER_SIZE 4
- #define GLFW_CAPTION_HEIGHT 24
-