aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-09-07 19:49:41 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-09-07 19:49:41 +0000
commit7046a55fd8c78a3bf8c78c239a321985cdb6e3ad (patch)
tree44170eaab332d8a08ad941e3638a2e1e422229c8
parent78ba9cefd2a78753796f0a79d3906abee675f58d (diff)
downloadports-7046a55fd8c78a3bf8c78c239a321985cdb6e3ad.tar.gz
ports-7046a55fd8c78a3bf8c78c239a321985cdb6e3ad.zip
Introduce variable ICONV_PREFIX at Mk/Uses/iconv.mk. The default for
pre 100043 is ${LOCALBASE} and /usr otherwise. Convert all ports to new variable usage. Approved by: portmgr (bapt, implicit)
Notes
Notes: svn path=/head/; revision=326683
-rw-r--r--Mk/Uses/iconv.mk2
-rw-r--r--devel/apr1/Makefile2
-rw-r--r--devel/apr2/Makefile2
-rw-r--r--devel/git/Makefile4
-rw-r--r--irc/epic5/Makefile6
-rw-r--r--lang/gauche/Makefile2
-rw-r--r--net-mgmt/ettercap/Makefile3
-rw-r--r--net/ssltunnel-client/Makefile2
-rw-r--r--net/yaz/Makefile2
-rw-r--r--net/zebra-server/Makefile2
-rw-r--r--textproc/libxml2/Makefile2
-rw-r--r--textproc/py-libxml2/Makefile3
-rw-r--r--www/apache22/Makefile2
-rw-r--r--www/apache24/Makefile2
14 files changed, 20 insertions, 16 deletions
diff --git a/Mk/Uses/iconv.mk b/Mk/Uses/iconv.mk
index 9c115cb4982a..06f1e5620394 100644
--- a/Mk/Uses/iconv.mk
+++ b/Mk/Uses/iconv.mk
@@ -20,6 +20,7 @@ iconv_ARGS= lib
ICONV_CMD= ${LOCALBASE}/bin/iconv
ICONV_LIB= -liconv
+ICONV_PREFIX= ${LOCALBASE}
ICONV_CONFIGURE_ARG= --with-libiconv-prefix=${LOCALBASE}
ICONV_CONFIGURE_BASE= --with-libiconv=${LOCALBASE}
@@ -35,6 +36,7 @@ PATCH_DEPENDS+= ${ICONV_CMD}:${PORTSDIR}/converters/libiconv
ICONV_CMD= /usr/bin/iconv
ICONV_LIB=
+ICONV_PREFIX= /usr
ICONV_CONFIGURE_ARG=
ICONV_CONFIGURE_BASE=
diff --git a/devel/apr1/Makefile b/devel/apr1/Makefile
index a943a14647ff..fffd062cf18f 100644
--- a/devel/apr1/Makefile
+++ b/devel/apr1/Makefile
@@ -44,7 +44,7 @@ SHLIB_APU_MAJOR= 5
APR_CONF_ARGS= --with-installbuilddir=${DATADIR}/build-1
APU_CONF_ARGS= --with-apr=${APR_WRKDIR} \
--with-expat=${LOCALBASE} \
- --with-iconv=${LOCALBASE}
+ --with-iconv=${ICONV_PREFIX}
.include <bsd.port.options.mk>
diff --git a/devel/apr2/Makefile b/devel/apr2/Makefile
index ad3f6d9f7d58..7edd06b7d1ae 100644
--- a/devel/apr2/Makefile
+++ b/devel/apr2/Makefile
@@ -42,7 +42,7 @@ CONFIGURE_ENV= CC="${CC}"
CONFIGURE_ARGS= --with-installbuilddir=${DATADIR}/build-2 \
--with-expat=${LOCALBASE} \
- --with-iconv=${LOCALBASE}
+ --with-iconv=${ICONV_PREFIX}
WRKSRC= ${WRKDIR}/apr
diff --git a/devel/git/Makefile b/devel/git/Makefile
index ffedd0893cfe..bb26e800d127 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -257,8 +257,8 @@ PLIST_SUB+= PERLSUB="@comment "
.if ${PORT_OPTIONS:MICONV}
USES+= iconv
MAKE_ENV+= NEEDS_LIBICONV=yes \
- ICONVDIR=${LOCALBASE}
-CONFIGURE_ARGS+= --with-iconv=${LOCALBASE}
+ ICONVDIR=${ICONV_PREFIX}
+CONFIGURE_ARGS+= --with-iconv=${ICONV_PREFIX}
.else
MAKE_ENV+= NO_ICONV=1
.endif
diff --git a/irc/epic5/Makefile b/irc/epic5/Makefile
index 1b348374dc50..ba8ca2fd6ad7 100644
--- a/irc/epic5/Makefile
+++ b/irc/epic5/Makefile
@@ -29,6 +29,9 @@ OPTIONS_DEFINE= IPV6 TCL PERL SSL TERMCAP DOCS RUBY
OPTIONS_DEFAULT= TCL PERL SSL RUBY
TERMCAP_DESC= Refuse to use terminfo/ncurses
+CONFIGURE_ARGS+=--with-iconv=${ICONV_PREFIX}
+USES= iconv
+
.include <bsd.port.options.mk>
.if ! ${PORT_OPTIONS:MIPV6}
@@ -63,9 +66,6 @@ CONFIGURE_ARGS+= --without-ruby
CONFIGURE_ARGS+= --with-termcap
.endif
-CONFIGURE_ARGS+= --with-iconv=${LOCALBASE}
-USES= iconv
-
post-extract:
@${FIND} ${WRKDIR} -type d -name CVS | ${XARGS} ${RM} -rf
diff --git a/lang/gauche/Makefile b/lang/gauche/Makefile
index e4c28d9f77af..c14e03fe7f73 100644
--- a/lang/gauche/Makefile
+++ b/lang/gauche/Makefile
@@ -34,7 +34,7 @@ DATADIR?= ${PREFIX}/share/${PORTNAME}-0.9
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-tls=none \
- --with-iconv=${LOCALBASE}
+ --with-iconv=${ICONV_PREFIX}
PLIST_SUB= VERSION="${PORTVERSION}" \
TARGET="${CONFIGURE_TARGET}"
USES= iconv
diff --git a/net-mgmt/ettercap/Makefile b/net-mgmt/ettercap/Makefile
index aaad0698fe0b..16eaf1ea2ab1 100644
--- a/net-mgmt/ettercap/Makefile
+++ b/net-mgmt/ettercap/Makefile
@@ -51,7 +51,7 @@ CONFIGURE_ARGS+=--disable-gtk
.endif
.if ${PORT_OPTIONS:MUTF8}
-CONFIGURE_ARGS+=--with-iconv=${LOCALBASE}
+CONFIGURE_ARGS+=--with-iconv=${ICONV_PREFIX}
USES+= iconv
.endif
@@ -91,6 +91,7 @@ post-patch:
-e 's|test -f /usr/include/libnet\.h|${TRUE}|' \
-e 's|(LNETINC=).*|\1"`${LIBNET_CONFIG} --cflags`"|' \
-e 's|(LNETLIB=).*|\1"`${LIBNET_CONFIG} --libs`"|' \
+ -e '/ICONVLIB/s|-liconv|${ICONV_LIB}|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -E \
-e 's|(^pkgdatadir.+=).+|\1 ${DATADIR}|' \
diff --git a/net/ssltunnel-client/Makefile b/net/ssltunnel-client/Makefile
index 9f3526d3cf2f..fe2043c4fa91 100644
--- a/net/ssltunnel-client/Makefile
+++ b/net/ssltunnel-client/Makefile
@@ -17,7 +17,7 @@ COMMENT= PPP over SSL virtual private networking (client part)
LICENSE= BSD
-CONFIGURE_ARGS= --disable-server --with-iconv=${LOCALBASE}
+CONFIGURE_ARGS= --disable-server --with-iconv=${ICONV_PREFIX}
GNU_CONFIGURE= yes
USES= iconv
diff --git a/net/yaz/Makefile b/net/yaz/Makefile
index eede282906a7..457cf40b0141 100644
--- a/net/yaz/Makefile
+++ b/net/yaz/Makefile
@@ -18,7 +18,7 @@ USE_GNOME= libxml2 libxslt
USE_LDCONFIG= yes
CONFIGURE_ARGS+=--enable-shared --with-openssl=${OPENSSLBASE} \
- --with-iconv=${LOCALBASE} --with-xml2=${LOCALBASE} \
+ --with-iconv=${ICONV_PREFIX} --with-xml2=${LOCALBASE} \
--with-xslt=${LOCALBASE} --with-icu=${LOCALBASE} \
--enable-tcpd
diff --git a/net/zebra-server/Makefile b/net/zebra-server/Makefile
index b975963e799a..d26918c33f80 100644
--- a/net/zebra-server/Makefile
+++ b/net/zebra-server/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-yaz=${LOCALBASE}/bin \
--with-tclconfig=${TCL_LIBDIR} \
- --with-iconv=${LOCALBASE} --with-expat=${LOCALBASE}
+ --with-iconv=${ICONV_PREFIX} --with-expat=${LOCALBASE}
USES= iconv
USE_LDCONFIG= yes
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 7ee713651d37..b2b36c8ada89 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -20,7 +20,7 @@ USE_CSTD= gnu89
GNU_CONFIGURE= yes
USES= pathfix gmake iconv pkgconfig
USE_LDCONFIG= yes
-CONFIGURE_ARGS?=--with-iconv=${LOCALBASE} \
+CONFIGURE_ARGS?=--with-iconv=${ICONV_PREFIX} \
--with-html-dir=${PREFIX}/share/doc \
--with-html-subdir=${PORTNAME} \
--with-lzma=/usr \
diff --git a/textproc/py-libxml2/Makefile b/textproc/py-libxml2/Makefile
index 42fbf66ed23a..90d7977a7149 100644
--- a/textproc/py-libxml2/Makefile
+++ b/textproc/py-libxml2/Makefile
@@ -16,9 +16,10 @@ PLIST= ${.CURDIR}/pkg-plist
USE_GNOME+= libxml2
USE_PYTHON= -2.7
+USES= iconv
CPPFLAGS+= `${PYTHON_VERSION}-config --cflags`
LDFLAGS+= -L${LOCALBASE}/lib `${PYTHON_VERSION}-config --libs`
-CONFIGURE_ARGS= --with-iconv=${LOCALBASE} \
+CONFIGURE_ARGS= --with-iconv=${ICONV_PREFIX} \
--with-html-dir=${PREFIX}/share/doc \
--with-html-subdir=${PORTNAME} \
--with-python=${PYTHON_CMD}
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index 3ceb017f1f93..2f26cbaf32b0 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -65,7 +65,7 @@ CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} \
--with-perl=${PERL5} \
--with-port=${WITH_HTTP_PORT} \
--with-expat=${LOCALBASE} \
- --with-iconv=${LOCALBASE} \
+ --with-iconv=${ICONV_PREFIX} \
--enable-http \
--with-pcre=${LOCALBASE} \
--with-apr=${APR_CONFIG} \
diff --git a/www/apache24/Makefile b/www/apache24/Makefile
index 470d6659fa2e..e45cd39573c7 100644
--- a/www/apache24/Makefile
+++ b/www/apache24/Makefile
@@ -74,7 +74,7 @@ CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} \
--with-port=${WITH_HTTP_PORT} \
--with-sslport=${WITH_SSL_PORT} \
--with-expat=${LOCALBASE} \
- --with-iconv=${LOCALBASE} \
+ --with-iconv=${ICONV_PREFIX} \
--enable-http \
--with-pcre=${LOCALBASE} \
--with-apr=${APR_CONFIG} \