aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-06 11:01:12 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-06 11:01:12 +0000
commit704e9d63852990eaec6c58764f4949806640b70b (patch)
tree238ac470a82d6013f1b9d5dcec76f778b77e2bf3
parentdc587b2b2e08c2e26e0295e172e975ccbf7218b7 (diff)
downloadports-704e9d63852990eaec6c58764f4949806640b70b.tar.gz
ports-704e9d63852990eaec6c58764f4949806640b70b.zip
This module is used to work with .desktop files. The format of these files is
specified by the freedesktop "Desktp Entry" specification. WWW: http://search.cpan.org/dist/File-DesktopEntry/ PR: ports/98259 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe> (also ports/98273 by Alexander Botero-Lowry) Approved by: lawrance (mentor, implicit)
Notes
Notes: svn path=/head/; revision=164595
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-DesktopEntry/Makefile24
-rw-r--r--devel/p5-File-DesktopEntry/distinfo3
-rw-r--r--devel/p5-File-DesktopEntry/pkg-descr4
-rw-r--r--devel/p5-File-DesktopEntry/pkg-plist5
5 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5b6fd0ad33ca..d7d266cf94c0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -975,6 +975,7 @@
SUBDIR += p5-File-Cache
SUBDIR += p5-File-Cat
SUBDIR += p5-File-Copy-Recursive
+ SUBDIR += p5-File-DesktopEntry
SUBDIR += p5-File-DirSync
SUBDIR += p5-File-FTS
SUBDIR += p5-File-Find-Rule
diff --git a/devel/p5-File-DesktopEntry/Makefile b/devel/p5-File-DesktopEntry/Makefile
new file mode 100644
index 000000000000..6c3433ebd6af
--- /dev/null
+++ b/devel/p5-File-DesktopEntry/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-File-DesktopEntry
+# Date created: 2006-05-31
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-DesktopEntry
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/P/PA/PARDUS/${PORTNAME}
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Object to handle desktop files
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools
+
+PERL_CONFIGURE= yes
+
+MAN3= File::DesktopEntry.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-DesktopEntry/distinfo b/devel/p5-File-DesktopEntry/distinfo
new file mode 100644
index 000000000000..1bf1ef475719
--- /dev/null
+++ b/devel/p5-File-DesktopEntry/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-DesktopEntry-0.02.tar.gz) = 9c97efa062c04bcb86a0a6a3707355d1
+SHA256 (File-DesktopEntry-0.02.tar.gz) = f86aa04b61a9aa38b1c3e911b0708f94ddadf888978e0efb2f32f72b53ff7423
+SIZE (File-DesktopEntry-0.02.tar.gz) = 5397
diff --git a/devel/p5-File-DesktopEntry/pkg-descr b/devel/p5-File-DesktopEntry/pkg-descr
new file mode 100644
index 000000000000..80ccd0e6a406
--- /dev/null
+++ b/devel/p5-File-DesktopEntry/pkg-descr
@@ -0,0 +1,4 @@
+This module is used to work with .desktop files. The format of these files is
+specified by the freedesktop "Desktp Entry" specification.
+
+WWW: http://search.cpan.org/dist/File-DesktopEntry/
diff --git a/devel/p5-File-DesktopEntry/pkg-plist b/devel/p5-File-DesktopEntry/pkg-plist
new file mode 100644
index 000000000000..490a038666db
--- /dev/null
+++ b/devel/p5-File-DesktopEntry/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/File/DesktopEntry.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/DesktopEntry/.packlist
+@dirrmtry %%SITE_PERL%%/File
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/DesktopEntry
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File