aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2014-06-19 20:05:13 +0000
committerJason E. Hale <jhale@FreeBSD.org>2014-06-19 20:05:13 +0000
commit706d15c991fd722daaae9d14ff5fd6728b3af1f7 (patch)
treef04598b57270819f65a9ad0b00837b5afd6850ca
parente0832ab2bbb4bab58658c47d47718361fc652f8d (diff)
downloadports-706d15c991fd722daaae9d14ff5fd6728b3af1f7.tar.gz
ports-706d15c991fd722daaae9d14ff5fd6728b3af1f7.zip
- Support staging
- Add LICENSE (GPLv2) - Make COMMENT make more sense Approved by: portmgr (blanket approval)
Notes
Notes: svn path=/head/; revision=358462
-rw-r--r--misc/gtkfind/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/misc/gtkfind/Makefile b/misc/gtkfind/Makefile
index 327fb43bb3a1..421190ebdddd 100644
--- a/misc/gtkfind/Makefile
+++ b/misc/gtkfind/Makefile
@@ -9,7 +9,9 @@ MASTER_SITES= http://www.bayofrum.net/dist/${PORTNAME}/ \
http://www.purplehat.org/downloads/gtkfind/
MAINTAINER= perryh@pluto.rain.com
-COMMENT= The program to use to have to remember all the options to find(1)
+COMMENT= GTK front-end to find(1)
+
+LICENSE= GPLv2
BUILD_DEPENDS= appres:${PORTSDIR}/x11/appres \
xterm:${PORTSDIR}/x11/xterm
@@ -18,15 +20,14 @@ USES= gmake
USE_GNOME= gtk12
GNU_CONFIGURE= yes
-MAN1= gtkfind.1
-PLIST_FILES= bin/gtkfind
+PLIST_FILES= bin/gtkfind \
+ man/man1/gtkfind.1.gz
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e "s,-O2,${CFLAGS}," ${WRKSRC}/configure ${WRKSRC}/Makefile.in
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/gtkfind ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/gtkfind.1 ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/gtkfind ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/gtkfind.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.include <bsd.port.mk>