aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-05-21 02:35:33 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-05-21 02:35:33 +0000
commit70b403e4e4c36ce2ed6bbba7fcf4bef0bd151be2 (patch)
tree0e3971aeeb58a10fc3aa79bb1a7e684a1de40187
parent52616b30cbf4fbb88107f368c8b077a19ab28a6c (diff)
downloadports-70b403e4e4c36ce2ed6bbba7fcf4bef0bd151be2.tar.gz
ports-70b403e4e4c36ce2ed6bbba7fcf4bef0bd151be2.zip
Add py-arxiv 0.2.2
arxiv.py is a Python wrapper for the arXiv API (http://arxiv.org/help/api/index). arXiv is a project by the Cornell University Library that provides open access to 1,000,000+ articles in Physics, Mathematics, Computer Science, Quantitative Biology, Quantitative Finance, and Statistics. They have an API that uses ATOM feeds to serve simple database queries. Unfortunately, handling these ATOM requsts can be clumsy (especially given inconsistency in data between different result objects, even in the same query). This is where arxiv.py comes it: it constructs requests for arXiv and gets ATOM feeds via a simple handful of methods, and parses the results into an intuitive format. WWW: https://pypi.python.org/pypi/arxiv WWW: https://github.com/lukasschwab/arxiv.py
Notes
Notes: svn path=/head/; revision=470501
-rw-r--r--www/Makefile1
-rw-r--r--www/py-arxiv/Makefile22
-rw-r--r--www/py-arxiv/distinfo3
-rw-r--r--www/py-arxiv/pkg-descr16
4 files changed, 42 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 57640819552b..8f84c09b5bcc 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1503,6 +1503,7 @@
SUBDIR += py-albatross
SUBDIR += py-amf
SUBDIR += py-apachelog
+ SUBDIR += py-arxiv
SUBDIR += py-autobahn
SUBDIR += py-aws-requests-auth
SUBDIR += py-azure-common
diff --git a/www/py-arxiv/Makefile b/www/py-arxiv/Makefile
new file mode 100644
index 000000000000..246d25a08d50
--- /dev/null
+++ b/www/py-arxiv/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= arxiv
+PORTVERSION= 0.2.2
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python wrapper for the arXiv API
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>=0:textproc/py-feedparser@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${FLAVOR}
+
+NO_ARCH= yes
+USE_PYTHON= autoplist concurrent distutils
+USES= python
+
+.include <bsd.port.mk>
diff --git a/www/py-arxiv/distinfo b/www/py-arxiv/distinfo
new file mode 100644
index 000000000000..c4112c2029b1
--- /dev/null
+++ b/www/py-arxiv/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520970061
+SHA256 (arxiv-0.2.2.tar.gz) = 0e9e1700537adf3f5e2944bd8e1d6a66d737723aee6dbcfe16e5ec9e173f0879
+SIZE (arxiv-0.2.2.tar.gz) = 2279
diff --git a/www/py-arxiv/pkg-descr b/www/py-arxiv/pkg-descr
new file mode 100644
index 000000000000..e69868a4919a
--- /dev/null
+++ b/www/py-arxiv/pkg-descr
@@ -0,0 +1,16 @@
+arxiv.py is a Python wrapper for the arXiv API
+(http://arxiv.org/help/api/index).
+
+arXiv is a project by the Cornell University Library that provides open access
+to 1,000,000+ articles in Physics, Mathematics, Computer Science, Quantitative
+Biology, Quantitative Finance, and Statistics.
+
+They have an API that uses ATOM feeds to serve simple database queries.
+Unfortunately, handling these ATOM requsts can be clumsy (especially given
+inconsistency in data between different result objects, even in the same query).
+This is where arxiv.py comes it: it constructs requests for arXiv and gets ATOM
+feeds via a simple handful of methods, and parses the results into an intuitive
+format.
+
+WWW: https://pypi.python.org/pypi/arxiv
+WWW: https://github.com/lukasschwab/arxiv.py