aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 16:23:14 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 17:03:09 +0000
commit70c96b6e814bf366562234ba3eb24d483ab5c29d (patch)
tree46d6bf1d392ba0676c2bd462df2c9e25be0572f4
parentc5ebde2ab858e84a03fdc26b576aba65add8a0f3 (diff)
downloadports-70c96b6e814bf366562234ba3eb24d483ab5c29d.tar.gz
ports-70c96b6e814bf366562234ba3eb24d483ab5c29d.zip
net-mgmt/fastnetmon: Fix build with protobuf 22+
- While I'm here, use tab instead of space
-rw-r--r--net-mgmt/fastnetmon/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/net-mgmt/fastnetmon/Makefile b/net-mgmt/fastnetmon/Makefile
index e3817ed5b1b2..c14bb60fb938 100644
--- a/net-mgmt/fastnetmon/Makefile
+++ b/net-mgmt/fastnetmon/Makefile
@@ -25,8 +25,8 @@ LIB_DEPENDS= libboost_regex.so:devel/boost-libs \
libabsl_base.so:devel/abseil \
libhiredis.so:databases/hiredis
-USES= cmake compiler:c++11-lang pkgconfig localbase:ldflags ssl
-USE_CXXSTD= c++14
+USES= cmake compiler:c++17-lang pkgconfig localbase:ldflags ssl
+USE_CXXSTD= c++17
USE_GITHUB= yes
GH_ACCOUNT= pavel-odintsov
USE_RC_SUBR= ${PORTNAME}
@@ -39,8 +39,9 @@ CMAKE_INSTALL_PREFIX= ${PREFIX}
CMAKE_SOURCE_PATH= ${WRKSRC}/src
CFLAGS_i386= -march=i586
-CXXFLAGS += -DBOOST_STACKTRACE_GNU_SOURCE_NOT_REQUIRED \
- -D_GNU_SOURCE
+CXXFLAGS+= -DBOOST_STACKTRACE_GNU_SOURCE_NOT_REQUIRED \
+ -D_GNU_SOURCE
+LDFLAGS+= -labsl_log_internal_message -labsl_log_internal_nullguard
USERS= ${PORTNAME}
GROUPS= ${PORTNAME}