aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2018-02-25 22:15:18 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2018-02-25 22:15:18 +0000
commit70e8ba8740361354b61821d15067c9ab15f6a767 (patch)
tree5a63fcb2c601bf181e405a9395bec21550cf2482
parent1b9fb25aa548ddced53f5e57ce2031762fc7c1bb (diff)
downloadports-70e8ba8740361354b61821d15067c9ab15f6a767.tar.gz
ports-70e8ba8740361354b61821d15067c9ab15f6a767.zip
- Add NO_ARCH=yes to those octave-forge-* ports that don't install anything
compiled. Reported by: Yuri <yuri@rawbw.com>
Notes
Notes: svn path=/head/; revision=462979
-rw-r--r--math/octave-forge-actuarial/Makefile2
-rw-r--r--math/octave-forge-base/Makefile1
-rw-r--r--math/octave-forge-bim/Makefile2
-rw-r--r--math/octave-forge-bsltl/Makefile2
-rw-r--r--math/octave-forge-cgi/Makefile2
-rw-r--r--math/octave-forge-data-smoothing/Makefile2
-rw-r--r--math/octave-forge-dataframe/Makefile2
-rw-r--r--math/octave-forge-divand/Makefile2
-rw-r--r--math/octave-forge-doctest/Makefile2
-rw-r--r--math/octave-forge-financial/Makefile2
-rw-r--r--math/octave-forge-fpl/Makefile2
-rw-r--r--math/octave-forge-fuzzy-logic-toolkit/Makefile2
-rw-r--r--math/octave-forge-ga/Makefile2
-rw-r--r--math/octave-forge-generate_html/Makefile2
-rw-r--r--math/octave-forge-gnuplot/Makefile2
-rw-r--r--math/octave-forge-mvn/Makefile2
-rw-r--r--math/octave-forge-ncarray/Makefile2
-rw-r--r--math/octave-forge-nnet/Makefile2
-rw-r--r--math/octave-forge-optics/Makefile2
-rw-r--r--math/octave-forge-plot/Makefile2
-rw-r--r--math/octave-forge-queueing/Makefile2
-rw-r--r--math/octave-forge-secs1d/Makefile2
-rw-r--r--math/octave-forge-secs3d/Makefile2
-rw-r--r--math/octave-forge-splines/Makefile2
-rw-r--r--math/octave-forge-statistics/Makefile2
-rw-r--r--math/octave-forge-symbolic/Makefile2
26 files changed, 51 insertions, 0 deletions
diff --git a/math/octave-forge-actuarial/Makefile b/math/octave-forge-actuarial/Makefile
index 8fce471540df..7ceb764bd0fd 100644
--- a/math/octave-forge-actuarial/Makefile
+++ b/math/octave-forge-actuarial/Makefile
@@ -21,6 +21,8 @@ OCTSRC= ${OCTAVE_PKGNAME}
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-base/Makefile b/math/octave-forge-base/Makefile
index 51d21842c5d0..d672a17f40c6 100644
--- a/math/octave-forge-base/Makefile
+++ b/math/octave-forge-base/Makefile
@@ -22,6 +22,7 @@ USES= perl5
SUB_FILES= load-octave-pkg
SUB_LIST= PERL=${PERL}
NO_BUILD= yes
+NO_ARCH= yes
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/share/octave/tarballs
diff --git a/math/octave-forge-bim/Makefile b/math/octave-forge-bim/Makefile
index a2dbeda73b14..a2e9d7b08ce6 100644
--- a/math/octave-forge-bim/Makefile
+++ b/math/octave-forge-bim/Makefile
@@ -24,6 +24,8 @@ RUN_DEPENDS+= ${TARBALLS_DIR}/msh.tar.gz:math/octave-forge-msh
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-bsltl/Makefile b/math/octave-forge-bsltl/Makefile
index b0dc6e9afe57..585e3228677a 100644
--- a/math/octave-forge-bsltl/Makefile
+++ b/math/octave-forge-bsltl/Makefile
@@ -23,6 +23,8 @@ WRKSRC= ${WRKDIR}/${OCTSRC}/src
do-build:
${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-cgi/Makefile b/math/octave-forge-cgi/Makefile
index ab900b271705..e7e0700e03f1 100644
--- a/math/octave-forge-cgi/Makefile
+++ b/math/octave-forge-cgi/Makefile
@@ -23,6 +23,8 @@ WRKSRC= ${WRKDIR}/${OCTSRC}/src
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-data-smoothing/Makefile b/math/octave-forge-data-smoothing/Makefile
index 12fcbb6a8da8..d13651a4ee95 100644
--- a/math/octave-forge-data-smoothing/Makefile
+++ b/math/octave-forge-data-smoothing/Makefile
@@ -21,6 +21,8 @@ RUN_DEPENDS+= ${TARBALLS_DIR}/optim.tar.gz:math/octave-forge-optim
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-dataframe/Makefile b/math/octave-forge-dataframe/Makefile
index d70e0c4e1f1b..04f31b4f7f1b 100644
--- a/math/octave-forge-dataframe/Makefile
+++ b/math/octave-forge-dataframe/Makefile
@@ -21,6 +21,8 @@ OCTSRC= ${DISTNAME}
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-divand/Makefile b/math/octave-forge-divand/Makefile
index d43b686222ac..9231fee2e698 100644
--- a/math/octave-forge-divand/Makefile
+++ b/math/octave-forge-divand/Makefile
@@ -23,6 +23,8 @@ WRKSRC= ${WRKDIR}/${OCTSRC}/src
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-doctest/Makefile b/math/octave-forge-doctest/Makefile
index bfe501578c63..ee9e1dd283ca 100644
--- a/math/octave-forge-doctest/Makefile
+++ b/math/octave-forge-doctest/Makefile
@@ -22,6 +22,8 @@ WRKSRC= ${WRKDIR}/${OCTSRC}/src
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-financial/Makefile b/math/octave-forge-financial/Makefile
index 80d28c0825bb..679ad215402d 100644
--- a/math/octave-forge-financial/Makefile
+++ b/math/octave-forge-financial/Makefile
@@ -23,6 +23,8 @@ RUN_DEPENDS+= ${TARBALLS_DIR}/io.tar.gz:math/octave-forge-io
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-fpl/Makefile b/math/octave-forge-fpl/Makefile
index 4bd487b284ea..e9ef5ed03440 100644
--- a/math/octave-forge-fpl/Makefile
+++ b/math/octave-forge-fpl/Makefile
@@ -23,6 +23,8 @@ RUN_DEPENDS+= dx:graphics/opendx
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-fuzzy-logic-toolkit/Makefile b/math/octave-forge-fuzzy-logic-toolkit/Makefile
index 98d249156eb3..098b88c6c047 100644
--- a/math/octave-forge-fuzzy-logic-toolkit/Makefile
+++ b/math/octave-forge-fuzzy-logic-toolkit/Makefile
@@ -21,6 +21,8 @@ OCTSRC= ${OCTAVE_PKGNAME}
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-ga/Makefile b/math/octave-forge-ga/Makefile
index 2456b9e9e0f2..5e185323a9fa 100644
--- a/math/octave-forge-ga/Makefile
+++ b/math/octave-forge-ga/Makefile
@@ -21,6 +21,8 @@ OCTSRC= ${OCTAVE_PKGNAME}
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-generate_html/Makefile b/math/octave-forge-generate_html/Makefile
index c03942b6d640..9b606dfb5df9 100644
--- a/math/octave-forge-generate_html/Makefile
+++ b/math/octave-forge-generate_html/Makefile
@@ -21,6 +21,8 @@ OCTSRC= ${DISTNAME}
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-gnuplot/Makefile b/math/octave-forge-gnuplot/Makefile
index 7c3d9460d80b..79dc9c5a59c7 100644
--- a/math/octave-forge-gnuplot/Makefile
+++ b/math/octave-forge-gnuplot/Makefile
@@ -21,6 +21,8 @@ OCTSRC= ${OCTAVE_PKGNAME}
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-mvn/Makefile b/math/octave-forge-mvn/Makefile
index e264a3dc2bac..7f294dc45559 100644
--- a/math/octave-forge-mvn/Makefile
+++ b/math/octave-forge-mvn/Makefile
@@ -21,6 +21,8 @@ OCTSRC= ${OCTAVE_PKGNAME}
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-ncarray/Makefile b/math/octave-forge-ncarray/Makefile
index 331bc005efe2..c0b3acc20c66 100644
--- a/math/octave-forge-ncarray/Makefile
+++ b/math/octave-forge-ncarray/Makefile
@@ -26,6 +26,8 @@ RUN_DEPENDS+= ${TARBALLS_DIR}/statistics.tar.gz:math/octave-forge-statistics
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-nnet/Makefile b/math/octave-forge-nnet/Makefile
index 4566c5b77b40..e6c0d0be57e8 100644
--- a/math/octave-forge-nnet/Makefile
+++ b/math/octave-forge-nnet/Makefile
@@ -21,6 +21,8 @@ OCTSRC= ${OCTAVE_PKGNAME}
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-optics/Makefile b/math/octave-forge-optics/Makefile
index 9f238b60270c..52d4c7c5aca7 100644
--- a/math/octave-forge-optics/Makefile
+++ b/math/octave-forge-optics/Makefile
@@ -22,6 +22,8 @@ WRKSRC= ${WRKDIR}/${OCTSRC}/src
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-plot/Makefile b/math/octave-forge-plot/Makefile
index 6ef2964b1552..5c160c9107fa 100644
--- a/math/octave-forge-plot/Makefile
+++ b/math/octave-forge-plot/Makefile
@@ -21,6 +21,8 @@ OCTSRC= ${OCTAVE_PKGNAME}
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-queueing/Makefile b/math/octave-forge-queueing/Makefile
index db50b25dc87d..693d49f89b5b 100644
--- a/math/octave-forge-queueing/Makefile
+++ b/math/octave-forge-queueing/Makefile
@@ -21,6 +21,8 @@ OCTSRC= ${OCTAVE_PKGNAME}
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-secs1d/Makefile b/math/octave-forge-secs1d/Makefile
index 30d0188bd719..1fa5f2feb365 100644
--- a/math/octave-forge-secs1d/Makefile
+++ b/math/octave-forge-secs1d/Makefile
@@ -23,6 +23,8 @@ RUN_DEPENDS+= ${TARBALLS_DIR}/bim.tar.gz:math/octave-forge-bim
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-secs3d/Makefile b/math/octave-forge-secs3d/Makefile
index a09997f7ab08..941f50fd327c 100644
--- a/math/octave-forge-secs3d/Makefile
+++ b/math/octave-forge-secs3d/Makefile
@@ -24,6 +24,8 @@ RUN_DEPENDS+= ${TARBALLS_DIR}/bim.tar.gz:math/octave-forge-bim
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-splines/Makefile b/math/octave-forge-splines/Makefile
index 00cd42193e35..a22c5a623ac3 100644
--- a/math/octave-forge-splines/Makefile
+++ b/math/octave-forge-splines/Makefile
@@ -23,6 +23,8 @@ WRKSRC= ${WRKDIR}/${OCTSRC}/src
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-statistics/Makefile b/math/octave-forge-statistics/Makefile
index e0013ce21d91..dd82f2a581a6 100644
--- a/math/octave-forge-statistics/Makefile
+++ b/math/octave-forge-statistics/Makefile
@@ -20,6 +20,8 @@ RUN_DEPENDS+= ${TARBALLS_DIR}/io.tar.gz:math/octave-forge-io
do-build:
@${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
diff --git a/math/octave-forge-symbolic/Makefile b/math/octave-forge-symbolic/Makefile
index 42f60faeeb47..5e4c2d6f82d1 100644
--- a/math/octave-forge-symbolic/Makefile
+++ b/math/octave-forge-symbolic/Makefile
@@ -26,6 +26,8 @@ WRKSRC= ${WRKDIR}/${OCTSRC}/src
do-build:
${DO_NADA}
+NO_ARCH= yes
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}