aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-02-07 22:11:57 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-02-12 17:55:54 +0000
commit711fba0c7a832f99e111165c69c26acaa01127e9 (patch)
tree358e93f67b775ae3082acd135f5a529de85f578e
parentb28e464e75cf8be0cbb413220e00b2feba17f3fb (diff)
downloadports-711fba0c7a832f99e111165c69c26acaa01127e9.tar.gz
ports-711fba0c7a832f99e111165c69c26acaa01127e9.zip
net/mosh: fix build on powerpc*
ocb_internal.cc:138:10: warning: 'bswap32' macro redefined [-Wmacro-redefined] #define bswap32(x) \ ^ /usr/include/sys/endian.h:68:9: note: previous definition is here ^ ocb_internal.cc:142:26: error: static declaration of '__builtin_bswap64' follows non-static declaration static inline uint64_t bswap64(uint64_t x) { ^ /usr/include/sys/endian.h:69:20: note: expanded from macro 'bswap64' ^ /usr/include/sys/_endian.h:78:22: note: expanded from macro '__bswap64' ^ ocb_internal.cc:142:26: note: previous implicit declaration is here /usr/include/sys/endian.h:69:20: note: expanded from macro 'bswap64' ^ /usr/include/sys/_endian.h:78:22: note: expanded from macro '__bswap64' ^ 1 warning and 1 error generated.
-rw-r--r--net/mosh/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/mosh/Makefile b/net/mosh/Makefile
index 5a5e8e303d84..9b90ffaf1257 100644
--- a/net/mosh/Makefile
+++ b/net/mosh/Makefile
@@ -15,7 +15,7 @@ USE_PERL5= run
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-utempter --without-ncurses
CONFIGURE_ENV+= OpenSSL_CFLAGS="-I${OPENSSLINC}" OpenSSL_LIBS="-L${OPENSSLLIB} -lssl -lcrypto" \
- TINFO_CFLAGS="-I/usr/include"
+ TINFO_CFLAGS="-I/usr/include" ac_cv_have_decl_bswap64=yes
INSTALL_TARGET= install-strip
USE_CXXSTD= c++11